No sound on HP X360 spectre with i7 tiger lake

I have a HP x360 with a 11th gen core i7 tiger lake and 512gb nvme and 16gb ram. I can't get sound to work. I have tried every fix on the internet. Installing pulse audio, alsa mixer, reloading alsa, and many many other command line hacks and NOTHING works. I also have no brightness control. I can see the output on speaker test but no sound to speakers?? I have tried on another tiger lake laptop by a different brand and an i5 and still have had the same problems and this is for Zorin 15.3 and 16 core. Anny help to get this issue fixed would be greatly appreciated.

I suppose you've already checked this page:

Yes. Any google search results for fixes I have tried already!

I even contacted Zorin support and they don't have a fix. I have a theory that sound cards on Tiger lake chipsets are a problem in Linux unless it is a laptop made for linux like Dell xps developer edition, etc. Otherwise it seems sound is borked on all tiger lake laptops??

Have you tried sof-firmware?

1 Like

That is quite possible.
Those "Linux edition" laptops come with hardware which is chosen to be compatible with Linux.

Can you issue this command in terminal and paste the output?


I even did not know such thing existed.
Glad you pitched in :slight_smile:

You are both right on Target. There is a slew of bug reports currently standing for "no sound" on Tiger Lake chipsets.
It doesn't mean that all hope is lost... Just as Windows and mac both have plenty of standing bug reports on other issues.
Some users need to update the BIOS using a package built for Windows... Which is always loads of fun.
For others, some firmware fixes can work.
Some users that dual Boot have a workaround by booting windows first, then switching immediately to their Linux Distro. (Which shows it is a MotherBoard Issue).
It really is on the Tiger Lake:
They didn't bother to check, wanted to cut some costs and made some changes, leaving everyone else scrambling to sort out a way of adapting to those changes.

1 Like

If the machine is a newish one, BIOS update sometimes helps (but not always). I suppose the days of using DOS to update BIOS is over.

If OP no longer has Windows, it is possible to download legitimate Windows from MS and use it for a few days before the grace period expires.

I have updated bios to latest version. ispci is not found??

Sorry, my bad.

It was

By the way, I removed your "double posting" in the other thread.

This forum is managed by a handful of volunteers and double/multiple posting is considered to be a form of sabotage which could split our attention.

Please refrain from it in the future.

I apologize for double posting. Won't happen again.

1 Like

and your

This command will list the hardware info of your system which is needed for trouble shooting.

0000:00:00.0 Host bridge: Intel Corporation Device 9a14 (rev 01)
0000:00:02.0 VGA compatible controller: Intel Corporation Device 9a49 (rev 01)
0000:00:04.0 Signal processing controller: Intel Corporation Device 9a03 (rev 01)
0000:00:07.0 PCI bridge: Intel Corporation Device 9a23 (rev 01)
0000:00:07.1 PCI bridge: Intel Corporation Device 9a25 (rev 01)
0000:00:08.0 System peripheral: Intel Corporation Device 9a11 (rev 01)
0000:00:0d.0 USB controller: Intel Corporation Device 9a13 (rev 01)
0000:00:0d.2 USB controller: Intel Corporation Device 9a1b (rev 01)
0000:00:0e.0 RAID bus controller: Intel Corporation Volume Management Device NVMe RAID Controller
0000:00:12.0 Serial controller: Intel Corporation Device a0fc (rev 20)
0000:00:14.0 USB controller: Intel Corporation Device a0ed (rev 20)
0000:00:14.2 RAM memory: Intel Corporation Device a0ef (rev 20)
0000:00:14.3 Network controller: Intel Corporation Device a0f0 (rev 20)
0000:00:15.0 Serial bus controller [0c80]: Intel Corporation Device a0e8 (rev 20)
0000:00:15.1 Serial bus controller [0c80]: Intel Corporation Device a0e9 (rev 20)
0000:00:16.0 Communication controller: Intel Corporation Device a0e0 (rev 20)
0000:00:1c.0 PCI bridge: Intel Corporation Device a0bd (rev 20)
0000:00:1d.0 System peripheral: Intel Corporation Device 09ab
0000:00:1f.0 ISA bridge: Intel Corporation Device a082 (rev 20)
0000:00:1f.3 Multimedia audio controller: Intel Corporation Device a0c8 (rev 20)
0000:00:1f.4 SMBus: Intel Corporation Device a0a3 (rev 20)
0000:00:1f.5 Serial bus controller [0c80]: Intel Corporation Device a0a4 (rev 20)
0000:57:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader (rev 01)
10000:e0:1d.0 PCI bridge: Intel Corporation Device a0b0 (rev 20)
10000:e1:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd NVMe SSD Controller SM981/PM981/PM983

Everything above suggest onboard intel only, but I'd like to clarify: Are you using an Nvidia or AMD graphics card as well as the dedicated Intel graphics?

Does your sound show as "dummy output"? Or does it show properly, but no sound is forthcoming?

I have integrated XE graphics from intel only

It shows intel hda sound?

1 Like

This must be it:
Multimedia audio controller: Intel Corporation Device a0c8 (rev 20)

The suggested solution on that one is:

sudo nano /etc/default/grub


GRUB_CMDLINE_LINUX="quiet spash"

Then update the grub

sudo update-grub

reboot and test...

1 Like

I tried the suggested solution with no change in audio?