No sound on HP X360 spectre with i7 tiger lake

I won't deny I am worried about your case. You have tried a lot, already. I'm not the giving up type, though.
Did you see above about sof-firmware? Had you tried that yet?

It seems that I can't save the grub changes? I checked and when I rebooted it was back to "quiet splash"

also I am editing Grub_CMDLINE_LINUX_DEFAULT="
not GRUB_CMDLINE_LINUX="

GNU nano 4.8 /etc/default/grub Modified

If you change this file, run 'update-grub' afterwards to update

/boot/grub/grub.cfg.

For full documentation of the options in this file, see:

info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian
GRUB_CMDLINE_LINUX_DEFAULT="snd-intel-dspcfg.dsp_driver=1"
GRUB_CMDLINE_LINUX=""

Uncomment to enable BadRAM filtering, modify to suit your needs

This works with Linux (no patch required) and with any kernel that obtains

the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)

#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

Uncomment to disable graphical terminal (grub-pc only)

#GRUB_TERMINAL=console

Can you please (again)

sudo update-grub

then

sudo nano /etc/default/grub

and looking to ensure it looks the same as above- then reboot and check if grub has reverted.

Sure give me a minute

Okay I was able to save the changes after reboot but still no sound. :frowning:

1 Like

As much as it stings, can you please revert grub back to just "quiet splash" - it is best to always revert a change that does not work.

Then update grub.

Ok - sof-firmware- I think that is where we left off before... had you tried that (Or did I miss a post?)

I got an error when typing the command sof-firmware. Do I need to install sof-firmware?

1 Like

No problem about reverting

That answers my question:D

It is not in the Main Universe repository but is indendently developed. I do not know if this will work for you on your machine. It has helped many though and it is why I love Linux- Many indie devs out there see a problem and independently create a solution- rather than relying ont he MS pipeline.

As ignorant as I am I don't know how to install SOF? Do I need to enable a repository? Do I need to download a kernel? Thanks for all of your help!

Don't worry. Part of what is taking me so long is me reading the documentation to learn how to do it, too :expressionless:

2 Likes

Tech, can you do me a favor...

sudo apt install synaptic

Once installed, open it (enter pw) then on the top toolbar, click Search
Enter in linux-headers

It will be a lot of scrolling... But please look for the Highest mainline signed kernel available.
Might look like:
"linux-headers-5-.13.0-10100oem"

Sure. hold on

Okay I see the "linux-headers-5-.13.0-10100oem" but it is not highlighted or it doesn't have the box filled in so I think it is not installed

1 Like

To install sof-firmware:

git clone -b stable-v1.6 https://github.com/thesofproject/sof-bin.git

cd sof-bin

sudo ./go.sh

Reboot to test...

Ok, it wouldn't be installed, but I wanted to know what was available to you.

I tried to install sof-firmware and tried instructions on link but I do not know what I am doing?

Do I just enter the commands in the terminal?

Yes. Open terminal and then just copy and paste each line in as posted above.
git clone is the program being used to get the package. If needed, you can install git with sudo apt install git
cd command is Change Directory
.sh is the Installer script.