No sound on HP X360 spectre with i7 tiger lake

I installed git. I pasted the commands in terminal and got errors.

git clone -b stable-v1.6
fatal: You must specify a repository to clone.

usage: git clone [] [--] []

-v, --verbose         be more verbose
-q, --quiet           be more quiet
--progress            force progress reporting
-n, --no-checkout     don't create a checkout
--bare                create a bare repository
--mirror              create a mirror repository (implies bare)
-l, --local           to clone from a local repository
--no-hardlinks        don't use local hardlinks, always copy
-s, --shared          setup as shared repository
--recursive ...       alias of --recurse-submodules
                      initialize submodules in the clone
-j, --jobs <n>        number of submodules cloned in parallel
--template <template-directory>
                      directory from which templates will be used
--reference <repo>    reference repository
--reference-if-able <repo>
                      reference repository
--dissociate          use --reference only while cloning
-o, --origin <name>   use <name> instead of 'origin' to track upstream
-b, --branch <branch>
                      checkout <branch> instead of the remote's HEAD
-u, --upload-pack <path>
                      path to git-upload-pack on the remote
--depth <depth>       create a shallow clone of that depth
--shallow-since <time>
                      create a shallow clone since a specific time
--shallow-exclude <revision>
                      deepen history of shallow clone, excluding rev
--single-branch       clone only one branch, HEAD or --branch
--no-tags             don't clone any tags, and make later fetches not to follow them
--shallow-submodules  any cloned submodules will be shallow
--separate-git-dir <gitdir>
                      separate git dir from working tree
-c, --config <key=value>
                      set config inside the new repository
--server-option <server-specific>
                      option to transmit
-4, --ipv4            use IPv4 addresses only
-6, --ipv6            use IPv6 addresses only
--filter <args>       object filtering
--remote-submodules   any cloned submodules will use their remote-tracking branch
--sparse              initialize sparse-checkout file to include only files at root

sudo ./
sudo: ./ command not found

git clone -b stable-v1.6 GitHub - thesofproject/sof-bin: Firmware and topology binaries

Then change directory into it:

cd sof-bin

Then, from within the sof-bin directory, run the command to run the installer:

sudo ./

1 Like

bash: cd: sof-bin: No such file or directory

The first step works and then the second step I get the result above?

Ok, so this part is resolved?

No. I don't know what to do? How do I specify a directory? Sorry for my ignorance

Are you pasting this entire line into the terminal:

git clone -b stable-v1.6

yes I am

Can you please paste the line in, but do not hit enter- take a screenshot and post it?
I have tested this several times on my machine with no trouble. Maybe an image will help suss out the trouble.

Okay I just tried the process again and it worked and installed intel firmware


Good terminal training :smiley:

The awkward part will be... When it doesn't work... :expressionless:

1 Like

I have not rebooted but I tried to test sound and it is still not working. Are there other steps I need to take now that sof-firmware is installed?

For this - it is firmware so a complete reboot is necessary to test.

okay I will try now! Thanks again!

Just rebooted and still no sound.

Given the Tiger Lake troubles, the only thing I can think of is it MAY work with a higher kernel.
This is why I had you you check in Synaptic earlier.
The highest I see is 5.13 for the mainline signed. You may want to go with a mainline unsigned.

I was thinking the same thing earlier. Okay. Thanks again for all of your time and help! I really appreciate it!

Highest mainline:

Highest Stable:

Other possibilities: a different Distro...
For Example Devuan is a non-systemd O.S., not relying on Pulseaudio and the systemd module in the same manner. Many users have much less sound troubles on Devuan.

I will try it. Thank You!

1 Like