No sound on iMac

I installed Zorin OS 16 Core on my iMac. But unfortunately I have no sound. (It's my first time using any Linux. So I'm an absolute newbie in it.)

Here are the specification of my Mac.

iMac (21.5-inch, Late 2015), iMac 16,1
Processor: 1.6 GHz Dual-Core Intel Core i5
RAM: 8 GB 1867 MHz DDR3
Graphic Card: Intel HD Graphics 6000 1536 MB

When I let inxi -SMA run, the following information is shown:
Host: kanrei-iMac Kernel: 5.13.0-41-generic x86_64 bits: 64
Desktop: Gnome 3.38.4 Distro: Zorin OS 16.1
Type: Laptop System: Apple product: iMac16,1 v: 1.0
serial: <superuser/root required>
Mobo: Apple model: Mac-A369DDC4E67F1C45 v: iMac16,1
serial: <superuser/root required> UEFI: Apple v: 428.
date: 10/27/2021
Device-1: Intel Broadwell-U Audio driver: snd_hda_intel
Device-2: Intel Wildcat Point-LP High Definition Audio
driver: snd_hda_intel
Sound Server: ALSA v: k5.13.0-41-generic

I tried the following things, but nothing made a difference:
sudo alsa force-reload

sudo apt-get install --reinstall alsa-base pulseaudio
sudo alsa force-reload

  1. Using PulseAudio. I don't see anything here which would change anything.

  2. Using Alsamixer. I don't think it's anything wrong here. In the screenshots you can see, how it looked like when I started it and when I pressed F6 to select a sound card, how it looked there.

I have no problem with having sound in the MacOS. (I have Dual Boot)

Has anyone an idea what else I could try to get that problem fixed?

Try with these:

sudo gedit /etc/modprobe.d/modprobe.conf

A file will open, paste this line below, save and then reboot

options snd_hda_intel model=mb5

Please, send a screenshot of pulse in the configuration tab...
(Comment: nice theme!!)

When I try to do this, this message appears:
"(gedit:39890): Tepl-WARNING **: 12:26:26.004: GVfs metadata is not supported. Fallback to TeplMetadataManager. Either GVfs is not correctly installed or GVfs metadata are not supported on this platform. In the latter case, you should configure Tepl with --disable-gvfs-metadata."

What do I need to do now?

Here's the screenshot.

:3 And thanks the theme is Orchis.

in sound control like in above pic, if u can make built-in audio digital stereo(Hdmi) the default by click on icon(right green mark=set as fallback or default),test u can get sound?

Oh, when I look now at the HDMI Profile it has (unplugged) after it's name. Nothing changes when I click on that. When I try to click on the point where you said, it will go immediately away.

sorry, I can't understand what happened, u mean u get sound now, or still no sound?

Still no sound. I clicked on the green icon. But it didn't work. HDMI has now the word (unplugged) after its name.

I tried clicking through different profiles, but none made any difference.

go back and make the built-in audio analog stereo(speaker) the default by clicking on right green icon beside it.
then I think that link may help u:

Ok, here's how it looks like. HDMI is unplugged now.
Analog Stereo (Speaker) is clicked on the green icon.
I tried out this different profiles. (I made a screenshot to show, what options all exists.)

(I can't make screenshots with shortcuts, because I have no Prnt key. I use the screenshot app usually, but in this case, the options would have gone away, when I changed apps, so I have to make a photo. (I wanted to make shortcuts as I know them from Mac, but the keys are used already otherwise, so it didn't work either. (On Mac Screenshot is Shift alt 3))

Ok, I looked at the link.

What I tried is this:
systemctl --user restart pulseaudio
rm -r ~/.config/pulse
pulseaudio -k

This didn't work either.

2 posts were split to a new topic: Zorin OS 16 on iMac - cannot find sound controls

Have you checked the contents of /etc/modprobe.d/alsa-base.conf?

sudo nano /etc/modprobe.d/alsa-base.conf

Check if the line options snd-hda-intel model=imac27 is present and does not have a hashtag in front of it. If it is not present, add that line. If it is present with a hashtag, remove the hashtag.
Tap ctrl+x to exit, then the y key to say yes to save, then the enter key to complete the operation saving and exiting.

sudo reboot

and test...

Ok, I tried that now. But unfortunately still no sound.
The line options snd-hda-intel model=imac27 wasn't there, so I added it and rebooted. But nothing happened.
(Is it the right model? Just wondering, because I have the 21.5 inch iMac.)

A very good question - I am not Apple-smart...
I did try some searching to clarify the answer to the above and found this:

Tried other things, but they didn't work either. I also got the same error again as above, when I used the command gedit. But looking at the file now, I guess it did safe the text, since it stayed changed in there when I reopened the file.
Just wanted to add this here, to tell what I tried.

Tried what was described here: Adventures with Linux: Installing Ubuntu on a Panasonic Toughbook CF-31 - Bob Johnson's Computer Stuff, Inc.

So what they suggested was the following:

sudo gedit /usr/share/pulseaudio/alsa-mixer/paths/analog-output-speaker.conf
A text file called analog-output-speaker.conf will open up in a new window. In the text file, find this part:

[Element Headphone]
switch = off
volume = off

and change it to this:

[Element Headphone]
switch = off
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right

Next, in the same text file, find this part:

[Element Speaker]
required-any = any
switch = mute
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right

and change it to this:

[Element Speaker]
required-any = any
switch = mute
volume = off

Save and reboot.

Maybe I found the solution!
On second screenshot, select Digital Stereo (IEC958) Output + Analog stereo Input

Did this solve?

Unfortunately it doesn't make any difference. It shows sound moving, but no sound comes out. (I clicked through all profiles to see whether any of it would work.)