No sound output from the jack port on MacMini

Hi everyone,

I have recently installed Zorin OS 16 on my Mac Mini 2018 (v8,1).
Apart from the slow start-up (not critical) and audio output (important), everything work fine.

My USB headphone works well but not my speakers connected to the jack port.

When I look on the list of audio output devices, I can't see the jack. I have tried to use pavucontrol but same problem.

Here is some information from my system:

> lspci | grep -i audio
00:1f.3 Audio device: Intel Corporation Cannon Lake PCH cAVS (rev 10)
02:00.3 Multimedia audio controller: Apple Inc. Apple Audio Device (rev 01)
> cat /proc/asound/cards 
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0x81e10000 irq 90
 1 [S5             ]: USB-Audio - SteelSeries Arctis 5
                      SteelSeries SteelSeries Arctis 5 at usb-0000:00:14.0-5.1, full speed
 2 [Camera         ]: USB-Audio - Aukey-PC-LM1E Camera
                      Aukey-PC-LM1E Camera Aukey-PC-LM1E Camera at usb-0000:00:14.0-5.2, high speed
> cat /etc/modprobe.d/alsa-base.conf 
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2

Do you have any ideas on how I can overcome this problem?

Thanks

Hi and welcome to the forum :slight_smile:

I think our Alsa mixer specialist volunteer might have some idea:
@zabadabadoo

1 Like

OK. Lets give it a try.
In terminal, type alsamixer
Hit [F6] and check it has your sound card selected.
Then display "All" sound channels and post a screenshot here.

1 Like

Thanks for your time

Here is the sound cards:
Capture d’écran de 2021-11-08 16-58-15
"HDA Intel PCH" is for the HDMI sound output, I think.

And here is all sound channel view for HDA Intel PCH:
Capture d’écran de 2021-11-08 17-00-25

I do not post SteelSeries and Aukey channel, because this is surely not the problem. But if you need it, I can.

In bonus, here is a screenshot from Pavucontrol

All the present output channel works great.

1 Like

I don't see much for HDA Intel PCH.
So go ahead and post the whole screen screenshot when you select SteelSeries.

Is it not a built-in USB DAC in the microphone?

I think 3,5 inch jack is controlled by Intel HDA.

Here is

This is on a MacMini. As I said above, there are no sound channel sliders showing for HDA Intel PCH to play with.

All I can suggest is websearch "HDA Intel PCH Ubuntu 20.04"
One result: 12.10 - No sound with HDA Intel PCH - Ask Ubuntu

Or the last resort.

Price between 6 to 20 Euro.

1 Like

Tanks you all for your help.
Unfortunately, I did not find a solution.

As proposed by @FrenchPress, I will buy an adapter soon.

1 Like

I used to run Hackintosh and most tricky parts were
Sound card, WiFi module and GPU.

WiFi module and GPU are easily replaced but for Sound card, I always used USB DAC.

It is because Mac does not have an independent sound module like PCs. It is integrated in the Logic board.

So it seems natural to me that the easiest solution is USB DAC for your mac.

1 Like

It's ordered, thank you.

Bisou

2 Likes

When you get your new USB audio adapter and plug it in, go to the Gnome Extensions website.
https://extensions.gnome.org/extension/906/sound-output-device-chooser/

If this is your first time on that site, it will have a notification up at the top of the page that is asking you to install the Gnome Browser integration, please click the install link to install it.
Then, at the link I provided above, you will then see a toggle button show up on the right side of the page.

Please click the toggle button to install the extension, a popup will come up asking you to confirm, by all means, do confirm it.
Now your extension is installed, and it can be found on the right side of your taskbar.

This is an awesome extension, it allows you to easily select which audio device you want to output too quickly. Your going to need it.


1 Like

Thanks, but I have already installed Sound Switcher Indicator :slight_smile:
I use this one since years.

1 Like

Hi again,

I have another problem. With my USB sound card, when I'm powering off my computer, I have a big noise buzz.

Here my sound card Ugreen External Sound Card

To stop this, I have to unplug the USB sound card. This is really not practical in my case.

Have you ever encountered this issue ? Do I need to buy another one ?

It seems you are not the only one complaining about humming noise:

Leider nicht zu gebrauchen, nach dem einstecken kommt sofort ein starker Netzbrumm

UGreen makes good cables but I do not how good their other products are.
Among the above photo I posted, I think Soundblaster is most trustworthy.

If you got it from Amazon, return is easy.

1 Like

Thanks, I will try the Creative Sound Blaster.

I missed this one :sweat_smile:

Yeah, I have already asked for a return and received the return instructions :wink:
Vive la poste

It is Amazon's trick to place negative reviews in a less obvious place :wink:

I hope you will find SoundBlaster works better for your mac.
Funny, it says compatible with Windows 7 and 8. Nothing mentioned for Linux. But in reality, I've never seen an external DAC which is incompatible with Linux.

Whenever I shop for hardware for Linux, I try to put Linux in the search. The greatest compatibility, will always be those that state Linux is the title or description.


It depends. For USB DAC. I do no bother.
It is Windows which requires additional driver but not Linux. It is integrated in kernel.

Actually I found some claims for "Linux compatible" are not very trustworthy. I am sure UGreen is more reliable than other brand-less products. But the performance is another question which is what Salamafet experienced.

Luckily at French Amazon, there is a selection for return reason for "poor performance".

2 Likes