No sound, please help!

Hi, i just get Zorin Pro, all works fine execept the sound.
I have no sound.
I have check with the inside help of the OS. But i cannot resolve my problem.

In output i see : "fictive output" (just that, not choise)
I have a Huawai laptop.
Audio device : AMD/ATI Device 1637
Kernel driver in use : snd_hda_intel
Kernel modules : snd_hda_intel

Hope you can help me
THanks !

Could you paste the output of alsamixer?

1 Like

Carte : HD-Audio Generic
Puce : ATI R6xx HDMI

Then i have S/PDIF. S/PDIF 1. S/PDIF 2

In terminal enter alsamixer
Hit [F6] and select HD-Audio Generic, (assuming it is listed)
Then in alsamixer find all output channels showing [M] one by one and hit M key on each to unmute. Also increase level to maximum for each.

Post a screenshot of your alsamixer display. That may help us fault-find with you.

1 Like

I tried.
With F6 it show me my "fictive output" where i can level up and down the sound.
Tried to M also each. nothing change, still not working.

Some people are reluctant to view images on a third party website.
Please add images in your reply.
Click the "upload" tool that looks like a picture in the Reply window toolbar.

1 Like

What options do you see when you hit [F6]? Show a screenshot of that please.

EDIT: I wonder if your drivers are up-to-date.
In Software Updater, check source is set "Main Server" (not a local server), then check for additional drivers.

I was on a local (french) server, i switched to "Main server", checked for additional drivers, there was nothing more to add.

Still not working.

the only thing i can add is "code source", in the zoein software menu.
Should i try that ?

I see no screenshot of this. Does it show any dropdown menu of devices?

The screenshot i sent i what's happen when i hit F6, no dropdown menu, just what you see (this "fictive outpud" window volume bar)

well in english its "dummy output"

"Dummy Output" OK, we see occasional cases of that.
Websearch using AMD/ATI Device 1637 dummy output ubuntu 20.04" for your sound device gives:

Only suggestion I see is maybe try a later linux kernel. But using a later version kernel not tested by Zorin devs may or may work, but could give you other issues.

EDIT: Did you try this:

pulseaudio -k && sudo alsa force-reload

I see you have bought Pro. That gives you entitlement to support from Zorin devs. You could try an email to them, but please be patient for any reply as there are only two of them.

Press fn + f6

Yes that is exaclty my problem, i have the same computer, Huawei Matebook D16.

It's the first time i unstall a linux that i want to use everyday, this is why i bought pro, i tought i wouldn't have any problem... yes i will maybe try to contact the support. Don't feel like touching the kernel, i am a absolute noob.

DIdn't try your last suggestion, while playing with all my settings, i have desactivated the trackpad !..f... !.. and i don't have any mouse for now... so i cannot do anything anymore.

Thanks for your help.

so maybe my only chance is to unstall a linux not based on ubuntu ?

if you are dual booting, shut down windows completely and reboot