No sound to speakers after kernel update

Ah the mysteries of Sound output to laptop speakers (lack of) in Zorin Core have bitten me once again. As usual, this follows a linux kernel update via software updater. I always do a Settings>Sound>Speaker Test after the update boots and recently have been surprised that I can hear “front left” and “front right” being recited. That was the case yesterday, hence happy bunny.
But that was yesterday.

I did a cold boot into Zorin today, heard click (expected) then background hiss (unexpected) through the speakers whilst Zorin banner was displyed. Thinking something was amiss I did a Speaker Test. Silence.

Normally this anomoly can be fixed quickly by me sliding the volume control (part of Sound settings) back and forth frantically from 0 to 100% a few times. Nope, not today.

Then checked sliders on Alsamixer (terminal) for any Muted items. Nope.

Then booted the previous kernel, Speaker Test and volume control exercises then repeated. Nope.

Now to check the hardware. Booted Windows, Sound from speakers OK.

Booted Zorin again, Speaker Test and volume control exercises again. Yay!, get “front left” and “front right” again. Music to my ears.

I have since installed PulseAudio Volume Control as recommended by @AZorin here.

I uninstalled GNOME ALSA mixer at same time, as could not see the point as Alsamixer is available in terminal.

I am not expecting any help here as Sound issues like this have been discussed before and my conclusion is that under Linux/Ubuntu/Zorin Sound is an art (involves luck) and not a science.
Go on, disprove my hypothesis.

Zaba, have you checked PM’s recently?

Are you now on the 5.4.0-52 kernel?

@Aravisian. Yes and Yes.

A couple suggestions you probably already know…
You could try a force reload:

sudo alsa force-reload

Followed by a reboot and check sound.

Another is to backup or remove ~/.config/pulse and reboot.

1 Like

Thanks. @Aravisian. Just bookmarked that. :+1:

Does remove ~/.config/pulse mean you can actually run Zorin without Pulse Audio?

Here is why I am asking. The other day I was using that other Linux distro and was having some issue stopping a process when I spotted a ‘scary’ (what looked like on initial viewing) process:

rtkit-daemon

I then found this interesting thread on askubuntu but in particular the response with 8 votes (second one down):

No, upon reboot, a new default configuration is created to fill the gap.

Still getting random No Sound issues on startup.
Today did my usual checks via:

  1. Settings>Sound
  2. Pulse Audio Volume Control
  3. Alsamixer (terminal)

I found some Alsamixer sliders were set Mute. Nothing I had done.
Anyhow unmuted and reboot. Sound now back through speakers.
OS Update yesterday, but that was mainly to remove 5.4.0-58 kernel.
Any idea what is messing with Alsamixer? Unreliable sound is the one thing constantly annoying me with Zorin 15.3 Core.

Using Pulseaudio and Alsamixer together means that they can interfere with each other’s settings. Usually, Pulse interferes with Alsamixer.
My own opinion is to be rid of one and just use the other one. I use pulseaudio.

As to why both come with Ubuntu: Canonical. Pushing product. They claim that they got it sorted, then release an update and… yeah…

1 Like

Is there a way of displaying the boot sequence as it happens on the screen?
I would really like to know the event in the boot sequence that causes the click heard through the speakers, which ultimately results in no sound through them afterwards.

This is what I did to eventually fix my sound problem in Z15.3 Core, but I consider it more of a fluke of trial and error than a scientific experiment. See this other post by me: Dell Precision 5750 - No sound ( Dummy Output ) - #35 by zabadabadoo

Just saw this. Since... you just bumped the thread, I guess...

Edit grub.

sudo nano /etc/default/grub

Remove the "quiet" or all of it - remove "quiet splash" (Leave the quotes empty)

GRUB_CMDLINE_LINUX_DEFAULT=""

1 Like