No sounds, cant execute fix

Hey guys, i have the standard dummy output error probably because im lucky and i suspect ive got a voodoo combination of hardware that just doesnt work well with updates hence it seems like such a common issue.

Im running an ASUS Chromebook c523n and i had the audio working in ubuntu 20.04. Then it updated and when it restarted i had lost all GUI and was stuck in terminal so i reinstalled and followed this processs again.

It worked last time but this time with each distribution i tried every method failed as i wasnt able to install SOF-firmware. Given my terminal knowledge isnt great it was a blessing when the script just worked. After trying Mint, Manjaro, Pop.Os, every software install app returned File not supported. The script hadnt changed so im not sure how to install the SOF-firmware to get onto the next step of the fix.

Is anyone able to guide me through the install process given the script to install isnt working anymore.

Thanks in advance guys!

On a side note, being an older laptop i dont expect it to run any games but given how old diablo 2 is i was thinking of somehow trying to get that going one day. Has anyone ever had that game going on linux before?

1 Like

No guarantees but see if this article helps:

@LandscapingTrav Do you know which linux kernel it did work Ok on?

Cheers for the reply mate, this is the one im certain worked Ubuntu 20.04 LTS 64-bit x86 5.15 (HWE) but tried ithe same process again after a fresh install and update and whatever the combination of things were a week before to get it to work must have changed and i could no longer get past the ensure Sof-firmware step is installed.

My issue is i am unable to get the SOF-firmware installed as the script isnt working for whatever reason. If anyone is able to check out the directions for that firmware and guide me through what i need to copy paste in terminal suited to my computer that would be awesome . Then i can proceed with the next few steps and fingers crossed it still works.

Where is the script?
I saw your link which posts the following directions:

  1. Install your distro. I used Pop_OS! 22.04
  2. Ensure WiFi connected. Open a terminal
  3. Ensure latest updates installed:
  • run sudo apt update && sudo apt dist-upgrade -y
  1. Ensure SOF (Sound Open Firmware) firmware/blobs installed:
  • run sudo apt install -y firmware-sof-signed
  1. Download fixed topology file:
  • run curl -LO
  1. Unzip topology file:
  • run gunzip sof-apl-da7219.tplg.gz
  1. Copy topology file to required location:
  • run sudo cp sof-apl-da7219.tplg /lib/firmware/intel/sof-tplg/
  1. Create driver config options file:
  • run sudo nano /etc/modprobe.d/inteldsp.conf
  • copy/paste in the following lines (right-click and select paste)
    options snd-intel-dspcfg dsp_driver=3
    options snd-sof-pci fw_path="intel/sof"
  • save and exit via CTRL+O, Enter, CTRL+X
  1. reboot

When you say "it isn't working" can you please be more clear?
Details make a pretty big difference.
Instead of "it don't work", you might try:
"The installation attempt leads to a message that says there is no installation candidate."
"The package installed, but I still do not have sound."

1 Like

I run the script and nothing happens after the cursor wheel stops spinning, ive opened the script in the software install option and up pops the blue suit case software store and it says file not supported.

Where can we find this script?

I have a notebook with similar hardware..

Do you by chance have an essx8336 sound card?? I used firmware-sof-signed V1.7.1 to get it working, then updated - have to run some commands to bring it 'alive', then that's it.. took me a while to figure it out. I'll work on tracking down the link to the firmware that I used.

In the mean time: does sudo apt install firmware-sof-signed not install the driver??

Hey mate i checked lspci -v and this is what came up.

00:0e.0 Multimedia audio controller: Intel Corporation Celeron N3350/Pentium N4200/Atom E3900 Series Audio Cluster (rev 0b)
DeviceName: Multimedia audio controller
Subsystem: Intel Corporation Celeron N3350/Pentium N4200/Atom E3900 Series Audio Cluster
Flags: bus master, fast devsel, latency 0, IRQ 25
Memory at 91210000 (64-bit, non-prefetchable) [size=16K]
Memory at 91000000 (64-bit, non-prefetchable) [size=1M]
Kernel driver in use: snd_soc_skl
Kernel modules: snd_hda_intel, snd_soc_skl, snd_sof_pci_intel_apl

The script that worked last time is called and its located in the tar.gz inside this SOF-firmware package Release v2.2.6 · thesofproject/sof-bin · GitHub

1 Like

Did you chmod the to make executable? Should just be sudo ./ if so.

I right clicked on the when its all extracted and clicked the box to make it executable. Are they not the same thing or does going through the terminal give the script a different set of privileges to do more or something?

/home/liz/Downloads/sof-bin-v2.2.6 is where the is located.

They are the same thing.

Ah, thanks. I am looking at it, now.
Did you read the
It points out about signed packages. Do you have Secure Boot enabled in your BIOS / EFI settings?

I read the script and I do not see anything obvious that would make the script faulty or not work.
Can you open a terminal and change directory into the directory that contains the file

cd ~/Downloads/sof-bin-v2.2.6

and run the file using the terminal:


and see if the terminal prints out any errors.

1 Like

How would i check and disable secure boot if its enabled? ill give those commands a go now

Usually, you can get into BIOS settings with an F key like F2 or F10 - your computer should display the options upon boot.
Once in your BIOS settings, look for the Security Tab.

liz@liz-Babytiger:~/Downloads/sof-bin-v2.2.6$ ./
Usage example:
sudo ./ [v1.8.x/]v1.8

I try and match the format with
liz@liz-Babytiger:~/Downloads/sof-bin-v2.2.6$ ./ [v2.2.6/]v2.6
./ ERROR: [v2.2.6/sof-]v2.6 not found

Sorry im horrible with this stuff and thanks for your patience, im enjoying learning but damn compared to windows this stuff im sure has its perks once you figure it all out.

1 Like

Change directory into it

Then run

sudo ./

(it suggested you may need sudo in the terminal according to your paste).

1 Like

liz@liz-Babytiger:~$ cd ~/Downloads/sof-bin-v2.2.6
liz@liz-Babytiger:~/Downloads/sof-bin-v2.2.6$ sudo ./
[sudo] password for liz:
Usage example:
sudo ./ [v1.8.x/]v1.8
liz@liz-Babytiger:~/Downloads/sof-bin-v2.2.6$ sudo ./ [v1.8.x/]v1.8
./ ERROR: [v1.8.x/sof-]v1.8 not found
liz@liz-Babytiger:~/Downloads/sof-bin-v2.2.6$ sudo ./ [v2.2.6/]v2.2.6
./ ERROR: [v2.2.6/sof-]v2.2.6 not found
liz@liz-Babytiger:~/Downloads/sof-bin-v2.2.6$ sudo ./ [v2.2.6/]v2.2
./ ERROR: [v2.2.6/sof-]v2.2 not found