No Wi-Fi Adapter Found in Dell laptop

I already tried ZorinOS in a desktop PC, or those PCs that are like a tower... Never knew how to call them. I liked it and never had problems with it only me having skill issue understanding linux envirosment but I enjoyed it.

So the main situation I have is, I want to download Zorin OS 17 Core in a Dell laptop... The problem is that there's no wifi list appearing, instead, it shows a big wifi icon saying "No Wi-Fi Adapter Found". My laptop has wireless connection, it works perfectly fine on Windows, and I don't want to use an adapter, I just don't find the sense...

My Hardware Model is: Dell Inc. Latitude E5450
Processor: Intel Core i5-5300U
Graphics: Mesa Intel® HD Graphics 5500 (BDW GT2)

Now, making something clear here, I haven't fully installed Zorin OS in this laptop yet, I'm coming from Windows and I don't want to reinstall Windows again if the wireless connection in Zorin doesn't work with any solution. But, I will take the step anyways.

Other stuff I did before posting this, was enabling an option called "Wake on Lan/Wlan", after reading a solution in this forum. I tried all the options "Wake on Lan", "Wake on Wlan" and "Wake on Lan or Wlan". Those three options just made the WiFi option dissapear. But when I leave it disabled, the WiFi option comes back.

Can anyone help me? If I should change a setting in the installation or something else, I'm ready for the steps.

Welcome to the Forum!

Good, that You send the Picture with. When You look on the Picture, there are 2 Toggles. There are off. You have to turn them on.

You can Zorin install alongside Windows as a Dual Boot. I would recommend this to test it and get a Feeling for the System.

Hey, I saw you typing... So, I forgot to say that when I turn on the Wifi switch, it just inmediatly turns off again. And also, it doesn't looks very well in the image but it says that is unavailable...

This ''unavailable'' should be normal; I have that, too. How is it with the Wifi Switch in the Quick Settings in the bottom Corner? Does this work?

And another Thing: When You look in the Settings to the Bluetooth Tab: Stand there that the Airplane Mode is active? It should look like this:

One last Thing: Did You controled You BIOS if there is maybe the Wifi Module disabled?

I had a similar issue with a ~10 year old Dell 2-in-1 recently: the bluetooth chip and even the 3G mobile broadband card were recognised and working immediately, but Zorin couldn't see the WiFi card at all, but worked fine with USB WiFi dongles. Even command line tools to directly interrogate what hardware the linux kernel can see (even if not use) including lshw, lsusb, and lspci did not indicate anything regarding WiFi. Zorin's Software Updater tool also didn't list any additional / proprietary drivers.

You'll need to check the Dell website for the official drivers - if there's one for linux, great, if not download the Windows EXE file. Some directly give you the option to extract or install when running them on Windows and some do not - if not, sometimes you can open the EXE in 7zip to get the files out.

Look through the various TXT / INF / CFG files for references to the WiFi chipset. Dell have a habit of branding the drivers in their own name, but it will actually be made by Qualcom or Broadcom or someone else - look for their model codes, not the Dell ones. I found stuff like "Dell Wireless 1538" or "DW1538" or "Wireless WLAN BT 1538C", but it was actually Qualcom Atheros of some sort - I originally thought it was a QCA6234. After searching for Dell 1538 / QCA6234 drivers for linux online I found practically no results, only that the ath10k driver series in the linux kernel supports QCA6174. Not quite right.

I then went back into the driver files and found the reference AR6004 which is, again, technically already part of the linux kernel, but it's either incomplete or an updated version didn't get merged into mainline for some reason. The hw3.0 subfolder from this github repo copied into /lib/firmware/ath6k/AR6004 followed by a reboot did the trick for me.

Obligatory don't trust random drivers and binaries you find online, I won't be using this computer for anything important / personal so security on the device is not a big concern for me.

Unfortunately, even if you find all this and get the correct drivers, it won't work on the live environment because you have to reboot for the drivers to take effect.

Also, not sure if relevant to your laptop, but Windows has a feature called "fast startup" and some BIOS / UEFI have a matching "fast boot" setting, both of which can mess things up for running linux via live ISO or dualboot. A common symptom of this is hardware or driver issues, assuming linux even boots at all.

Whether your BIOS / UEFI has the matching option, and where to find it if so, you'll just have to poke around for it. I hate how every BIOS and UEFI is totally different and even use different names for the same features! Even within the same brand!

Hi Ponce. Sorry for late response. I will show you some images:

Quick Settings in the bottom corner:

Bluethoot surprisingly works. So in the other tab you asked me, the plane icon doesn't appear, instead, appears the available bluethoot devices to connect:

The last thing you asked me to check: I think the Wifi module is enabled... I mean, the only thing I found that was disabled was the "Wake on Lan, Wlan" etc. And after enabling that, the icon of wifi dissapeared like if my laptop only supports LAN cable, thing that isn't true...

1 Like

My BIOS have a "cascading" look, like a wiki page or a blog. Related to the Fastboot, I have three options: Minimal, Thorough and Auto. Is set in Thorough

Something similar to the Fastboot I think is the Secure Boot, thing that was already disabled.

The last thing I found that you haven't mentioned was the "Wireless Radio Control" that is currently disabled. It have 2 options that are multioptional: Control WLAN radio, and Control WWAN radio. Both are disabled by default. I don't really know if this is necessary

This is the correct setting. "Minimal" would be "fast boot enabled" and limits hardware during boot, while "Thorough" initialises everything properly.

Secure Boot is a different thing, and it depends on your machine and the version of linux you install as to whether you need to disable it or not. I've found booting from Ventoy USB sticks tends to need Secure Boot disabled, but most linux works with it enabled after installation.

You probably want those unticked / disabled. Your BIOS screen should provide an explanation when you select either option, like your screenshot is showing for Fastboot, and if you tick those "control" options then the machine will soft-disable the WiFi card when it detects a wired / Ethernet connection. It's a power-saving feature, but with how finicky the linux WiFi driver is for old Dell machines, using that feature feels like playing with fire; just another thing that can go wrong.

Have you booted into Windows to see if it has "Fast Startup" enabled, and to try extracting the driver files?

Not yet, but I will. The only thing that I'm lost. How was I had to extract the files...?

So, I think the Fast boot is already disabled in Windows. However, i can't be fully sure, since only appears in the Shutdown settings options that arent related like Sleep or Lock. So I found a command for CMD that disables that I think, doing: "powercfg /h off".

You'll need to check the Dell website for the official drivers - if there's one for linux, great, if not download the Windows installer file. Some directly give you the option to extract or install when running them on Windows and some do not - if not, sometimes you can open the installer in 7zip or WinRAR to get the files out (you may need to change the extension from .exe or .msi to .zip or .7z for that to work).

You may be able to find the driver that is currently installed on your Windows OS, by inspecting your WiFi adaptor in Device Manager, and looking into the files there for the model references. That saves trying to mess with extracting the installer file if it doesn't have an easy option to do so.

You can also use the DISM commands in Windows CMD or PowerShell to dump all your installed drivers into a more convenient single location (separate from where they're installed to no worry about breaking things if you accidentally edit or delete anything) and then hunt through them for the WiFi driver.

Ignore everything except Step 2 in that article, we only care about dumping the drivers not anything else about modifying the offline image.

If you don't have this option in the power settings in Control Panel (see previously linked article for full screenshots) then your Windows OS does not possess the feature, so it can't be enabled. At the very least, we've now ruled out any sort of fast boot / startup being the culprit for your WiFi issues!


I think there's are drivers for my device for Linux, but shows for Ubuntu. I mean, Zorin is based on it but I don't know if that really matters. I wilh give the link:

Oh, and I'm sorry for sending the link in spanish, is my main language and the page was set in it by default, and I forgot to check that, haha...

Other than the fact the details page for that Ubuntu driver package has "installation instructions" that assume you haven't even installed Ubuntu yet, which is incredible, they are designed for Ubuntu 14.04 which is very old.

There's a good chance it won't work out-of-the-box, especially any sort of automated installer script it includes, but the actual drivers inside should be okay, I think.


Looking inside the downloaded file, it actually contains a bunch of really old linux kernel files which is odd. The drivers might actually be in patched kernels which I feel should be illegal.

Though a manifest file references Atheros 9565. Looks like this should be part of ath9k and work automatically in linux since like 2015 - though that's what I thought about my own Dell WiFi drivers initially.

Could you post the output of these commands?

  1. lspci | grep -i network
  2. sudo lshw -C network
  3. rfkill list all

I didn't even notice, it redirected to the English version automatically! :joy:

Those commands you gave me also works for Live boot right?

I recently had a blackout lol

Yes, just open a Terminal and put type them in. They only output information, don't change any settings or mess with files, so nothing to worry about.

Alright. Give me like five minutes to boot in the live boot of Zorin, since I'm actually on Windows...

Another reference in the Dell Ubuntu driver package is Intel 7265 which should have been part of the kernel since 3.13 (Zorin will be using 5.x or 6.x by now) but it does seem fairly common for people to run into situations where it's disabled for silly reasons. This thread has 2 or 3 possible solutions you could try to run through:

  1. sudo apt install backport-iwlwifi-dkms
  2. "WIFI works again after disabling 802.11n. I added the option 11n_disable=1 to /etc/modprobe.d/iwlwifi.conf - now it looks like this:" (see thread for details)
  3. sudo apt-get remove --purge backport-iwlwifi-dkms followed by sudo modprobe iwlwifi

Disclaimer: I don't know if any of these will work without rebooting, so may not appear to work in a live environment even if they actually do resolve the driver issue.