No wifi after Kernel update

Hello everyone,

I'm on the last version of Zorin 16, on a HP Probook laptop. I upgraded the Kernel a few days ago (to 6.0.8-060008-generic) and now my wifi doesn't work anymore. I have a hardware wifi button on my laptop, but when I press it I just get the "airplane mode" icon.

With lshw I get this :
*-network NON-RÉCLAMÉ
description: Network controller
produit: BCM43228 802.11a/b/g/n
fabricant: Broadcom Inc. and subsidiaries
identifiant matériel: 0
information bus: pci@0000:02:00.0
version: 00
bits: 64 bits
horloge: 33MHz
fonctionnalités: pm msi pciexpress cap_list
configuration : latency=0
ressources : mémoire:e1100000-e1103fff

I tried a few solutions found on the Internet but no luck. If somebody could give me a hand it would be amazing !

What happens if you downgrade the kernel ?


You should downgrade the kernel to one that doesn't have any bugs in it. Using the latest and greatest on a system that wasn't designed for it yet, things like this will happen.


Was there a specific reason why you needed to do this?
Do you have newer hardware that does not work on the latest stable Zorin kernel?


Thanks for the answers ! I came back to my previous kernel (5.15.0-52-lowlatency) but still no wifi. Does anyone have another idea ?

Reload the driver... sort of like disabling and re-enabling the wifi card. Use the instructions here to find, remove and re add your wifi card.

1 Like

AHAHA IT WORKED! Thanks a lot.

lshw -class network actually didn't give me a driver id for the wireless card, so I used the GUI update manager instead. Deactivated the proprietary wifi driver, rebooted, activated it back, rebooted again, and boom, it works.


While I did highlight and type the wrong driver in my example, I'm glad everyone was able to look beyond my mistake and see the relevance in the help I was attempting to offer.

Forgive me for not noticing my farce both when creating the post and when it was pointed out to me.

I'm glad it could help so many.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.