No wifi -- Broadcom bcm43228

Why is a widely popular wifi card like BroadCom bcm43228 no longer supported?

16.2 is pretty disappointing.

Please connect using either working ethernet or using your phone as a hotspot.
Launch terminal and run:

sudo apt install firmware-b43-installer b43-fwcutter bcmwl-kernel-source

Reboot and test wifi.


For whatever reason, I always have issues using the bcmwl-kernel-source one - 15 Lite installed by default on one laptop, had to remove it and just use the others for b43.. might just be my stuff though lol

Thought that might useful to throw out if it still doesn't work.

1 Like

In this situation, it was easier to swap in an n6205 card that I knew would work, rather than go down a bunch of rabbit holes.

Why not just support Broadcom cards right out of the box? 16.2 is now a Big Fatty. Surely a few more drivers won't make any difference.

Out of curiosity, how would my laptop, with no wifi capability, have been able to detect my phone-turned-hotspot?


With the USB Cord.

Because Broadcom - as a company - is restrictive about their drivers being included in Open Source.
Broadcom considers their drivers Proprietary, so while a user is permitted to install them, a company is not.

1 Like

USB, or Bluetooth - either one. All my B43xx devices were installed through USB tether haha

Also, have you checked Additional Drivers through Software Updater? You'll need to insert your installer disk used to install Zorin; if you don't have internet.

Got it. Noted for future reference

There seem to be the necessary Broadcom drivers in previous versions of Zorin. I ran into this problem when upgrading from 12.4 to 16.2. Pretty sure this card worked under 12.4 right out of the gate.

AV -- I noticed in another thread that you own a Qualcomm Atheros AR9462 wifi/BT card. Were you ever able to get the Bluetooth function to work under any version of Zorin? From what I read, this seems some sort of Holy Grail.

Thanks, Fellas!

Who are you addressing here?
I do not have Qualcomm Atheros. It is Realtek for ethernet and Intel for wireless on my machine.

You, Aravisian. Sorry.

In this thread -- Wi-Fi not showing up at all -- you wrote:

Yes, I have Atheros AR9462.
Never had any problems.
It is strange. I wonder if the wifi card is actually having hardware failure.

That was a couple of years ago, looks like.


Oh... yeah. That was before my new computer.

As I remember, bluetooth worked fine out of the box. I never messed with it.
I had Avantree bluetooth headphones at that time.

Until my son broke them. :expressionless:

Bad Boy!

Do you remember what version of Zorin you were running at the time?

Do the Zorin Bros know the MediaHuman crowd? Trying to get them to preserve the download order of YT playlists and they don't seem inclined to tweak things that way.

You might get a kick out of this. Hard to believe she's 94 and, from what I can tell, still sort of at it.


Yes, I was on Zorin OS 16 at that time. Zorin OS 16 was released in August of 2021.

Now that's dedication.
I was living in Austin, TX at that time, too... huh...

Here she is rocking at Austin City Hall five years ago. Looking pretty fit, all things considered.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.