Wi-Fi not showing up at all

Today I turned on my computer and connected to the internet wirelessly as I always do, but then it just disconnected itself, I rebooted my laptop and it connected normally again, but it disconnected again, tried it again and again and the problem didn't solve... After trying to solve it myself with help from other forums now the "Enable Wi-Fi" option doesn't show up at all, I tried more forums to try and solve this by myself again, but nothing worked...

How do I get the Enable Wi-Fi option to show up again? Help please! Thanks.

Can you recall what steps you tried from the other help?
It may be that some of that needs to be undone.

Can you copy and paste over the terminal output of

sudo lshw -c network


I tried installing new drivers, but the installation always failed, I tried installing firmware-b43-installer, b43-fwcutter, broadcom and backports from what I remember.

Also, here is what it shows up when I try sudo lshw -c network:

       description: Ethernet interface
       product: RTL810xE PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: enp1s0
       version: 07
       serial: c0:3e:ba:3c:ed:5b
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 duplex=full firmware=rtl8106e-1_0.0.1 06/29/12 ip= latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:16 ioport:3000(size=256) memory:91400000-91400fff memory:91200000-91203fff
  *-network UNCLAIMED
       description: Network controller
       product: QCA9377 802.11ac Wireless Network Adapter
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 31
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: memory:91000000-911fffff

Is any of the below familiar?

sudo apt-get update
sudo apt-get install build-essential linux-headers-$(uname -r)
echo "options ath10k_core skip_otp=y" | sudo tee /etc/modprobe.d/ath10k_core.conf
wget https://www.kernel.org/pub/linux/kernel/projects/backports/2015/11/20/backports-20151120.tar.gz
tar zxvf backports-20151120.tar.gz
cd backports-20151120

make defconfig-wifi
sudo make install

git clone https://github.com/kvalo/ath10k-firmware.git
sudo cp -r ath10k-firmware/QCA9377 /lib/firmware/ath10k/
sudo cp /lib/firmware/ath10k/QCA9377/hw1.0/WLAN.TF.1.0/firmware-5.bin_WLAN.TF.1.0-00002-QCATFSWPZ-5 /lib/firmware/ath10k/QCA9377/hw1.0/firmware-5.bin

sudo reboot

I think you do not have a Broadcom card.
Those are wrong drivers you have tried to install.


Yep, that's one of the things I tried.

1 Like

I noticed after installing them, I also tried to install Qualcomm drivers but I got errors as well.


Tried it again just in case, everything goes fine until make defconfig-wifi
And this error shows up:

Generating local configuration database from kernel ...Kernel version parse failed!
Makefile:40: recipe for target 'defconfig-wifi' failed
make: *** [defconfig-wifi] Error 1

What about this guide?

I am sorry - this is one of those troubling cases of the manufacturing not bothering to provide drivers for what they consider Too Small a Market...


I get the same error... I think the only solution I have now is get one of those wireless USB things, thanks for the help though!

1 Like

Admittedly, that is what a lot of Linux users end up doing.
@FrenchPress usually has good suggestions on Wifi dongles.


All are tried and tested personally by me.


Wow I see! Thanks for the info, I'll be looking online to get one of those.


I've personally stayed well clear of RaLink dongles. I bought one for youngest PC that dual booted. The box said it was compatible with Linux but when you went online to view the manual it stated that it was compatible with kernel 2.16 - that's the equivalent of a hardware manufacturer of Windows hardware stating it will work with Windows XP! I'm surprised Atheros didn't work straight off as I still have a netgear W111 v.3 dongle that uses the Atheros chipset and works instantly. See if you can find one on eBay. Alternatively:



Yes, I have Atheros AR9462.
Never had any problems.
It is strange. I wonder if the wifi card is actually having hardware failure.


Yes, its having a failure to communicate. And I hate it when my hardware gets lost in the popcorn kernel's and fails to communicate.


That is a link to a USB dongle that will work for Linux. And since its not one of the super speed ones, it won't require a 3rd party driver to work on Linux, it should literally be plug and play.

1 Like

Interesting I have a usb dongle that I just ordered last week got it last night .... bought it after my last episode with Zorin not connecting ... thankfully the WiFi card was not the problem but as I already had a Linksys dongle for Win WUSB6300 and it doesn't work for Linux ... I bought one that would ....

Haven't tested it yet ... it has no name on it but nicely packaged and all in English that's a plus .... dual band

What ever you do be sure it can connect to Linux ... just like mice a lot of manufactures say there product is compatible with Linux but believe me they are not .... look at FrenchPress's collection her's are tried and tested ....

1 Like

Interesting as all the ones I have seen including the one I just bought say that .... :sob: :sob: :sob: .... very disappointing .... thanks for the info

I do not think that can be a problem.
Windows XP compatible hardware is very often compatible with the later Windows versions unless it requires a special driver for it. Windows are improving in that regard since Windows 10 - more drivers are already included within the OS.

As for Linux, my understanding is that anything compatible with kernel 2.16 should be also compatible with the later kernels.

A couple of Ralink USB dongles I have are all Linux compatible.

I think you do not have to worry about this reference to the older kernel. It means that it is compatible with kernel 2.16 and up. I've never seen Linux kernel dropped a support for the old WiFi chipsets. One of the reasons why Linux can run on the machines older than 10 years or more.


Just was able to get my phone hooked back up to KDE Connect .... file went missing .... LOL ... anyway here is a picture of the dongle I was talking about .... 600 Mbps and 5 GHz & 2.4 GHz