No wifi icon in taskbar Zorin 16 Core

I found this thread and I also have the same problem: I can't see the wifi icon on the lower right part of the laptop nor the wifi settings; just "Network" and "Bluetooth".

Today, I took the leap of faith to wipeout my Windows 10 OS laptop to Zorin Core OS 16. The wifi internet was working smoothly.

My laptop does not have a ethernet cable port.

I followed each step in this thread and would not get the wifi icon to appear.

Cry Reaction GIF by SpongeBob SquarePants


@samal4 can you please open a terminal and run

lshw -c network

... and paste the results here?


First of all, I would like to wish you, your family, and all the families of the Zorin community a happy Thanksgiving.

I'm typing from my Windows Desktop and typing what I see on the Zorin OS Core 16 laptop and this is the output from the terminal:

ramon@ramon-VivoBook-ASUS-Laptop-E410MA-E410MA:~/Desktop$ lshw -c network
WARNING: you should run this program as super-user.
*- network UNCLAIMED
description: Network controller
product: RTL8821CE 802.11ac PCIe Wireless Network Adapter
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:02:00.0
version: 00
width: 64 bits
clock: 33 MHz
capabilities: cap_list
configuration: latency=0
resources: ioport:e000(size=256) memory: a1100000-a110ffff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

1 Like

That's the part we need...

Ensure that Secure Boot is Disabled in your EFI settings if you are not dual-booting Zorin and Windows.
In terminal, please install:

sudo apt install rtl8821ce-dkms

Reboot and test and happy thanksgiving to you, as well.

1 Like

Sorry, but what is "EFI settings"? Where do I find them?

I apologize that this is my first time using Linux OS. I hope to master it in time.

Usually by tapping F2 at the Motherboard splash screen.
You can search the web with your computer manufacturer and model and BIOS settings
"your computer manufacturer and model disable secure boot"

1 Like

After disabling secure boot in the EFI settings, and typing sudo apt install rtl8821ce-dkms in the terminal, these are the following output:

ramon@ramon-VivoBook-ASUS-Laptop-E410MA-E410MA:~/Desktop$ sudo apt install rtl8821c3-dkms
[sudo] password for ramon:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package rtl8821ce-dkms

Is there a way to download rtl8821ce-dkms package on a flashdrive from a windows desktop and upload the package to the Zorin OS laptop? Theoretically, the terminal should find the package and install it there, or will it ever install from the flashdrive?

1 Like

By the way, I found this....

The thread is old so it might not work..


On mine, I have a different result.

[sudo] password for mech-1:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
libappimage0 libsquashfuse0
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
The following NEW packages will be installed:
dkms rtl8821ce-dkms
0 upgraded, 2 newly installed, 0 to remove and 1 not upgraded.
Need to get 2,264 kB of archives.
After this operation, 25.5 MB of additional disk space will be used.
Do you want to continue? [Y/n]

Which version of Zorin OS are you using (it's not listed in your profile)?

In Software & Updates is your "download from" set to Main Server (It should be)?

1 Like

According to the laptop, which I'm running Zorin, it says:

OS Name                Zorin OS 16
OS Type                64-bit
Windowing System       X11

In Software & Updates the default "download from" was set to Server for United States . Hence, I changed it to Main server , however I have no connection to internet which I'm trying to solve.

I read the thread and its a solution for deleting the wifi icon by accident, but when I installed Zorin Core 16, the wifi icon did not appear.

I would to know if downloading a rtl8821ce-dkms package is possible in a flashdrive and install the package from there.

You can't connect to the internet? I thought that only the button did not appear. In that case you need to turn on WIFI from the settings app to see the WIFI button in the taskbar.

Yeah... that... that would be an issue...

Here is the package as a .deb self installer:

You can download it on Windows, transfer to a USB, then transfer to Zorin and double click to install it.


For the past 2 hours, the package .deb self installer have been "Pending Installation"... Wowzers! So when installation?

Animated GIF

That is strange... Can you try this one?
I just tried it and it downloaded the file within seconds:

Same result, stopped at "pending download".

I am thankful for @Aravisian and @Elegant_Emperor for helping me out. Even though this ASUS laptop is a problem, I decided to purchase a much more powerful laptop.

Seriously, the ASUS I have, has an x86 chip clocking speed at 1.18 GHz.

I'm looking into System76. However, I would like to know which laptop setup is beneficial to run the latest Zorin version.

Again, thank you for your support!

Beer Salute GIF


You can temporarily connect one of those to test if WiFi icon will appear:

Almost all 150bps version will work OOB with Linux.
Least expensive one was something like 5 Euro.


Quad core or better, at least 8gb ram, drive is personal choice since anything over 60gb is easily obtainable at a reasonable cost. Graphics is also a choice... have you looked on the Zorin website for your next laptop? They sell laptops with zorin preinstalled if you want to go that route.