Wifi icon missing and not able to connect

Hope this helps for you

Hmm, the wifi key on the function keys is toggling the airplane mode

I could not find the find the rc.local file. I searched for it but couldn't find it.

So the issue stopped, then returned?
What happens if you run sudo systemctl restart networking in terminal?

Here is the output of sudo systemctl restart networking

jeslin@jeslin-Satellite-L510:~$ sudo systemctl restart networking
[sudo] password for jeslin:       
Failed to restart networking.service: Unit networking.service not found.
1 Like

Maybe it's:

sudo systemctl restart NetworkManager

is it supposed to show nothing after I enter my password?

jeslin@jeslin-Satellite-L510:~$ sudo systemctl restart NetworkManager
[sudo] password for jeslin:       

If it works, yes.
It will only give a message if something went wrong.

What this shows is that the network manager is working... If your icon vanishes and it drops out - then try that command.

1 Like

Thanks a lot. Now the wifi icon is visible :grinning:

19 posts were split to a new topic: Foray into XFCE on Zorin OS 16 Core

A post was merged into an existing topic: Foray into XFCE on Zorin OS 16 Core

Guys, it's back. This thing is even on xfce.

1 Like

I tried this one but no use.

This clarifies it is not desktop related...
What is your output if this terminal command, again?

sudo lshw -C network

1 Like
jeslin@jeslin-Satellite-L510:~$ sudo lshw -C network
[sudo] password for jeslin:       
       description: Ethernet interface
       product: RTL810xE PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: enp2s0
       version: 02
       serial: 00:1e:33:f9:e0:4c
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=5.11.0-36-generic latency=0 link=no multicast=yes port=twisted pair
       resources: irq:16 ioport:2000(size=256) memory:d0410000-d0410fff memory:d0400000-d040ffff memory:d3600000-d361ffff
       description: Ethernet interface
       physical id: 2
       bus info: usb@2:3
       logical name: usb0
       serial: a2:3c:ce:3b:6f:a6
       capabilities: ethernet physical
       configuration: broadcast=yes driver=rndis_host driverversion=5.11.0-36-generic firmware=RNDIS device ip= link=yes multicast=yes

Can you try this driver for it?

Install instructions included in the link.

Well now most of the options in the menu are unclickable.

1 Like

That shows as the correct driver for your device;

Have you restarted the network manager?

Restarted network manager, but did not work. Restarting the laptop gave the problem a punch on it's face and knocked him off :facepunch: (I just mean that it solved the issue). Now I feel like there are more options in the menu.


A post was split to a new topic: No wifi icon in taskbar Zorin 16 Core