Wifi icon missing and not able to connect

I tried this one but no use.

This clarifies it is not desktop related...
What is your output if this terminal command, again?

sudo lshw -C network

1 Like
jeslin@jeslin-Satellite-L510:~$ sudo lshw -C network
[sudo] password for jeslin:       
  *-network                 
       description: Ethernet interface
       product: RTL810xE PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: enp2s0
       version: 02
       serial: 00:1e:33:f9:e0:4c
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=5.11.0-36-generic latency=0 link=no multicast=yes port=twisted pair
       resources: irq:16 ioport:2000(size=256) memory:d0410000-d0410fff memory:d0400000-d040ffff memory:d3600000-d361ffff
  *-network
       description: Ethernet interface
       physical id: 2
       bus info: usb@2:3
       logical name: usb0
       serial: a2:3c:ce:3b:6f:a6
       capabilities: ethernet physical
       configuration: broadcast=yes driver=rndis_host driverversion=5.11.0-36-generic firmware=RNDIS device ip=192.168.42.67 link=yes multicast=yes

Can you try this driver for it?

Install instructions included in the link.

Well now most of the options in the menu are unclickable.

1 Like

That shows as the correct driver for your device;

Have you restarted the network manager?

Restarted network manager, but did not work. Restarting the laptop gave the problem a punch on it's face and knocked him off :facepunch: (I just mean that it solved the issue). Now I feel like there are more options in the menu.

3 Likes

A post was split to a new topic: No wifi icon in taskbar Zorin 16 Core