Nordvpn connection

So i have purchased NordVPN from nordvpn.com. Now i am trying to connect to it on Zorin. it worked just fine on windows. With Zorin, I have installed both packages from NordVPN.

And then I try to log in thru the terminal with the following commands,

nordvpn login
give a link i click it and log in, and it says I'm in.
nordvpn connect is the next command,
when i type that, i get an error saying that I am not logged in.

I have reached out to nordvpn support, and they told me to do the following command.
nordvpn login --callback
try it and then i get
image

Does anyone else have this issue?

The .rpm package is for a different package management system. You need only the .deb package.

I am not sure on the rest of that...

I tried that one. When I go thru the terminal to login like it said online.
said the
nordvpn login

and it sends me a link, i copy and paste it and click on it, and still takes me to the same page. I log in, and the webpage says great you are logged in, click continue. I do that, and at the same time I go back to the terminal and type

nordvpn connect

and that is when i get the error of you are not logged in.
so the

nordvpn login --callback

is what nordvpn support gave me to try to get it working and when i type that in then i get the second error.

Is UFW Firewall enabled?

What is that?

I have tried it at different locations, even thru my personal hotspot and getting the same result.

Are you using Zorin OS Lite or Zorin OS Core?

I am using Zorin OS Core 16.1

Or you can navigate to Settings > Network and see the Configure Firewall Button.

Okay i found that. it was not on, now it is on.

I would recommend keeping it off for now, as the Firewall can interfere with NordVPN. As you are trying to configure NordVPN, the less complication or interference, the better.

Has NordVPN responded to your report about the callback giving the URL error?

Okay.

No they have not.

Try this .... I use Nord and am on it now ..... nordvpn connect US ..... or choose another country by typing in after connect ..... use space and then.... Australia ..... or Switzerland or Greece or any other country .....

See if you can connect to any country you choose ..... you can also type nordvpn in the terminal to see a very short list of various commands ....

Type nordvpn account ..... to see your account information ..... if nothing there than you might have done something wrong in setting up Nord ....

Just for kicks I typed in the command Nord support gave you but I got something just a little different .....

mike@mike-ROG-Strix-G731GT-G731GT:~$ nordvpn login --callback
expected a url
mike@mike-ROG-Strix-G731GT-G731GT:~$

on this command that support gave me it was supposed to have at the end.

1 Like

I tried it again, and still getting the same result. here is the terminal with the commands and what i see.

I even uninstalled the .dep app and reinstalled it and still nothing.

1 Like

You may try scrolling down to Advanced and browsing to see if Configuration files need correction:
https://vpntesting.com/reviews/nordvpn/nordvpn-failed-to-connect

2 Likes

Figured it out. It was an issue with the MFA app that i set it. I turned it off and tried the command from nordvpn support.

nordvpn login --legacy

and it worked. The legacy is where you can log in typing your login options thru the terminal.
after i disabled the MFA. turned it back on and it works.

3 Likes