Not allowed icon keeps flashing when earphones are plugged

whenever I plug wired headphones, not allowed sign icon keeps flashing on the screen. it also keeps unpausing any media which is paused.

I had the same problem a year back with manjaro linux as well, at that time I didn't know that it is caused by plugging in earphones. I switched to zorin 16 at that time but after updating, same problem appeared in zorin 16 too. so up untill now I have been using zorin 16 without updating even once. now that I have installed zorin 17, the same problem appeared again.

now I know that the problem is caused by plugging in earphones. So I have surfed other forums(ubuntu, manjaro, garuda) as well. and like me, many are facing the same problem, so it not a hardware issue and it is still unsolved.

any ideas?

What type of earphones and how plugged in i.e. 3.5mm jack or USB?
Under Zorin>Settings>Sound> what do you see when you plug in and later unplug?

I have a 3.5mm audio jack.
I have used multiple earphones but it is the same in all.
when plugged in, I see headphones -built in audio
when not plugged, i see speakers - built in audio.

I noticed that while the sound settings are open (only sound settings, not any other settings tab), it stops flashing.

so I am able to stop it by just letting that sound settings window be open in background. but sure isn't the solution.

Open terminal and type alsamixer.
Check output sound channels are unmuted. Select channel and hit "M" to unmute any and increaase volume slider.
Check the [Auto Mute] setting. Try change to that, to see if any effect.

this alsamixer is new to me. i have taken screenshots of the window. also I noticed that once I mute headphone channel it won't unmute untill I increase or decrease the volume with my keyboard.

The stack of arrows on the right edge of your screenshot indicates more channels that are hidden. Can you expand your window to show the hidden channels to the right, then post another screenshot of all output channels.

Also in alsamixer If you hit F6 are other soundcards listed?

What is effect if you unmute the [S/PDIF] channel?

i have tried all s/pdif combination settings. it seems it do nothing.
from other forums I have gathered that it is related to gnome.

Have you tried unmuting [Speaker]?

Separately try different settings of [Auto-Mute]

Have a play around with alsamixer, sound issues do not always respond to logical diagnosis, more trial and error.

You could check Software Store if you have Pulse Audio Volume Control (pavucontrol) installed. That is another tool that may help solve the weird behaviour. See this post by @Aravisian Sound doesn't work on Acer Gateway NE46Rs laptop - #5 by Aravisian

Also any answer to this question:

Another thing to think about is linux kernel version and support for your audio hardware. Can you tell us the make/model/spec of your computer?
If it is very old or very new machine the linux kernel version could be a factor.

yes, I did some changes including unmuting speaker channel, enabling auto-mute, changing s/pdif settings. nothings seems to work.

as of now I am keeping the sound settings window open and minimized. that stops the icon from flashing and also stops media from unpausing itself.

Also there is one thing I would like to share is that whenever I shut down my laptop, for a split second it shows a black screen with continuous string of ^@^@^@^@^@^@^@^@^@^@^@.....and I have reasons to believe that one "icon flash" is equal to one "^@". more flashes means the string is longer and when I use the system without the earphone, it gives no trouble and also no string at the time of shutdown. I have not yet confirmed that it is indeed the situation.

I am also attaching screen shots from other forums for your reference.

and yes, I did tried pulse audio volume control previously. I don't exactly remember if I was using manjaro or zorin 16 at that time, but it did not solve the issue. i would try once again in this OS as well.

I am attaching sound card screenshot.

1 Like

Just wondering..

Do you have any options in your BIOS for any kind of sound / headphone option pop-up when plugged in or HW actions when unplugged? :thinking: That sounds kind of like HW actions are being performed when that device port has activity..

OK 1 Soundcard.

Please answer this:

@PlumpKibbles Now you got me thinking about if Windows is hanging on to sound setup on that machine.

@pradyuman15 Did you have Windows or are you dual-booting Windows?
Did you disable Fast Start in Windows and disable Secure Boot in BIOS?

1 Like

Also was wondering about SB status myself.

@pradyuman15 Windows 10+ will keep some devices active across reboots - ran into this with dual-booting 16.3 Core and Win11 myself. Just had to shutdown Win before booting Zorin and it was good to go. If I forgot, just had to reboot into Win, shutdown, then boot back into Zorin.

I am using only zorin. i have no requirements as of now to have dual boot.

here is my system information

my secure boot is disabled.
i will upload my bios information as well.

here is a proof of that ^@ string i was saying when shuting down

1st time shutdown
(many times stop icon flashed)

2nd time shuting down.
I didn't use my earphones so there was no issues and screen went straight to shutdown logo. there was no black screen.

3rd time I intentionally plugged the earphone untill the sign flashes 5 times.
here a screenshot of black screen after shutdown. exactly 5 times ^@ appeared in that string.

I hope this information means something to you.

here are pictures of my bios settings.

OK. So Zorin 17 Core only OS installed. Noted "Secure Boot" disabled confirmed.

As you didn't have these problems on older version Z16 and kernels, did you try my advice about booting an older kernel from grub screen on startup?
i.e. via grub "Additional Options for Zorin" menu item.

Did you check the SHA256 checksum of your ZorinOS 17 downloaded .iso file against the published value on Zorin website?

If you boot your ZorinOS installation USB and do "Try Zorin" do you have same sound problem etc?

1 Like

I did check the SHA256 checksum file.
it was ok.

I have not yet tried booting on an older kernel on zorin 17.

In zorin 16 also, I was facing this issue after updating. so I reinstalled and never updated.

In Z17, it is right from the beginning. even when I live booted from usb.

I agree that this sounds like a kernel issue - where a driver includes a regression that has remained. On LiveUSB or at initial boot, you are on a generic driver, but once you upgrade and use the associated driver instead of the generic; the issue begins.
Have you tested using the kernel that is present on the initial install of Zorin OS 16?

I don't remember what kernel it was on Zorin 16. if you could tell me then I would try booting zorin 17 using that kernel. But in zorin 16, software store didn't work at all, I had to use terminal to install and uninstall even the standard applications. I don't know if that related but That's my fear.

I will try though.