Not being able to connect to Windows 10 using Remmina or KRDC

I have been trying throughout the day to connect to my Windows 10 desktop from my Zorin OS laptop using RDP on Remmina. In my Windows 10 desktop, I have stopped my antivirus firewall as well as disabled the Defender firewall. I also have another laptop running Ubuntu 18.04.4, and from there, I am easily able to connect to Windows 10 in RDP mode using Remmina. However, the same is not true for my Zorin OS machine. I tried removing the freerdp folder by running the following command:

rm -rf ~/.config/freerdp/

However, even after that, when I restart Remmina and try to connect, the problem remains. I'm also not understanding what the difference is between Zorin OS and Ubuntu that it shouldn't connect from the former, but does so from the latter.

Ubuntu may come with something pre-installed that Zorin OS does not.

sudo apt install xrdp

systemctl enable xrdp

systemctl status xrdp

Many thanks for the solution @Aravisian . I banged my head for an entire day with this, thinking something is wrong with my installation. Thanks for providing the exact solution.

1 Like

One terminal command helped you after an entire day of banging your head over the GUI application?

No, I don't know why the reply took only that command. I meant all three of them.

1 Like

No problem. I was tying the point into another discussion.
The only point being: Using the right tool for the job can make it fast, efficient and easy; solving the problem so you can get on to other things.

1 Like

Exactly, @Aravisian . I actually am not very conversant with what packages come installed or not installed by default in the various distros. And no amount of googling was pointing me to these packages in particular which may be the problem. They were all widely varying with someone asking to remove freerdp and then reinstalling it, or changing the connection type to NLA or TLS and claiming that those solutions worked. Yet, nothing was working for me. All these solution browsing cost me the full day! Only at the end, I thought of bringing my old Ubuntu laptop and trying from there. When it worked, I understood that there must be some difference between the two distros, and hence finally asked my question here. Thanks again, for resolving the problem which was seeming so very difficult to me.

1 Like

The story was still not at an end, unfortunately. Today, when I restarted my machines, the problem was back. Ubuntu is able to connect, Zorin OS is not. So I went absolutely under the hood, like @Aravisian 's analysis, to see what is occurring. I used the following command to debug Remmina:

G_MESSAGES_PREFIXED=all G_MESSAGES_DEBUG=all remmina

I could always see the following line in the console:

[ERROR][com.freerdp.core.connection] - Timeout waiting for activation

A google search led me to believe that FreeRDP does not work for certain versions. I left Remmina alone and tried to connect to RDP using FreeRDP itself from the command line after installing FreeRDP manually using this link:

xfreerdp /f /u :Tester /p :1234 /v :192.168.0.101

I got the same error. Ubuntu however, was able to connect. So I checked the versions of FreeRDP in both laptops:

xfreerdp --version

Ubuntu gave 2.2.0, Zorin OS gave 2.3.2.

Then I started searching for how to downgrade the version. First, I uninstalled two packages, freerdp2-x11 and freerdp2-shadow-x11 which I had installed in the previous step.

sudo apt-get remove freerdp2-x11
sudo apt-get remove freerdp2-shadow-x11

Then I checked for the versions which I had available in the repo:

apt-cache policy freerdp2-x11

This gave the following output:

freerdp2-x11:
Installed: (none)
Candidate: 2.3.2+git202103151229-0+remmina202106280908.rc3df0be63.dd08c3ca35~ubuntu20.04.1
Version table:
2.3.2+git202103151229-0+remmina202106280908.rc3df0be63.dd08c3ca35~ubuntu20.04.1 500
500 Index of /remmina-ppa-team/remmina-next/ubuntu focal/main amd64 Packages
2.2.0+dfsg1-0ubuntu0.20.04.1 500
500 Index of /ubuntu/ focal-updates/universe amd64 Packages
500 Index of /ubuntu focal-security/universe amd64 Packages
2.0.0~git20190204.1.2693389a+dfsg1-2build2 500
500 Index of /ubuntu/ focal/universe amd64 Packages

I saw that the 2.2.0 version is available. So, I installed the same using the following:

sudo apt-get install freerdp2-x11=2.2.0+dfsg1-0ubuntu0.20.04.1 -V

Similar for freerdp2-shadow-x11:

sudo apt-get install freerdp2-shadow-x11=2.2.0+dfsg1-0ubuntu0.20.04.1 -V

After this, when I tried to connect to the RDP, it worked!! However, still, it's a hit-and-miss, it sometimes works, sometimes doesn't. But still, it's started working, and that's all that matters. Just posting this here in case it's helpful to anyone else.