Not quite there

I suppose I should first start by saying Thank you to to the ZorinOS team. You are creating without a doubt, one of THE BEST Linux distro’s available to date.

I am a long time Windows user as well as a long time Linux dabbler. My "Go TO" distro was/is Fedora Core, SUSE and Mint. I have tried MANY distro’s in the past. Always with the goal to dump windows. Dare I say you are the FIRST distro where I have formatted my Del Insperon 7773 17" laptop and installed ZornOS.

My feedback,
I am a legally blind individual. Your font control while nice, does not quite do the job.

It would be nice if one could adjust system wide fonts as well as scroll bars.

Thank you,
V

2 Likes

Hi and welcome to the forum :slight_smile:

You might find this thread useful for you.

4 Likes

First welcome to the forum @VLFberht ! Cool you took the jump to Zorin OS core, it's a wonderful stepping stone to learn Linux.

You should be able to access fonts via Zorin Appearance and set to 72 as the size. Not sure on the scroll. but it's a start.

Look forward to your input so we all can grow too

There is also Accessibility in Settings where you can change some parameters. Mine looks like this:

By installing Gnome Tweak (from Software), you should be able to change the magnification of the fonts system wide.

My system runs in Japanese but the items should be in the same spot in the English version.

1 Like

Linux Mint has a Setting for this which is very handy.

But you can achieve the same effect with a custom gtk.css placed in ~/.config/gtk-3.0 directory.

On my themes, I keep to a minimum of 16px on scrollbars. I also disable overlay scrolling.
In your gtk.css, paste in:

scrollbar trough,  scrollbar slider, scrollbar slider:hover, scrollbar slider:disabled, scrollbar slider:active {
     min-width: 16px;
}
 scrollbar.horizontal trough,  scrollbar.horizontal slider, scrollbar.horizontal slider:hover, scrollbar.horizontal slider:disabled,scrollbar.horizontal slider:active {
     min-height: 16px;
}

Change the width to suit.

To disable overlay scrollbars:

sudo nano /etc/environment

Add the following line:
GTK_OVERLAY_SCROLLING=0
Hit ctrl+x to exit, hit the Y key to say yes to save, then hit the Enter key to save under current configuration.

2 Likes

This is mine Gnome


Zorin Appearance
Gnome Tweak

4 Likes

Thanks @Bubby!

English version helps :slight_smile:

1 Like

Granted(assuming that) English is the primary :grin:

2 Likes

As someone who has worked in supporting students with low vision, giving examples of light blue on black is not a good example. That's why in my videos I will launch LibreOffice or TextMaker with a white background and font 18 Bold.
In terms of Menus, font sizes should not go above 15/16 pts as anything above that will make part of the menu disappear - (and I am talking from an environment that used Windows as the primary OS. One font I discovered that was good for capturing for tutorial videos is URW Gothic Demi.

The screenshot above is after I had changed the fonts globally to URW Gothic Demi 15 but made it 18 for the Terminal Profile. The menu font did not change for the Desktop Menu but did change for the applications menu. The workaround for this in KDE is using Alt+ F2 to get correct size font search bar, in this case 15 point Demi. The KMag tool is no where near as good as Gnome's Magnification sadly.

2 Likes