Not recognising my 2nd DVD drive

I have two DVD/CD drives but only one is listed under Utilities Drives along with the Hard drive, it also don't show up on the desktop as mounted if I install a disc.
Yet it will work OK in VLC both Audio & Video Discs but not in any other media program it also works in and is shown listed and works in Virtualbox with Windows7 OS Installed as I need Photoshop, cant get on with Gimp after 20 odd years with Photoshop, everything else works fine.
I have reinstalled Zorin twice to no avail the sha and disc checks all confirmed
Ok. I am new to Linux and as my old computer dose not have the necessary software in the motherboard for Windows 10 or 11, anyway I hate them, I am trying to learn Linux but at 88 the grey matter takes longer to work.
Zorin does everything I want apart from Photoshop which is not compatible but I found a work a round and you would think it was native to Linux.
So can anybody help please its not a big issue but room for thought to put right.

Hi delboy, and welcome to the forum. See if this old ask Ubuntu thread helps:

I think the issue with GIMP is the way it shows up (Dark). When I worked, our daily go to was PaintShop Pro 8 (Corel bought it out and made it worse, just like they did with Painter!). I am happy to share a tutorial video I had to do for work for colleagues during lockdown on how to tweak GIMP to be usable, without a dark background. If you would like to view it I will PM the link to you. (It's not available for general release).

Here's a list of functioning Photoshop versions that work with Wine:

Second using Gimp - you'll need something like Darktable or Rawtherapee for RAW images, just FYI!

I take it that you're using a desktop - correct? (visualizing it helps lol) And did the two drives work well in Windows - or was this a new device addition? And, if you open Disks, does it populate in the left column? If it's not mounting correctly on boot, you may need to modify fstab to set that mount with options for r/w/x at start.. and before I can give any advice on that, I need to clean some stuff up lol I'll do some research and come back; but sounds almost like a permissions issue, or mounting incorrectly :thinking:

(edit) So, looking through some stuff, before going with fstab options - in your /dev directory, do you have two DVD drives listed? The two may be mounted to the same location.. which if so, they would need separating in fstab. You can list your /dev directory, in terminal: ls /dev and that will show you the drives / devices. It may be DVD in the /dev directory, if both are recognized, look for a DVD1, possibly could be cdrom 1 or 2 as well..

Thanks guys for you interest as I am new to Zorin and Linux its a bit daunting using the terminal I am worried in case I mess up the system as I have never used anything like this before I am a plug and play man.
Anyway I took a chance and copied and pasted as I could not find that L shaped symbol on my keyboard and this is what came back perhaps you could help with interpreting it

So, I see one dvd and one dvdrw - are they separate types of drives; i.e., one read-only, one re-writable? That would be good, since they're separated already - but still kind of seems like mounting issues. In terminal, again, use sudo lshw -C disc and if that displays nothing, try sudo lshw -C dvd - that will list your hardware relating to disc drives or dvd drives; may or may not be either dvd or disc - maybe try both..

Do both drives show up if you look in BIOS?

Since one is showing up, and the other one isn't - try swapping the physical drive order. Take the primary drive, unplug it, then take the secondary drive, unplug it - and literally swap their places. Does that make a difference in displayed disc drives?

The ls command means 'list' - so if you do 'ls /home/your username/Documents', you'll display all the contents in Documents from your home directory that don't have hidden attributes. ls -a will show all contents including hidden directories, -a meaning 'all'.

Now, what I would be interested to see (terminal is used for a lot of troubleshooting, much more verbose rather than a GUI): sudo dmesg | grep -i dvd or sudo dmesg | grep -i cdrom - dmesg shows kernel messages, and can really help point out if something is acting funny. You could also see a different output if you run the dmesg commands without and with a disc in the drive.

And for giggles, what does cat /etc/fstab show? 'cat' means concatenate; shows text contents of a file in terminal. I'm interested to see what mount options are in fstab for that drive that does show - if maybe that can be copied to the one not showing up to match :thinking: maybe.. But do post the output of the other commands above! :grin:

Hi thanks for all this information it may take me a bit of time to go through all that, in the meantime both drives are :- DVD/CD RW and they show up in the Bois Ok .
I don't think I have mentioned this before but the drive that is not recognised is the one I installed Zorin on. I had thought maybe at sometime to reinstall on the other drive to see what I get,I also thought as I still have the Zorin download to make a bootable USB and install from that and see what I get.
The thing is the system is running so well I don't want to mess it up and loose all the hard work I have done setting things up.

Hmmmmmmmmm.. that's strange if it's permanently un-mounting that drive after install :thinking: Maybe as it's installing it doesn't write that drive to fstab.. that's odd though.. very..

If not a full install - make the USB, boot from it, and see if both drives are showing in the Live desktop. If they're showing / working in the Live USB; high chances it'll be the same after install. I've not installed by actual disc in such a long time to know what nuances may be brought with newer systems and all.. but sounds like there are some differences lol

I wanted to kind of revisit the physical connections to the drives / disks - are they SATA or IDE; or a mix of both?

Hi PlumpKimbbles
All drives and discs are IDE

Gotcha - have you checked the jumper settings on the device? I.e. primary / secondary. Also with the IDE ribbon cables, do you know if it's a 40 or 80 wire?


Something else I was kind of wondering about too, was since they're both the same type of drive, they may be both mounting as the dvdrw /dev location .. Put a disc in the one that's not showing up, then take a look in /media/your_user and see if anything is there - if so, you may need to make a separate mount point in /mnt like /mnt/dvdrw2 to reflect.

I'm interested to know what the jumper settings are though - I do believe Windows has a 'safety' feature so if they're not correctly set, it won't matter - and Win / BIOS will be able to handle the mismatch; but Linux / Zorin may not be able to.. It's been a long time since diagnosing anything IDE connected for me, heh..

Sorry I got it wrong they are SATA when I saw your reply and the layout of the connections as I said at the beginning I am 88 I think Dementia sets in sometimes.

1 Like

No worries!

So - since it's SATA, won't have any of the jumper settings. But, how many SATA ports do you have on the motherboard? I would try moving the one not showing up into another SATA port to see if any changes happen; or just a re-seat of connections to ports. Maybe even unplug the misbehaving one, boot, login, shutdown, plug it back in, and see if that resets the device list.. Which wouldn't explain why it's not showing up - but looking in the /media/user location should show two different drives, with discs in the trays. If not, then they're mounting as the same drive regardless by mounting to the same location.. Not being able to smack it into working makes it a little difficult to diagnose :laughing:

Hi there thanks for all the information you have been giving me I have copied it for future reference.
I think I am going to leave well alone, I dont need both drive nowadays I used to do a lot of video documentries video editing and copying on the fly thus the two drives. Its been wonderfull comunicating with you and I thank you very much for your time, what a lovley comunity Zorin has nothing like that in Windows,I shall keep following all the questions that come up as I find it very interesting and informative and start to learn Linux a bit more.
I dont know what part of the world you come from but Im from the UK .
Kind regards Delboy

1 Like

Thought I would have one more go with the SATA leads after shutting down I ditched both rebooted in Discs no DVD Drives showed up shut down switched drive leads over one drive showed in discs and mounted on desktop transferred lead back to other drive showed up in Discs and mounted on desktop connected both up only showed one drive in Discs only one mounted back to original situation I also tried selecting Discs and the DVD Drive then the little star and tried edit mounting options to no avail. I think my saying about the drive I installed on was just a coincidence.
Is it possible that Zorin was designed to only use and see one DVD drive as they are pretty much obsolete these days modern computers don't have them built in if you have need to use one then you use a USB Disc Drive.

I forgot to say I even ditched the BOIS battery to loose any memory


Getting a bit more adventurous got this from terminal

Been looking at other peoples problems and come across one similar in as much as his Hard drive was master and DVDRW was slave my two drives are master and slave could this be the problem? but it all works OK in Windows on Virtualbox.

1 Like

HDD/SSD master | CD/DVD slave - yep, that's very common for setup. Which, is why I was wondering if it were SATA / IDE - and if IDE, jumpers or cable width. The 80-wire cables were better suited for having two drives, and better transfer speeds; 40-wire, older, had some issues using two devices after some time and upgrades to devices came. Most IDE drives have three settings for jumper spots - Master, Slave, and CS or Cable Select. Cable Select doesn't always work out - which Windows might be able to, and would show up; might be why it shows in your VM and not with Zorin.

Now - what I can see from your output: cdrom-0 looks to hog disc locations in /dev with cdrom, dvd, dvdrw | cdrom-1 looks to only occupy cdrw within /dev...

So, what you could do:

Unmount both with sudo umount /dev/sr0 and sudo umount /dev/sr1. Create two new mount points within /mnt and name them 'dvdrw1' and 'dvdrw2' - sudo mkdir /mnt/dvdrw1 && sudo mkdir /mnt/dvdrw2. Mount them with sudo mount /dev/sr0 /mnt/dvdrw1 to mount the first drive, then sudo mount /dev/sr1 /mnt/dvdrw2 for the second - check to see if both drives show. That may or may not work, if SATA ports / jumper settings yield nothing. If that does work, you can edit the fstab file to do this on startup, mounting both drives as above in 'dvdrw1' and 'dvdrw2'.

Wow need to get my head around this, I presume I copy and paste in the order you show. The sudo mkdir /mnt/dvdrw1 && sudo mkdir /mnt/dvdrw2is this all one or do I split it into two sudo if so between what points excuse me for being inquisitive but should there be two &&. Sorry to be such an idiot but this is all very new to me

All one - yeah, those are in order so you can just copy / paste them. && is how you can string more than one command into one. For that one, since it's two directories, it'll be quicker to && the two together - like sudo apt update && sudo apt upgrade which will update, then upgrade any packages that need upgrading.

Seems like a lot, but it's not that much! Terminal is good practice though; I use it for everything I can besides the most basic GUI functions of the OS; but is much faster than using a GUI! :wink:

You can use terminal to update / upgrade for practice, browse around with software, install, uninstall - apt is one to get good with for sure :+1: