Notification Icon Size

Greetings!

I noticed an interesting thing happening with my notification icon size when I adjust the row size of my panel.

The size of the icon adjusts normally when I change the row size of my panel until I reach a size of 42. Then it jumps to a much bigger size than the other icons.

Row Size of 41:
panel-indicator-size-41

Row Size of 42:
panel-indicator-size-42

Is this a known issue? I was unable to find a thread on it.

In case you’re wondering, here are my specs.

system

The icons used are the Symbolic Icons. The Javascript for the app determines whether or not the Icon increases in size with the panel or not and at what increment it does.
It Row Size 41, “Notifications” is using the spec for the 24px icons. When you increase the row size to 42, it then moves to the next scaling level up in Icon size which can be a pretty big jump. It appears that the other apps are not using the same size determination (Which, in my opinion… Is the fault of the rest, not the fault of Notifications which is the only one doing it right).

EDIT: In XFCE, you can right click the panel, then on the panel option, slide to the arrow and then select the Panel Settings. In the Popup window, you can select the Icon size, Scaling or Fixed.

Thanks, @Aravisian.

Switching to ‘Scaling’ gives me this at the row size of 36.

panel-indicator-size-36

It appears that the apps are indeed using different rules in the Javascript.

1 Like

I just logged in on XFCE D.E. on Zorin Ultimate 15.3 Lite and I am seeing the same thing. However… I would like to test this for a few minutes by trying out different icon themes, as well.
–Ok, I have tested that and the effect remains the same across several Icon Sets, so I do not think it is a fault of the sizing layouts in the index.theme file.

It seems to make a difference whether the icons are of an app plugin or placed into a more general Notifications Plugin. As I recall, I resolved this when I used XFCE D.E. by removing the Notifications plugin, then adding the individual notifications to the panel that I wanted. At that point, all the panel icons then sized in unison. At that time, I was resolving something else- the icon sizes were a side effect that I remembered now while testing.

EDIT: If you open the Panel settings, then go to the items tab, you can select the Notification Plugin from there and select icon sizes in that, I think. I am not currently using that but I can test that later if needs be. (I have logged back into the Cinnamon D.E. for now).

EDIT Numbah 2:
One more thing you can try if the above does not work for you. Use the gtk.css to affect icon sizes.
In your ~/.config/gtk-3.0/gtk.css file (If the gtk.css file does not exist, just create a new one) add the following lines:

#pulseaudio-button image {
-gtk-icon-transform: scale(0.5);
}
#xfce4-indicator-plugin{
-gtk-icon-transform: scale(0.5);
}
#xfce4-blueman-plugin image {
-gtk-icon-transform: scale(0.5);
}

And so on. You can add whichever app plugin you need and adjust the scale factor as needed. To See the Changes:
alt+F2
enter in

xfce4-panel -r

to restart the panel. You can do this each time you make a change to see what effect the changes have and zero in on your desired setup.

1 Like

Thanks for your research on this, @Aravisian. I’ll give these steps a go.

The methods you suggested did not work for me, but they led me down the right path. I was able to add the following code to my gtk.css file, and that fixed the notification icon issue.

.xfce4-panel
button {
    padding: 6px 6px;
}

As far as the battery and volume icons are concerned, I just kept the ‘Adjust size automatically’ option turned off and set the size of those to 16.

Now, all the icons are the same size, and my panel looks the way I want it to.

Thanks again, @Aravisian :slightly_smiling_face:

2 Likes