NTFS Volume Corruption with mountpoint loss (Zorin 17 Pro)

Hi everyone
I love Zorin. TBC
I bought 17 Pro a couple of days ago. Have been running 16 prior to that without any issues as my daily driver on my Dell Latitude 5500, with LUKS and ZFS.

Installed 17 on my AMD Ryzen desktop with ZFS and LUKS on to an MSI 1Tb M.2 drive, dual-booting 16 on another separate 1Tb MSI M.2.

I have 2 x 8Tb 7200rpm Seagate IronWolf drives that I use for training material attached as well.
The two internal SATA 8TB drives suddenly could not mount while using File/Folder browser and despite creating new mount points under /dev/media and attempting mount as SU, the two drives just would not, with an error message to say that I needed to boot into Windows and run CHKDSK /f.

Next step: while migrating material off to a Transcend 1.6Tb external hard drive, the disk (EXT) corrupted after the COPY/MOVE process hung and I restarted the OS.
Since then, another 3Tb Seagate external USB3 drive FS (NTFS) has become unreachable.

I also noticed that with ZFS, TimeShift also opens in Read mode so I can't create any more snapshots.

Not complaining, this is just FYI. I cannot go back to Windows on principle, so will revert back to v 16 and not use ZFS, but LVM instead.
I really don't want to even dual-boot Windows so I'll have to keep on working at this.


You don't really need to dual-boot with Windows (unless you've got a program that you absolutely need that doesn't have a Linux version)... for the infrequent tasks that require Windows (UEFI updates in Windows-only file formats), you can set up a USB stick with Ventoy, then drop the Zorin OS .ISO file and the Hiren's Boot CD Win10PE .ISO file onto it.

My machine is an HP, but it'll work for any computer make.

1 Like

The Ventoy suggestion is a good one. Everything I really need is catered for in Zorin and if I need to do some security auditing, I have a fully patched, stand-alone W10 22h2 VM that I use in VirtualBox with the Windows apps I have for that. This is just a hiccup. The only thing that changed recently was the installation of EasyDiffusion3 in Z17.
Going to try and do any outstanding FW updates on my Asrock Fatality K4 MB, reset my BIOS and try again.

Thanks for this.

Check inside the BIOS / UEFI itself... desktop motherboards often have a built-in utility to do updates. If that doesn't work, search on your computer manufacturer's support website for a Linux-compatible UEFI update. If that doesn't work, download the Windows-only version, and use the Hiren Boot CD Win10PE .ISO file on the Ventoy USB stick to update the UEFI.

It actually does have that option to update straight from the BIOS. The Ventoy option with the W10 .iso would negate having to install Windows in order to do a CHKDSK I'm assuming?

Absolutely. In fact, when I've got a particularly troublesome disc to troubleshoot, I run chkdsk from the Hiren's Boot CD Win10 PE .ISO file on the Ventoy USB stick.

If you've got a Window installation, I'd recommend cloning it to an external drive and wiping the drive being used now for Windows to repurpose it. Let that external drive sit, unconnected and unused... if you find you do need Windows for some reason, you can clone it back to that drive it had been on, and continue using it without Windows complaining about hardware changes. If you find, after a year or so, that you've not had to touch that Windows disk, you can wipe it and use it for other purposes.

1 Like

Brilliant. Going to create the stick now. I even tried a FSCK on the unmounted 8Tb drives and it just gave the version of the toolkit and went back to a prompt. It's interesting though. Just moving my Downloads off to external now. I connected the external to a laptop with W10 and ran CHDSK /f to repair it, so all good. Would you recommend trying ZFS again? In lieu of Bitlocker, I thought LUKS would be fine, and it works well if you don't dual-boot with Windows.

I would only recommend ZFS if you've got multiple drives (on multiple drive interfaces) to set up drive mirroring. For instance, I've got 3 500GB drives mirrored. One drive can completely fail, and the machine will still boot. All I have to do is remove the failed drive, drop in an identically-sized drive, and ZFS will rebuild the data on the new drive and continue on as though nothing happened.

I don't have hot-swap capability, so I'd have to shut down the machine to switch out the drive. Hot swap would let one switch out the drive without even having to shut down.

I've found that with 3 mirrored spinning-rust drives, it's about as fast as a single SSD on read speed, and I don't have to worry about write-wearing of the drives. Write speed is still as fast as a single drive, though... to speed that up, you'd need fast SLOG drives mirrored, but then you'd need SSD drives and they'd eventually wear out. I'm searching for a drive that uses RAM sticks to use as a SLOG drive... that'd get me super-fast write speeds and no write-wearing.

OK, thank you for that. I'm not doing that at all so will stick with LVM. ZFS is impressive from what little I've read on it so I thought I'd give it a go, but not this time around. I have a Dell T420 that I'll try ZFS on as it has multiple drives but in 2024.... I come from SCSI and IDE days.

Ok. I'm going to try that. If I reload everything without figuring it out, I won't have learned much from this. I'll revert once done, thank you for the suggestion.

I think Ext4 is the most stable option when it comes to the file system. Ext4 can easily pick up my WD Elements 4 Tb drive. I never use Encryption having had warnings of potential loss of data when I purchased SuSE Linux 9.3 Professional many years ago. I was about to encrypt the /home folder when I received an installer warning about potential loss of data. In a work scenario, my line manager asked me to setup a secure data partition for her business manager. 3 days later the machine fell over and the data was gone forever - but fortunately, the business manager had the sense to backup all of their critical data so only lost a couple of days items.

Hi there. Thank you for the suggestion. I have SMART enabled in the BIOS in addition to the SMARTMON tools for Ubuntu. Correcting the errors on my two 8Tb SATA drives was easy with CHKDSK - free space was marked allocated in the Volume bitmap. Once this was fixed and orphans were deleted, I could read the drives again. Encrypting my filesystem is important on my laptop as laptop thefts are rife where I live. Ext4 it is :+1:

1 Like

Might be worth creating a YUBI key and keep data on portable external drive?

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.