NVIDIA Driver problem

Hi. I've just changed from Ubuntu to Zorin Pro 16. My 'NVIDIA GeForce GTX 750 Ti' sound card is stuck on its lowest resolution. I've looked at the threads on here and I've tried some of the suggestions. Nothing has worked. I am a complete non-tech person when it comes to OS's, so you'll have to be gentle with me. When I use the line "sudo telinit 3", my screen goes blank and I can't do anything to 'unblank' it, even after a reboot. I have to use the pen drive with the OS on it to get it back. I love the OS, particularly for the much more stable way it handles my music software (mostly MuseScore). I have downloaded the latest driver for the video card, but I haven't a clue what to do with it, especially with a totally blank screen.

Hi and welcome to the forum :robot:

Can you open Additional Driver and see if you are using proprietary NVidia driver?
Mine looks like this:

Are you trying to install the nvidia driver manually ? If yes, follow this guide

I am just waiting for the day when some clever OP replies to your screen shot with "that all looks japanese to me" He He.

Thanks for the reply. Mine looks the same, with the same driver selected.

Thanks. I have tried to follow the guide, but my screen goes blank after I switch off the GUI and I can't 'unblank' it. So the process stops there.

You see, Japanese language is not a problem in this context :wink:

1 Like

Did you take update/upgrade before this problem happened?
What is the output of the command
uname -a

Here's the output;

uname -a
Linux philip-All-Series 5.11.0-38-generic #42~20.04.1-Ubuntu SMP Tue Sep 28 20:41:07 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

That is exactly the same version as mine.
Can you switch to Nouveau driver and see if it make any difference?

I'm sorry, I don't quite understand your first question. I did a clean install from Ubuntu (latest version) to Zorin 16 Pro. The problem was apparent as soon as Zorin started. I didn't have a problem with resolution in Ubuntu.

I've tried changing to Nouveau driver and it makes no difference.

You may try installing the 460 driver:

sudo apt install nvidia-460

Ensure that driver is selected.

If that does not work, you may try:

sudo add-apt-repository ppa:ubuntu-x-swat/updates

sudo apt update && sudo apt full-upgrade

Here is the output for: sudo apt install nvidia-460

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package nvidia-460

The other two routines made no difference.

sudo apt install nvidia-driver-460


What about purging NVidia driver completely (while using Nouveau).
Reboot then re-install NVidia driver?
That's how I fixed a similar issue when I was using Mint.

1 Like

Did you follow post 1 from the tutorial ?

I changed the command to include the word 'driver' and, this time, I got this:

sudo apt install nvidia-driver-470
Reading package lists... Done
Building dependency tree
Reading state information... Done
nvidia-driver-470 is already the newest version (470.74-0ubuntu0.20.04.1).
0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.

I followed the advice to the letter until my screen went blank and couldn't continue.

How do I a. purge the nvidia drivers, and b. reinstall them without my screen going blank?
(These might seem like stupid questions to you)