Nvidia Proprietary Driver Selection resulte in an error - however is ACTIVE driver

Machine: Dell Vostro 1700 Laptop
Problem hardware: NVIDIA GeForce 8400 GS (G86)
VGA compatible controller: NVIDIA Corporation G86M [GeForce 8400M GS] (reva 1)
Current ZORIN O/S Version: 16.1
Kernel: X86_64 Linux 5.15.0-48-generic
Desktop: Xfce

Problem, using the SOFTWARE UPDATER --> ADDITIONAL DRIVERS method, I was able to get the Wifi Card working successfully, however the NVIDIA binary proprietary driver selection has left me WITHOUT a FULLY functioning DE that locks up most of the time unless I keep it busy/using it.

During the Nvidia driver selection(Software Updater --->Additional Drivers), I selected APPLY change and it trucked along until just near the end and returned the following error:

"Error while applying changes
**pk-client-error-quark: Error while installing package: Installed nvidia-340 **
package post-installation script subprocess returned error exist status 10 (313)"

Although, the driver does show it is SELECTED in Software Updater.

I ran the command:
sudo dpkg --configure -a

Which resulted in some errors as well and I will have to reboot the machine to get that for you if you need it. My bad, tried to have as much INFO for you all.

Yes, this is a very old Laptop, but fully functioning and I believe in the resurrection :wink:

Any and all help, pointers, links, how too's will be MOST appreciated.

Thank you All.

I read in another post that Kernel 5.8 might solve a problem with NVIDIA 340 drivers. Where can a person DOWNLOAD that to give a try ?

I wonder if the purge command in this guide will work.

You can install the 5.8 kernel directly from the terminal:

sudo apt install linux-headers-5.8.0-63-generic linux-modules-5.8.0-63-generic linux-modules-extra-5.8.0-63-generic linux-image-5.8.0-63-generic

I also recommend @anon6471198 's suggestion to fully purge the Nvidia driver, then reinstall:

sudo ubuntu-drivers install

Launch the Additional Drivers and select the appropriate Nvidia Driver from the list. Have you yet tried the open source Nouveau driver?

I have a similar problem. I found that the last supported kernel for the NVIDIA 340 driver is 5.4 (The installation of the NVIDIA display driver 340 fails in Kubuntu 20.10 - Ask Ubuntu) not 5.8.
Now to my question: What is better downgrading the kernel or running the nouveau driver (which runs ok for my purposes)?

Removing the Driver and Reinstalling the Correct one.

Either, since either option should run fine on your system. If, for some reason, you find that you prefer the proprietary 340 driver, then the 5.4 kernel should work just fine on your system.
The newer kernels address newer hardware. Remember: the 5.4 kernel was the newest and greatest at one point, on the same hardware. It wasn't exactly broken...