Nvidia server settings empty -driver 470

Hello! I'm having the same problem hehe, but I did install Zorin OS 16 with the modern nvidia drivers!

In the "additional drivers" tab, "Using NVIDIA driver metapackage from nvidia-driver-470 (proprietary, tested)" is selected, and the "NVIDIA X Server Settings" just show an empty window.

image

Thanks in advance for your kind help.

Could you give us a model number of your NVidia graphics card?

Sure! It's a GTX 1650 ti. If you want more details, I use an Acer Nitro 5 AN515-44-R8HN notebook.

I ran into the same problem with my installation of Zorin OS Pro 16.

I got the same results as mentioned above. I have a nvidia gtx 1060.

The only way I was able to resolve the problem was to do an install without enabling these two options

Install third-party software for graphics and wi-fi hardware and additional media formats

Download updates while installing Zorin OS

Downloading updates and installing them post install and then using the Additional Drivers tool to install the nvidia drivers worked.

I didn't look into it any further but would not be surprised if when you have the two options for drivers and updates enabled that the nvidia drivers are not getting properly installed against the newer kernel.

If you have a nvidia card it should be an easily replicated bug.

I ran into that issue as well, but that happend because i messed with gpu drivers to test (ppa install). Try to install nvidia drivers manually.

1 Like

If you have an older computer, which by your admission of your GPU's, sounds like a 2019 machine, you don't really need anything beyond the 5.8 kernel. And installing the latest kernel's, seems to conflict terribly with older machines, even ones that are only a couple of years old!

Basically, they need to work out the bugs in the kernels, its as simple as that. So for now, if your machine is couple years old, please use the 5.8 kernel, and use Nvidia driver 430. Those are a good matched pair, and should cause you no issues.

If your computer is newer, 2020 - 2021 machine. You can use the 5.11 kernel, and the Nvidia 460 or 470 drivers.

FYI: I just checked my POP OS 21.04 installation, and I've been upgraded to the 5.13 kernel, and I am having 0-issues that I can see.

However, I wouldn't want my Zorin OS installation to upgrade to the 5.13 kernel, cause Zorin OS is installed on a dual core machine that would probably puke its guts out if 5.13 was shoved into it lol.

No issues here with a 2017 machine and latest kernel/nvidia driver.

Does Zorin OS even have the 5.13/5.14 kernel ???

So I should do a fresh install, don't click on "modern nvidia drivers", and then install them later with Additional Drivers?

That may be an option, but let's try a few other things first just in case you can spare yourself that much trouble.

Can you open a terminal with ctrl+alt+t and run

sudo ubuntu-drivers autoinstall

IF that does not work, can you try a direct approach:

sudo apt install nvidia-driver-460

I did that, but then I realized the solution. It's now working.

Secure boot was enabled, and every time I switched a NVIDIA driver it asked me for a password to put in secure boot, so then I did so. When I rebooted my pc, appeared a screen with options "continue" (or something like that) and "enroll MOK". I always clicked continue. Now, I clicked "enroll MOK", put the password I chose before, and it's working now!! So I don't think it's a driver problem, it's a secure boot problem. I think I'll just disable it.

1 Like

I think it is a wise move.
As far as I know, secure boot would not offer any benefit to Linux OS. Mine is always disabled and I've never felt any ill effect.

2 Likes

It offers no benefit to Linux - it just gets in the way.

It offers benefit to Windows- so Zorin OS has most signings for it, in order to assist those dual booting.

1 Like

I split the thread since it involves a different version of Nvidia driver.

My computer is about 4.5 years old I built Gigabyte 370 series. GTX 750 card.
Running Zorin 16 Pro standard install no other drivers with secure boot & Fast boot disabled.
It has updated Zorin several times now. One of the updates said something about several files did not get install and needs to do partial update of 30 files or something like that.
Have nivida-#470 driver installed. Kernel is the -34 and if I select the -27 on booting, it will double the image size. With Aravisian help getting minor bugs fixed my office has been on Zorin 16 for 2 days without having to boot into Windows 10 for something. This computer stays on 24/7 365 days a year. It has gone down one time power supply dead about a month ago.
Maybe this information will help.

1 Like

See, thats why I tell everybody who is having installation problems to disable SECURE BOOT

There is absolutely no benefit on Linux I agree, it only gets in the way, its annoying lol.

Secure boot is a setting for windows users anyway.