Nvidia settings not loading on bootup

been looking all night and cant find out how or if you can get the settings in the nvidia xserver settings window to load up after boot. i been trying to change the screen resolution to 2560x1440 on my desktop but when i enter them manually and save. when i boot up it resets back to 1920x1080. everytime. I am new to linux just switched a week ago.the default settings only goto 1920x1080.. even in the display settings.so have to keep manually changing them after boot.

Hi jlandy71 and welcome to the forum. What driver did you use and what card do you have ?

Did you save the save the nvidia x server settings ? via nvidia-settings configuration ?

the driver is 470 and i have a rtx 2070

Try to change resolution via settings (without the nvidia x server settings)

that only goes to 1920x1080. i want to go higher. i looked up how to add it and none seem to work.

I have no luck with nvidia x server settings, when i downgrade to lets say 1080p i get a black screen and need to force reboot.

The only thing i can think of is to save the nvidia x server settings ? via nvidia-settings configuration ?

Or try to follow this guide

yeah i guess i am not allowed above 1920x1080 in xrandr. i get this error sudo xrandr --addmode DP-4 "2560x1600_60.00"
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 140 (RANDR)
Minor opcode of failed request: 18 (RRAddOutputMode)
Serial number of failed request: 45
Current serial number in output stream: 46
and i even tried your resolution and it says unrecognized option 3840

and is the drivers the correct version?

Use 470 proprietary not 470 propietary (tested).
The 470 tested has multiple issues. It's name is misleading.

cvt 2560 1440

2560x1440 59.96 Hz (CVT 3.69M9) hsync: 89.52 kHz; pclk: 312.25 MHz
Modeline "2560x1440_60.00"  312.25  2560 2752 3024 3488  1440 1443 1448 1493 -hsync +vsync
Modeline "2560x1440"  241.500  2560 2608 2640 2720  1440 1443 1448 1481 +hsync -vsync
xrandr --newmode "2560x1440_60.00"  312.25  2560 2752 3024 3488  1440 1443 1448 1493 -hsync +vsync

If flickering, you may need refresh rate to be 54.95, instead.


Aravisian .... I just checked my NVIDIA settings and found it to be the 470 tested version so I went to the 470 and it installed .... but when I rechecked it is now it will only use the the Zorin driver .... I haven't tried any of the other drivers

My card is .... TU117M(Geforce1650mobile/maxQ

Do you mean the Nouveau?


Yes that's the one

urm... I am not sure...
You can try:

sudo ubuntu-drivers autoinstall


Hummmm ... it says I have broken packages especially for 470 ....

mike@mike-ROG-Strix-G731GT-G731GT:~$ sudo ubuntu-drivers autoinstall
[sudo] password for mike:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
nvidia-driver-470 : Depends: nvidia-kernel-source-470 (= 470.74-0ubuntu0.20.04.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

sudo apt --fix-broken install


OK looks like everything was installed .... do I run the last command again

sudo ubuntu-drivers autoinstall

mike@mike-ROG-Strix-G731GT-G731GT:~$ sudo apt --fix-broken install
[sudo] password for mike:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
blueman catfish chromium-codecs-ffmpeg-extra
dmz-cursor-theme fonts-noto-hinted
fonts-symbola gir1.2-appindicator3-0.1
gstreamer1.0-nice gstreamer1.0-vaapi
heif-gdk-pixbuf libfarstream-0.2-5 libgadu3
libgtkspell0 libgucharmap-2-90-7 libmeanwhile1
libotr5 libprotobuf-c1 libpurple-bin
libpurple0 libzephyr4 mate-calc
mate-calc-common menulibre numix-gtk-theme
onboard onboard-common onboard-data pastebinit
pidgin-data pidgin-otr python3-xcffib
shimmer-themes thunderbird whoopsie
xfce4-panel-profiles xfpanel-switch
xubuntu-artwork xubuntu-community-wallpapers
xubuntu-docs xubuntu-wallpapers
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Check which driver you are using in the Software & Updates additional drivers tab... if it's is working, i'd prefer to back away slowly...

By the way, you can run

sudo apt clean && sudo apt autoremove

if you want to.


OK problem solved .... I was going to ask you if I should use the Use 'sudo apt autoremove' to remove them command .... see ... I did read it this time .... LOL

Thank you again sir for a job well done ..... :+1: ...

1 Like

Everything else looked normal except this line ...

dpkg: warning: while removing fonts-symbola, directory '/usr/share/fonts/truety
pe/ancient-scripts' not empty so not removed

That is no problem- it left a font behind.

1 Like