OEM installation of Zorin OS

Hello,
When I no longer use a PC, I sell it (for example on ebay). Usually I install Windows 11 but I would like to show the people to whom I sell the Linux PC and as I love Zorin OS, I said to myself that I was going to install it but unfortunately, I found how did you do an OEM installation on Ubuntu but not on Zorin OS. So I would like to know how to do an OEM installation of Zorin OS 17 Core. Thanks for future responses!

If you want to do an OEM install in Zorin OS, do this :

  1. When you start a Zorin OS live USB, you get prompted with "Zorin OS", "Zorin OS (safe graphics)", etc...
    In this menu, you will need to press tab on any of the Zorin OS entry, and you will see a text box at the bottom of the screen.
  2. In this text box, there will already be text. At the end of the text, add a space, and add this after the space :
oem-config/enable=true ---
  1. Press enter, and press enter again to boot in the OEM installation mode. Be sure you connect to the internet while in the install setup.

Sources :

1 Like

Thank you for your reply !
I did what you said but Zorin OS Core 17 still asks me to create a user account.

huh, thats strange. Could you send a screenshot of the screen where you typed the text i sended ?

Thank you for your reply !
Here is the screenshot :


And then I press F10

Thats strange, for me the screen looks like this :
image

And when i try to edit (by pressing tab), the text box is at the bottom :
image

Also you could try typing the text on the main entry (and not the safe graphics one), in case thats the problem.

I tried what you said but it doesn't work. I noticed that in your boot menu, it is different than my grub on the ISO which is available on the Zorin OS site. Could it be possible that my iso is a problem?

Does your PC have UEFI ? It is possible that the boot menu looks different from BIOS to UEFI. Me i have UEFI.

Also, my iso is Zorin OS 17.1 Core (latest version), are you on the same version ?

In the VM that I used to test what you told me, I selected UEFI and I used the Zorin OS 17.1 Core ISO.
And when I start the ISO, I have this menu :

I recorded a video of what is supposed to happen :

I didn't edited it, because its just here for help here, and if i open VirtualBox's virtual keyboard, its because i'm french, and the keys to type the command aren't at the right place :sweat_smile:.

Put the video in fullscreen to see the text on screen

OK, thank you very much but when I start my ISO, I don't have the screen that you showed in your video, I took a screenshot of what I have in the previous message

I don't know why do you have a different screen, and its weird that the OEM install doesn't work. Try re-downloading the ISO, then try the OEM install again.

Exactly, I redid it already redone because I noticed that your GRUB of your ISO is different from mine but that said, I download the ISO from the Zorin site and I do not see why your GRUB is different from the mine :thinking:

When you type the command, do not put any line break, just a space, then the command :

oem-config/enable=true ---

So don't do any line break or anything when editing the boot entry, just put a space, then the command.

If you were already not putting any line break, i don't know why it doesn't work.

I did what you said but it still doesn't work:


(it's normal that there is a / after the first two hyphens because there is no more space in the frame so GRUB returns to the line by putting a / before)
and then I don't have the OEM installation that is offered :

However, it is indeed UEFI as you can see :

You need to add the OEM thing after the last word
But here its in the middle of the command

I did what you said :


But it still doesn't work:
image