Off topic question about Pop! OS

I know this is not the right forum for this but I have gotten more help from this forum than any forum I have ever been a part of. And I know there are some people on here that use Pop! OS also.

My problem is that I have finally gotten a good? maybe install of Pop! OS and have successfully gotten Picasim the RC flight simulator to work great but it has no sound. I used Play on Linux to install the game and it seems to work perfectly except for the sound issue.

I then decided to check out the sound area of settings. Using the test buttons there the sound works fine. So I next went online and watched a video and the sound also worked with the video. I then tried a regular Linux game (solitaire) and no sound! It seems that anything online the sound works but anything local including regular Linux games don't work. I have searched online for several hours now and found no solution so thought I would ask here.

i have included a screen shot of terminal after using inxi to check my Pop! OS configuration.

Thanks for any help anyone can give.

I think we have to invoke our POP specialist volunteer @Michel.

Here is a screenshot from alsamixer. It shows the headphones are muted but as I said I do get sound from my speakers when online. And this is a desktop PC with jacks on the back for plugging in my speakers which is how I have them connected. I didn't see any way to unmute the headphones in alsamixer. Nothing I clicked on did anything.

Do you have any other possible sound source?
What do you see when you press F6?

1 Like

Hi FrenchPress,

Yes there are two sound devices as shown in the first screenshot after I ran inxi. Here is a screenshot of alsamixer after I hit f6 and selected the other sound device.

As you can see it shows all outputs unmuted. I again tried Picasim after doing that and it still has no sound. I downloaded a couple of other games and they DO have sound but strange that the solitaire game does not because it does when running on Zorin.

This is a playback controller for the HDMI port.
Unless you are intended to get the sound from the monitor's built-in speaker, it is OK to have all channels muted.

Solitaire is missing Zorin environment :sob: and sabotaging your sound system :crazy_face:

But joke aside, it is indeed strange one game has no sound while others have.

I hope @Michel is coming here soon since my experience with POP is next to nothing :frowning:

1 Like

bad install or corrupt one.

1 Like

You mean the problem is in game itself?

1 Like

I'm no gamer.. but that would be my thought. Software not OS issue... all the other things are working with sound he can play music files watch videos and play most other games. Hearing all them...process of elimination

I also notice now.

While Headphone is muted, Surround, Front, Center is all working.

1 Like

@citfta this may help

Fix for no sound issue on Linux when using headphones

Okay, a little update. When I went back to settings/sound I found that system sound was again turned all the way down. I don't know why that keeps changing. But anyway now every game has sound except Picasim which was installed using PlayonLinux because it is a windows game. So I did something wrong during the install probably. I'll wait for our Pop! Os expert to suggest something. I don't really have to have the sound for the RC simulator as the planes I fly are electric so as soon as they get away from me I can't hear them anyway. Only when flying close 3D simulations is the sound helpful because it lets you hear the prop speed and that helps when learning to hover a plane with the nose straight up.

Thanks for all the help. I hope someday to know enough to help someone else but I think it will be a while before I get there.

As a side note Pop! OS was a real pain to get it installed. Zorin installation is 10 times easier. Pop! OS would get almost all the way installed and then give an error. But eventually it did install and seems to be working okay now.


Michel is in the same time zone as me and it is 1 AM here.
You might have to wait for a while.

1 Like

Thanks Bubby,

I did look at that before coming here for suggestions. It was helpful in that I learned how to use Alsamixer from that info. But I do have sound just not in Picasim.


Don't short change yourself. You are already helping other right now :wink:


Thanks FrenchPress,

As I said it is not really a big deal. I am just trying to learn all I can about Linux and solving problems is a pretty good way to learn. If everything was easy we wouldn't learn much. Waiting for Michel is fine.


You can check if you start a game settings audio not mute automatic or change source audio. I heard connected some audio usb example don't have problem. Sound Blaster card have a problems with volume. Here we focus on code Zorin and a game. Maybe problem is another a road?

1 Like

Hi citfta,

Sorry for the late reply i already read you got alot of great help on the forum. Picasim does it have a dll file called OpenAL32.dll ? I have 1 game that had no sounds at all and i had to delete that file to get the sound to work.

Did you try to run the game in lutris with a custom runner ?

Did you check when you fire up a game if the main sound is enabled ? When i fire up a game and connect my ps4 controller wireless my sound changes to the ps4 controller sound (no idea why because the sounds in the ps4 controller dont work in linux for me).

@FrenchPress, i wish i was a expert :woozy_face:


Come to think about of it, if you were a true expert, you would be in the POP forum, not here :stuck_out_tongue_winking_eye:

1 Like

Pop does not have a forum sadly.