On restart only no bootable device

Laptop boots from shut off to grub - Zorin and Win 7 - no problem. When I reboot from either - the reboot leads to "no bootable device found" try reboot F1 or go to setup F2 or diagnostics F5. I have repeated this and it is consistent. I can shut it off and then start it - all good - but restart fails.
This is a first for me and I'm not finding anything online. I bought a refurbished Dell e6230 laptop. It passes all diagnostics. I installed an SSD (Kingston sv300 120 gig) I had used in another system. I clean installed Windows 7 on one partition (60gigs), with empty space. Then I booted from a flash drive with Zorin 16 lite and set up a ext4 partition for Zorin along with a swap (which probably won't get used as I have 8 gigs ram and this is for light duty).

Adding info:
Bios boot setting is set to legacy boot. Drive is recognized and is set to number one boot position.

I set the ext4 partition during Zorin installation to "/" only.

I have found nothing online like this.
P.s. I tried another distro - also Ubuntu based - Mint - same result.
So back to Zorin which was the preferred choice for this laptop.

According to your post, it sounds like you were manually creating partitions. So it makes me wonder if you made them correctly. Here is how it is on my computer, and these were automatically made, by the Zorin installer BTW.

Zorin OS 16 PRO & PRO LITE

I assume you clicked on install Zorin OS after you made those partitions, and installed Zorin OS onto the hard drive. You may have done it wrong, in which case, here is a very helpful guide from our very own Harvey, the partitions expert.

Your legacy boot may be the issue. Zorin 16 is designed for EFI boot, not legacy. If you're running a 32bit windows and trying to run Zorin 16, this will be problematic. There are several that have jumped through hoops to get this setup to work... some have succeeded, most fail. Being that it's a Dell is even more problematic. Your best bet is to clear the drive, change the bios boot from legacy to EFI, install 64bit windows and then Zorin.

Your partitioning seems sound, except your zorin EFI boot partition is being written to the 32bit MBR sector, which is confusing the hell out of your bios.

You may be able to get away with another partition for EFI boot after the windows and before the Zorin root, but it's asking a lot for the bios to understand your intentions with both mbr and efi on the hard drive.


Thanks much for the replies!!! Will read carefully.

I should have noted, I'm using 64 bit win 7.

I also just found this information online. Potential hardware issues with Dell laptops. So will test out various solutions and leave anything I find that might be helpful to anyone else. Link to article about hardware below:

Okay, I tried one option - pre partitioning with Grub, then installing Windows, then Zorin - still using Legacy. Same result.
This whole thing surprised me as I have been dual system booting for about eight years. Oft on the same rust platter mechanical drives - never an issue.
An interesting note:
This hard drive was used in a Dell e6420 as a boot disk - windows only, and a second drive in the optical bay that was Linux - multiple distros. I did this so if Windows got corrupted - I could easily do a clean install and not upset grub - worse case scenario run grub update from lead distro - easy peazy.
Prior to that - this SSD drive was temporarily in an old Dell D-620 - with a dual boot Windows 32 and Linux Mint on another partition - worked well.
So this narrows things down - variable wise.
Variables still in play:
64 bit windows
Maybe hardware SSD not as flexible (maybe just this particular SSD) as a rust platter - firmware?
Maybe the bios set up in what affects the hardware - not referencing the UEFI vs Legacy.
So I guess the next tests are - different drive - I have a spare rust platter ...and doing the UEFI set up. I was hoping to just use the down and dirty Legacy - but.
Also maybe a new SSD - which is preferable in these tiny laptops for heat reasons. Prefer not to heat it up with a 7200 rpm rust platter.

I don’t have much to offer beyond the observation that heat consideration would likely only matter if you’re doing intensive work on the laptop. At idle, if you’re more on Win 7 than on Linux then you’ll get more heat but likely not enough that running a HDD would be an issue. My laptops (only Zorin OS) have HDDs and they run fine - I game heavily.

Just for clarity... Are you saying the the SSD is not original to the machine being used?

Just checking back in with new info.

On the Kingston SSD - no - not original. Have had it for I think 5 years - light use - a lot of life left.

On using a rust platter. I will experiment with that asap.

I did a complete UEFI install. First time around - a massive headache, and Windows booted so slow. I clean the disk of partitions in gparted, and reinstalled both. But it was again - a headache. I had to play with the bios to get it to boot from the old Win 7 re-install disk. I wasn't sure it would properly install as UEFI as a result - but it did, but still boots slower than it did in the legacy install. So I went and installed Zorin. It installed no problem and I had Ubuntu in front of Windows Boot Manager. I still don't know if everything installed correctly - but it boots fast to grub.
Now the tragedy :woozy_face::grinning_face_with_smiling_eyes: it still won't restart - still fails to find bootable media - but still boots up fine to grub from a shut down :face_with_raised_eyebrow:.
I leaving it there for now - no time left to tinker - and it could be something incompatible in the SSD according to an article I read - or there might be something I can manually tweak in the boot code.
Dell - love hate!!! :grinning_face_with_smiling_eyes:. This old little machine can be had at a reasonable price and can hold 16 gigs (I had 8 gigs in my spare parts). It is a very viable little hiking laptop ...with a frustrating bios. Speaking of which - I haven't checked to see if there is a bios update!
Anyway - Zorin runs awesome on it.


I know you won't want to spend more money. But the issue could indeed be because of SSD brand. I've had excellent success with Western Digital SSD's.

I recommend trying with one of WD Black drives, see how it goes. And keep in mind, many of these drives can be turned into external SSD's via an external box enclosure.

So either way, it's not a total waste of money, cause they can always be used for external storage if you have an extra drive or two on hand.

Marked Solution. 366

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.