Only 1 core of CPU is recognized with acpi=off (Windows Dualboot)

This PC could not be installed as it was, and when I searched it, I found a way to add acpi=off to the Kernel parameter in GRUB. As a result, Zorin is installed. but CPU is supposed to have at least 8 cores, but the system monitor indicates only one core. (And I have not had this problem with Windows11.)

System Information:

PC: DAIV X7
Manufacturer: Mouse
Motherboard: X299-S01A
CPU: Intel(R) Core(TM) i9-10900X CPU @ 3.70GHz
GPU: NVIDIA GeForce RTX 3060
BIOS: MSI BIOS E7A941MO.A07


"cat /proc/cpuinfo" Output:
$ cat /proc/cpuinfo
processor   : 0
vendor_id   : GenuineIntel
cpu family  : 6
model       : 85
model name  : Intel(R) Core(TM) i9-10900X CPU @ 3.70GHz
stepping    : 7
microcode   : 0x5003302
cpu MHz     : 3985.867
cache size  : 19712 KB
physical id : 0
siblings    : 1
core id     : 0
cpu cores   : 1
apicid      : 0
initial apicid  : 0
fpu     : yes
fpu_exception   : yes
cpuid level : 22
wp      : yes
flags       : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc art arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid dca sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm 3dnowprefetch cpuid_fault cat_l3 cdp_l3 invpcid_single ssbd mba ibrs ibpb stibp ibrs_enhanced tpr_shadow vnmi flexpriority ept vpid ept_ad fsgsbase tsc_adjust bmi1 avx2 smep bmi2 erms invpcid cqm mpx rdt_a avx512f avx512dq rdseed adx smap clflushopt clwb intel_pt avx512cd avx512bw avx512vl xsaveopt xsavec xgetbv1 xsaves cqm_llc cqm_occup_llc cqm_mbm_total cqm_mbm_local dtherm ida arat pln pts hwp hwp_act_window hwp_pkg_req avx512_vnni md_clear flush_l1d arch_capabilities
vmx flags   : vnmi preemption_timer posted_intr invvpid ept_x_only ept_ad ept_1gb flexpriority apicv tsc_offset vtpr mtf vapic ept vpid unrestricted_guest vapic_reg vid ple ept_mode_based_exec tsc_scaling
bugs        : spectre_v1 spectre_v2 spec_store_bypass swapgs taa itlb_multihit mmio_stale_data
bogomips    : 7399.70
clflush size    : 64
cache_alignment : 64
address sizes   : 46 bits physical, 48 bits virtual
power management:

Gday @K-Orange ,
look here, it is old but has a few good points , compatibility/ect, hope this may trigger something.

Keep us informed.

Also try update in zorin & also is windows & reboot.
Im assuming this is a new pc your wishing to use as dual boot!

Added:
It maybe things like fast boot/Secure Boot!
To the point of re-downloading Zorin or refresh usb drive, like re-try creating bootable, use fresh downloaded OS,
If not created on new pc maybe try creating the bootable on new machine? if ur using Rufus,, try another , try the changes on both programs you maybe using.
The Point im getting at is, maybe it was a bad install,, The question is which part of the process is faulty?

1 Like

The last post in this thread may help?

2 Likes

Thanks for the reply.

I added acpi=ht to the kernel parameter with this link, but it does not boot with a blank screen. (Same as when booted without the additional parameter) I also tried with Rufus and it is the same and does not boot with blank screen. (I used to use balenaEtcher).

With acpi=off, you could be restricting interface with the hardware, Hence not ready CPU correctly.
( You may get other issue's as well )
Can you explain how you installed ZorinOS,
Eg;
How did you format/make the flashdrive?
How did you install?

Also, did you turn off fast/safe boot?

Please explain a little differently,
When you get the GRUB or MBR ,,
Then when select either OS you end up with a bland screen now?

This my also be of help.

Thanks for the reply.

Secure Boot/Fast Boot is turned off.

The installation procedure is as follows:

  1. recreate partition (formatted) the USB (ELECOM MF-MSU2B 16GB) with Minitool Partition Wizard.

  2. wrote Zorin OS 16.2 Core 64bit ISO file to USB with BalenaEtcher.

  3. Booted OS from USB.

  4. After the Grub screen appeared, I added acpi=off to the kernel parameters and booted. (Without this, it would not boot and would go to a blank screen).

  5. installed Ubuntu with "Install while leaving Windows on".

1 Like

Do you have the latest BIOS version?

In your BIOS, do you have a HyperThreading option and is it enabled?

Does your BIOS allow you to selectively disable CPU cores, and do you have that functionality set to run all cores?

Have you tried removing acpi=off and replacing it with acpi_osi=Windows to tell the kernel to lie to ACPI?

Have you tried removing acpi=off and replacing it with acpi_osi=Linux to tell the kernel not to lie to ACPI (it may be set to lie to it by default)?

Have you tried removing acpi=off and replacing it with intel_idle.max_cstate=1?

If that works, and the machine is stable, you can subsequently try 3, 6, 7, 8, 9, 10 to determine which cstate is causing the failure. If that doesn't work, try 0.

Do you have Intel Microcode installed?
sudo apt install intel-microcode

Also this:
https://dgpu-docs.intel.com/installation-guides/ubuntu/ubuntu-jammy-arc.html
"Please note that Resizable BAR (aka ReBAR, aka Smart Access Memory) is currently required to be enabled in the system BIOS on the host platform. For Intel based platforms, this includes most systems based on 10th Generation Intel® Core™ Processors and newer."

Report back if any of those worked for you. I suspect your GPU is falling off the bus due to the CPU entering a too-high c-state, and that's locking the machine up.

1 Like

G'day @K-Orange ,
As Mr_Magoo stated about "BIOS Update",
It made me think it maybe graphics issue...

  1. Is the motherboard compatible for Linux?
    2.Check the BIOS version is up-to-date, ( as stated by Mr_Magoo)
  2. It maybe, ZorinOS needs to run updates, & especially Drivers for you Nvidia graphics.

2 ways to do this.

1st. Via GUI>Software-Updater,
Open Software Updater after you see the listed updates,(if needed to add Nvidia Drivers),
click "Settings" at the bottom of updater window,
goto Additional Drivers 'TAB', then select your driver needed there. then.
Run updater
Reboot pc.

Or

2nd. Via Terminal.
first run,
sudo apt update
then
sudo apt upgrade.
Next
apt search nvidia-driver ,( this will give you a list of available drivers.)
After finding the driver,
run
sudo apt install driver_name
( eg, sudo apt install nvidia-driver-440)
Now
Reboot

hope this may help.. keeps us informed :+1: