OpenRGB does not work, featuring piix4

Solution Note:
"Read the entire thread, I had many problems but OpenRGB is working now"

I cannot control the RGB lighting on keyboard and mouse. It tells me that I am missing piix4 for AMD systems.

If run "lsmod | grep -i i2c" I see the following. smbus not loaded and piix4 is listed but does not show its "attached" to anything.

piix4 error 2

Help is appreciated. I am at the limits of my knowledge in this area.

I had this happen the very first time I installed and used OpenRGB.
The cause was due to me setting one of the settings wrong - I had thought I needed to add my hardware to the Supported list. I could have Disabled all in Settings > Supported.
Instead, I completely removed OpenRGB and then reinstalled it.
Both should work.

I uninstalled openRGB and reinstalled from software center. I was not able to use terminal, couldn't find openRGB.

Same error.

I had to add acpi_enforce_resources=lax to my grub boot options to get my gigabyte auroras rgb stuff to work.

Grub boot?

i Followed this guide, but starting at 3:00 in he shows how to adjust the grub line, here he uses manjaro but works for Zorin as well. not sure if this solution will work for your rgb but give it a try if it does we can go through making the acpi lax setting permanent

Ok thank you but how do you to advanced boot options? I tried ESC and DELETE.

You can use esc or tab or both for EFI boot.
For Legacy (MBR) boot, hold the left shift key down.

That should bring up the Grub Menu.

You do not need to do this to add a grub parameter, though.
Boot and log in and open terminal.

sudo nano /etc/default/grub

Add the paramter in the cmdline so it looks exactly like;

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_enforce_resources=lax"

Tap ctrl+x to exit the editor. It will ask if you want to save, so tap y, then tap enter to save as current configuration.
The terminal will revert to normal appearance. Now you must run

sudo update-grub

...for the changes to take effect.
Then reboot and test OpenRGB.
How much success you have with that parameter will depend on your hardware. For some, it works, others, it doesn't. And that parameter will also affect LM-Sensors for fan and heat control...

1 Like

ESC brings to a boot menu, only Ubuntu or BOIS
TAB brings me into the BIOS.

My SDD is encrypted, if that matters.

I used the terminal instructions but "sudo update-gub" does not work, command not found.

Well I restarted. It still does not work.

Software center said everything was up to date but sudo apt update said otherwise, almost 1Gb of updates. I restarted again, it still does not work. Same error.

That... is concerning. Can you show a screenshot?
No, I just need a brain.

1 Like

that says gub not grub ~ typo strikes again :laughing:

sudo update-grub

1 Like

Thanks for spotting... Scrolled up and it is my typo.
Corrected the post above...

Still does not work after running "sudo update-grub".

piix4 3 error

Is Secure Boot enabled or disabled in your BIOS Settings?
Have you tried

sudo modprobe i2c_dev

Then launch OpenRGB

Still does not work after using "sudo modprobe i2c_dev"

When I used terminal to update in an earlier post it said I had to enable secure boot. Should I disable it?

Are you dual booting Windows?

I am not, see my username.

Then Secure Boot should be disabled.
Secure Boot is for Windows only.

What method did you use to install OpenRGB?

I looked but how can I disable secure boot? Why did Zorin 16 tell me to setup secure boot from terminal updates?

I installed OpenVPN with Software and I test with an appimage.