Opera language in FR & Netflix

good morning,

I'd like to test Zorin on a laptop for my wife with the applications she uses every day to compare, but from the first Opera application it bugs. Impossible to put it in French. And Neflix doesn't launch the videos with the same errors on linux: 07701-1003. (I've already tried everything google offered to help me :slight_smile: )

What about another browser? Does it work with them?

Yes with firefox no probleme
But she use Opera since ....10yaers :slight_smile:

If it's an Opera problem specific, you may have better luck on the Opera forum/board (if they have any?). It may be a bug(s) which needs to be sorted out. Another option is to try beta/nightly build of Opera to see if it solved the problem.

yes. But why on liunx it's complicate to change simply the language ? in opera browser

I don't know why Opera has problems changing language. It has nothing to do with Linux but Opera itself. If you wan't to change language in Linux you simple:

Sysyem is already in french but opera still in english.

Software needs to be developed separately for different operating systems. If Opera doesn't work in one of them, it could be either the underlying operating system or it could be the version developed for it.

In this case, given how other browsers are capable of handling language settings normally, including Chromium-based ones (Opera is based on Chromium), it points to an issue with the Opera binary for Linux.

How did you install Opera, from the Software Store? If so, remove it and download the installer from the Opera website directly.

This will download a file with a .deb extension, which is the native format used by distributions such as Debian, Ubuntu and ZorinOS. Double click on that and just follow the prompt to install it. Hopefully, this should work much better now.

To give a little context, in Linux there are several package formats that are meant to run in a containerized environment, separate from the rest of the system. This is good for many reasons but also has some drawbacks, such as this issue where the settings from the system are not translated to the running program.

So, how can you know if you are installing the native package format or one of these containerized ones? In the Software Store you can scroll down a bit and read the source of the package.

In this case, Flathub is the store for one of said package formats, known as flatpak. In the case of Opera you cannot choose another source, it depends on the package itself. But when there are multiple options available you will see them at the top of the window:

Here you can actually see 3 different package formats: Snap, Flatpak and Package. Snap is similar to Flatpak, and "ZorinOS" is the native .deb package that you can install directly.

If you are confused about this I don't blame you the slightest. Flatpaks and Snaps were develop to solve real problems but they still have many rough edges to work through. For the time being, I would encourage you to try and use the "ZorinOS" format whenever possible. If you don't find it, try to visit the product's website as most of the time there's a download option with the .deb package available.

And if you have doubts, just ask!

1 Like

Hello, it's the same result :
How did you install Opera, from the Software Store? If so, remove it and download the installer from the Opera website directly.

This is most likely a check that Netflix is doing on their website, as the language changes automatically when I access through a VPN. Here I'm accessing through The Netherlands and the language changes to Dutch automatically, although the cookie consent modal still appears in the system-set language, which is French.

The same is true if I change my location to other regions. However, other websites are able to detect and respect my language settings e.g., qwant.com.

You can see a similar issue in this thread, where the only solution was to spoof the user agent to appear as if the machine was using Windows. Not the best solution, but ultimately this is on the website developers themselves to respect or not the user settings.

1 Like

I found a solution but it has to be done every time I update :frowning: . But it works :slight_smile:

Does video playback work for you?

You should advise your good lady that Opera is now owned by a Chinese consortium. It was sold by the original developer to them, so who knows what data is being gathered. His current project is Vivaldi. You could also try the Open Source alternative to Opera, Otter.

If you have installed Opera from the .deb package then you need to download the correct libffmpeg.so and put it in /usr/lib/x86_64-linux-gnu/opera/lib_extra/ to solve the video playback issue.

This one worked for me:


Hello just a copy and paste ? in the files directory ?

1 Like

Yes. you may need to elevate to root:

sudo -i

Then launch the File manager


Navigate to the necessary directories and copy/paste the file or drag and drop.

Once done, close Nautilus File manager and type


in the open terminal to exit Root.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.