Opera wont start maximize

I have read the post from Apr 22 and followed the instructions but I have a problem I can't find the Opera .desktop file so I can complete the instructions

The *.desktop files should be located in /usr/share/applications
Have you checked that location?

yes, several times

How about ~/.local/share/applications (in Home ~ Directory, tap ctrl+h to reveal the "hidden" files and directories if needed)

Or check /opt. I have never installed Opera Browser... but many other browsers place their files in opt.

no, when I follow that "hidden" I arrive at mimeapps.list and it is empty. in opt I have "brother" and "microsoft" and "screenrec"

Can you please check if you installed Opera as a Snap or a Flatpak?
In terminal run:

snap list

flatpak list

In Software, navigate to the Opera Install page and look at the Source either by clicking the Zorin Source button on the Titlebar or scrolling to the bottom of the page.

as a flatpak

1 Like

Now we are getting places. Flatpak (And Snaps) are Containerized packages. They do not rely on system files, but instead run inside their own containers. This can have good results and it can have bad results. There are many opinions about them discussed on this forum at large... And across the web. I have plenty of my own opinions. I will let you do your own reading to reach your own conclusions.

In the meantime, your options are to remove the Flatpak Opera Browser using Software...
and install as a .deb package:

Or if you wish to retain the Flatpak version, install Flatseal and search the web for a method to enable starting Opera as Maximized with the Flatpak package.
I have tried that search myself and came up empty handed but you may have more luck.

But that's how I installed opera through Software. But thanks I will install it with your download link. Thank you

Software installed via Flatpak.
You can use Software to remove the Flatpak and then use the link I posted above to download the .deb (not Flatpak) package and double click the package to run the installer.

Yes I know I have already done it and now I will follow the instructions to maximize opera. thank you very much for the help

hmm it says it is read only, how do I get around that

The .deb package says that?
In the directory in which the .deb is, open a terminal. It probably went to ~/Downloads, so you also could cd (Change Directory) in terminal to that directory

cd ~/Downloads


sudo dpkg -i opera-stable_101.0.4843.58_amd64.deb

If it is the only .deb package in the Downloads directory, you can just run

sudo dpkg -i *.deb

The (*) wildcard will stand in for any name of a present .deb package in that usage.


It just now occurred to me that by

You may have meant the .desktop file in /usr/share/applications

If so, elevate to root:

sudo -i

Launch File Manager in that same terminal elevated to Root:


Navigate to "Other Locations" in the left Pane, then "Computer" in the right pane. Then to /usr/share/applications
Right click on the opera .desktop file and choose open with Text Editor (gedit).

The above comments about using sudo dpkg -i to install packages may come in handy another day. :smiley:

yes through nautilus it works. I was not in root on the first try I think. I save all the hint I see :smiley:

1 Like

If I follow the instructions as you described in another thread, opera disappears and I have to uninstall/install opera again. Opera desktop looks like this, where and what should I change

Just a thought?


Exec=opera %U --start-maximized

In your desktop file, you also have an errant entry. You have
This line needs to be removed.

ok now i tried your suggestion but it didn't help one + is that opera didn't remove itself. ohh yes line 6 is removed now

old news with china buying opera. Then there are some who suggest Vivaldi, I have tried it but have had problems with it, it won't open or it took a long time to connect to the network

I am sorry; I do not understand this statement.
What do you mean by "remove itself?"
You can kill the Opera Browser process:

killall opera