Option to Toggle/Disable Instant/Direct Search on Keypress (Typeahead?)

While in the file explorer app (Nautilus), on pressing any character, alphabet or number key opens up the search function.

I use my keyboard for navigation more than the trackpad, and also have a wild household with a keyboard that seems to fly across rooms at will.

Accidental key presses cause this search to open very frequently which is quite frustrating, especially if I'm using my own fat fingers.

Since ubuntu already has an option to search via Ctrl+F shortcut, is there any method to disable this "direct search" feature? I only want to use Ctrl+F and didn't find any related settings in every preferences/settings menu that made sense. Tweaks didn't have it, nor did Zorin Appearance. The system Settings app only shows radio switches to disable or enable searching of specific results shown in the "Activities Overview" - I'm not quite sure what this does or how it works.

In short, I'm looking for a way to modify the "interactive search" / "typeahead search" feature in nautilus. This request comes from searching Google and Zorin Forum for every key word that came to mind - and while there are similar requests out there for Ubuntu, none had an answer.

Additional information/resource on Zorin and typeahead functionality would be amazing as well.

While I'm here; is there a way to get a title bar for these Nautilus windows so I don't have to carefully ensure I do not place my cursor on the search bar when attempting to drag a window - I do that A LOT!

Thank you so much!

1 Like

Sadly, no. Gnome did away with Window management, removing all titlebars. This allows Gnome greater control over widgets, at the users expense of user control.
To get around this, I install Cinnamon Desktop on Gnome or use Zorin OS Lite, which comes with XFCE4 desktop. XFCE is a fully fledged desktop that comes with everything you need, including a window manager, unlike Gnome which is a partial desktop that relies on tons of questionable extensions.

Gnome removed typeahead feature and replaced it with the Direct Search feature you wish to disable. There is less control over this... But you may be able to work around it:

1 Like

Thanks @Aravisian, I went to the link you provided and although the main posts didn't solve my issue, I followed the 'duplicate post' link and found the fine text leading to the alternative nemo option at the very bottom of the post-answerer's entry. Blows my mind that there are so many people out there with the same opinion about Nautilus developers going the M$ route with the usual corporate tendencies to ignore user input regarding potential issues or improvements that can be made to support quality control of the software they want their users to continue using.

As stated in my 'instant-search' post about another bothersome feature of Nautilus; I decided to drop it and swim with nemo which I've found is already 90% better for my use purposes.

Also managed to re-mount my Put.IO drive again after the nemo hiccup detailed in the linked post above - even nemo's interface/fluidity/performance/config & preference options and response are better than Nautlius when browsing these online drives...

On to the new post I promised, requesting Put.IO integration with 'Online Accounts' in Zorin 'Settings'.

1 Like

Yes, I also use Nemo File manager.

@Aravisian Can you please advise or refer me to nemo plugins which will help me identify specific folders with color or icons like (star, heart, etc.) as I was previously able to accomplish with Nautilus via right-click context menu?

Still new to Linux, I still don't understand how to properly symlink an .sh file to my desktop so it would be nice if I could open up my file manager and be able to immediately identify the folder I knew I wanted with visual indicators.

Unless you prefer to help me fix my root problem by helping set up my .sh executable for launch from desktop. The commonly referenced 'Allow Launching' option didn't appear in the context menu when I was trying this with Nautilus, but I doubt it was a Nautilus issue.

If you want to stop helping me, I'm willing to accept monetary compensation from your group so I can help others as I assist you and also learn about feature-rich Linux distros like this one. :joy: #dreamjob

No plugins are needed. Right click on the folder you wish to change the icon of, select Properties.
In the Upper Left of the properties window, you will see a Square Button with the icon in it- click that button. You can now change the icon from the selection window.

To give a File (such as one on desktop) exec permissions:

chmod +x /path/to/your/file.txt

Wish I was gettin' paid... :expressionless:

1 Like

I wish that for you too.

I don't see the Square Button with an icon in it. What am I doing wrong? Is this specific to Nemo?

Regarding the symlink - .sh executable issue: I am unable to to install the software normally via terminal commands you mentioned/Synaptic. The program is called SongKong and is proprietary; I think that's the reason for it anyway.

Thank you for the link and snippets of code to try. Is there a way to have the command: ln -s /path/to/file /path/to/new/location also print out a log of what went wrong if unsuccessful? So far I've been unsuccessful trying everything I managed to find on Google -- which was a lot. I also tried copying the general format from VLC player .desktop file with no success.

I've actually accomplished this desktop linking task once before with just a basic link to my UE5 Editor; working with icon image and everything...

[Desktop Entry]
Name=UE5 Early Access
Comment=Launch Unreal Editor
Exec=python '/home/aj/Keepers/Unreal Engine 5/UE5 EarlyAccess/Engine/Binaries/Linux/UnrealEditor'
Icon=/home/aj/Keepers/Unreal Engine 5/UE5 EarlyAccess/Engine/Content/Splash/Splash.bmp

I just can't see how any of it is different than what I'm trying to do with this SongKong application.

sh-desktop launch

[Desktop Entry]

I've tried using paths with and without the quote. I've also used the chmod +x /path/to/my/file.txt. I've also tried turning the file.txt into a file.desktop + chmod +x and chmod a+x (as guidance I found suggested) performed on both. My world isn't ending although it may seem like it, I just prefer making this more intuitive rather than less.

Is there something specific I have to do in order to get this to work with certain paid applications?

Using your image, I put a Square around the button in question:

I think you may need to go into more detail.
Creating a symlink will always create the symlink.
Whether the link itself works or not depends on whether what was linked works.
Can you clarify if the symlink is created, but not launching - etc?

This should say Exec not TryExec

The TryExec line is just left over from when it didn't work after attempting with the "VLC.desktop " [Desktop Entry] format copy/paste you can see above.

I figured I would try editing that path line to something applicable to the application I was trying to run. If it didn't find songkong in usr/bin, no harm no foul; it doesn't make sense to me that a wrong TryExec= path would wreak havok and attempt to create or destroy anything. "Look for something here to execute by this name, if not found then return" If I'm wrong, I'm okay with that.

... only problem is that I can't get it to execute the link on the desktop. I know the paths are correct because after the first few failures, I gave up trying to type the Exec= and Icon= paths over and over again and just dragged and dropped after chmod, etc.

All I wanna do is double-click on a desktop icon to start this obscure application sitting in my /home folder. I would prefer to avoid navigating to the same /home folder each time just to start the application.
A Super menu entry would also work.
If I could get both Super menu entry and an executable desktop icon for this one application, my life would be complete. :wink:

I really do not understand what is going on here...
If the item is located in your Home Directory, why are you creating a desktop file referencing /usr/bin?

Did it attempt to destroy anything?

No, I will create a new post. Essentially all I wanted to do was create a desktop shortcut which calls program.sh and launches it. I can't seem to get this to happen and don't know what I'm doing wrong.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.