OS 16 hdmi audio issue

3rd attempt to switch to Zorin from win.

Its one of the best UI distros out there, and have been wanting to switch to it for day to day use.

OS 15 got stuck with Nvidia on dell G7, which looks to have been sorted in 16.

However, now stuck on Dell Latitude E5440 HDMI has no sound. If I try the test, (clicking on test left or test right) will eventually produce some audio (after 10~15 seconds), but still no audio once test is closed. Pavucontrol shows all as expected.

Any help appreciated

Did you try a diffrent hdmi cable too ?

1 Like

its a dual boot. windows 10 works fine

1 Like

Let me look into the Sound issue more. If you could...

sudo apt install inxi

Then, paste the output of the following here:

inxi -Fxz

however, I'm enjoying the holiday so I may be gone eating a large meal and talking to family

1 Like

In terminal, type alsamixer

post a screenshot of the resulting sound settings here.

Like others, I'm celebrating Christmas, so may not be on here much over the holiday, so please be patient.

1 Like

Try this: HDMI picture but no sound

I've also recently discovered on a few distros I've been playing with have no sound but on opening sound in Settings the volume is set to zero and as soon as you start sliding the volume control you'll hear the 'ping' notification sound.

I have this problem example when my jack phone and cable creating short circuit. It could be problem with port pins or cables not correct abut. Trying diffrent port or recognize a correct drivers when installed correct some plugins alsa or another things. This is not problem software operating system but hardware. When you find correct drivers then sound will back to normal working. It happens when you start operating system or restart system? Check in bios if you don't have off or on some hardware audio options.
Good to know what audio soundcard you have or using some dac ? Dragonfly?

Hi Thanks. attached

Hi thanks. that's a different issue

1 Like

everything shows fine. sound levels are correct

it is not a hardware issue. As I mentioned, it is a dual boot and switching to win 10, everything works fine. Thanks

What happens in alsamixerwhen you hit [F6] and choose the other sound card you have?

Not sure what you mean? Sound is fine in local laptop speaker

It remind me my problem when bios or cmos have saved drivers correct for windows but switch to linux not recognize because they are not working. Clear bios and then maybe help. I know Bios have some memory. Can you checked if you have hard reset bios?

Sorry I read "No sound" as applying generally, not just HDMI only.

Hi. On the sound output in settings, are you seeing "Dummy Output"?

The final fix that worked for me came from support. This immediately changed my card from showing Dummy Output to the correct HDMI choice under the sound output.

If your sound device is still listed as "dummy output", please try opening the Terminal (Ctrl+Alt+T) and running these 2 commands:

  • echo "options snd-hda-intel dmic_detect=0" | sudo tee -a /etc/modprobe.d/alsa-base.conf
  • echo "blacklist snd_soc_skl" | sudo tee -a /etc/modprobe.d/blacklist.conf

Then, please restart your computer to apply the changes.


I had marked the last post as "Solution", but then realised that post was not from the OP, so unmarked it.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.