Partial upgrade

okay, this is the second time this is happening to me. i update the computer and it gives me an error saying unable to upgrade, run a partial upgrade and it shows me the files that it will delete and what it is upgrading. all seems well until i go to restart and all i get is a white flashing cursor in the corner of a black screen. last time i just did a fresh install this time i was able to get into the zorin recovery and then boot from that and get in. what the heck is happening any and all help is greatly appreciated as i am not a complete whiz kid on linux and i am still learning ins and outs

Should be able to look in var/log/dpkg.log to see what failed in the update. The log will be large so try filtering by date like

grep "2021-05-15" var/log/dpkg.log | grep "status error"

I think it's status error* might be failed

im unfamiliar how to pull that report

i did however figure that out, but looking at todays report it isnt showing anything that jumps out to me as a problem

In terminal does
sudo dpkg configure -a
Return any errors?

that command doesnt seem to work at all

If there's no error or anything to action it won't return anything, that command configures any package that's in a pending state.

When I recovery mode do you remember what you do to fix the install? Was it rolk the kernel back? Or did you just boot into recovery and reboot? And it worked

yes i just used the recovery mode reboot and it worked, upon researching the similar issues others have found things seem to point to lightdm? but i have no clue, im using zorin 16pro. and when i tried to use those methods im still left with a black screen with flashing cursor at reboot

as of now im only getting into the laptop by using that recovery screen, which is largely impractical

Hmm I think* I may be wrong but I think pro/core uses gdm, and lite uses lightdm

Try sudo dpkg-reconfigure gdm
And either reselect lightdm or try gdm and reboot.

may of found the problem,
harley@ZorinOS-Latitude-E6430:~$ sudo dpkg-reconfigure gdm
[sudo] password for harley:
dpkg-query: package 'gdm' is not installed and no information is available
Use dpkg --info (= dpkg-deb --info) to examine archive files.
/usr/sbin/dpkg-reconfigure: gdm is not installed
harley@ZorinOS-Latitude-E6430:~$ sudo dpkg-reconfigure lightdm
dpkg-query: package 'lightdm' is not installed and no information is available
Use dpkg --info (= dpkg-deb --info) to examine archive files.
/usr/sbin/dpkg-reconfigure: lightdm is not installed

so now how do i get that back cause it appears gdm isnt there

Does sudo dpkg-reconfigure gdm3


nothing happens other than a new line appears. doesnt seem like much happened. i will reboot and try again though

annnndddddd nothing. still same boot issue

ok you should have seen a screen like this

try sudo apt install gdm3

i managed to get the same pink screen, made sure to select gdm3 and then made sure lightdm wasnt running. rebooted and still have nothing. for what its worth i was able to get that flashing cursor screen on bootup to show me username and then prompt for password but that didnt work to let me get in.

i hate to have to reinstall zorin again, i really am getting tired of doing this everytime and update through software update doesnt work correctly.

in the console login, after logging in does
return any errors? or do anything?

that would be ctrl alt f7?