Partitioning and Installation, Help!

Hello
I Reinstalled Zorin os to get the partitions right
but after several installing attempts which all of them failed, idk why
I did follow every step in the guide in [how to] partition and install Zorin 16
all ended to the same result; grup rescue no such partition.
Plz need help asap.


I'm not one to give advice on this topic but just in case, there's a guide to repair the bootloader, hopefully that helps?

1 Like

My old laptop can't be fixed with boot repair
it has legacy bois.

For what its worth, my ancient laptop with BIOS was fixed using Boot Repair disc, back in the days of Z12, Z15 transition.

Maybe a Gparted screenshot posted here would be a way for us to see what partitions you have set up.

Screenshot from 2022-03-30 13-54-55
I don't have an option for UEFI, Edited the post with my gparted and disk config.

Your GParted image shows missing flags for '/' and '/home'.
The Fat32 Partition is only needed if your machine has UEFI/EFI and it would be too big anyway - Fat32 partition size for EFI only needs to be 50 Mb not 500.
For '/' (root file system) I would make 50 Gb - if this is a spinning hard drive then Ext4 is fine - if it is for an SSD then it should be Ext2.
The same applies to '/home'.
My initial advice on partitioning was 30 Gb for '/' on the unofficial manual for Zorin 15 but then I had an issue with another OS based off Ubuntu that ran out of space, so I would always aim for 50 Gb for '/'.
Check out my ancient Dual Boot Video here (Zorin 9 with Windows 7) 34 minutes 50 seconds in:

https://vimeo.com/manage/videos/110085401

Unofficial manual:

Page 12

image
image
those are 2 images to give you a brief idea about how simple this bios is.
look I did the mount points in installation not in gparted
After the install i was ordered to restart so I did but i got the grup rescue prompt when i was checking the listing i found out that the root and prefix was put on a partition that wasn't even made. like the system was on (hd0,msdos2) and the root and prefix was on (hd0,msdos5) after i put them in the paths i tried to insert "insdos normal" i received that it wasn't even there and got stuck there.
Got any ideas about this problem?

That second screenshot is really blurry. Can you type in the Product ID and reply here please? Thanks.

It's a hp pavilion g6 1256ee, the images above have the exact bios but not my laptop.
Sorry can't get you the product id as it's hard to boot up from the usb and login to stuff.

Is there no serial number label underneath? Sometimes the battery needs to be removed.

Just had a look at this page:

https://support.hp.com/gb-en/retired-products

It is a retired product so no BIOS updates available.

Just remembered that it is likely that the FAT32 partition is usually HP recovery/factory restore partition which could be the issue. Personally I would flatten the drive - delete all partitions unless you want to sell on with Windows at some point.

yea ik

do have any idea why insdos normal doesn't work ?

I have deleted the drive a couple of times now :] and made the partitions from scratch but all to the same result, if only you could guide me through grup rescue prompt.

I've never had any success with any grub repair tool. Recently I had to do a manual grub repair on a family member's machine after a Windows App under Wine screwed up the graphics and the OS I was working on booted without GRUB:

I think my problem is just paths, can you tell me about the commands i need?
and i will try my best.

If you still have that 500 Gb FAT32 partition you need to start by deleting all the partitions on the drive. Once that restore partition has gone, things should install better.

I got depressed and forgot about making individual partitions for zorin.
I installed it normally.
Thank you very much you and the others in this post that tried to help me :heart: :heart: