Path to external folder not recognised for the first time

I have a folder on another partition which holds my websites and related stuff, there's a link to it in the filemanagers' sidebar.

After a fresh restart I can not open this link, same with Pulsar: it doesn't recognise the path.

To solve this I first have to open this folder using "Other locations", just once and then all applications can find it too.

I guess there's some setting in some config-file somewhere, but I can't find anything about this.

Is this solvable somehow?
pulsarstarterror

I am wondering if it is a files permission issue?:

https://help.ubuntu.com/community/FilePermissions

I thought so too, but every user can create and delete in every directory in the path, I just looked that up.

The system assumes that the directory does not exist, until I basically show it that it does by opening it with "other locations" and then every app can do what it needs to do there.

It wouldn't be that big of an issue but Pulsar especially needs to keep the tabs alive, I often have ten or more files that I am working on at the same time and need those tabs back the next morning when I want to go on, otherwise I do not know anymore which files I was working with.

I had the same with other code-editors and thought the app itself was the problem, but clearly that wasn't the case...

Don't know if this helps or hinders:

I know you stated that you can only access using Other Locations. There has been another post recently about issues being caused by Nautilus (renamed by the Gnome Devs to 'Files', but it is still Nautilus at the end of the day (a bit like Teams is really Skype for Business!).

I was wondering what would happen if you installed a different file manager, such as Thunar, (from xfce) or Dolphin (KDE Plasma) - both should be available via Synaptic Package Manager. I am sorry I cannot be of much use on this topic. I mainly advise on creating separate NTFS Data partition so that both GNU/Linux and Windows can access the same data location:

Thank you, this works! Pulsar now remembers the path to the files, one more (for me) highly important issue solved. However: there is a new thing now, Pulsar does load the files in the background but now another message pops-up: "Authentication required, the login keyring did not get unlocked when you logged in to your computer".
Ofcourse: I can login and get to work, but it might cause the same issue when I want to open this directory in the browser on localhost (xampp), so better to get that keyring-thing out of the way by default...

But I will do a search for that on this forum and when I can't find a solution I will open a new subject on this for backreference later when needed.

I guess that's basically exactly what I am doing here, it's on a separate partition and I can access it from both OS's directly.

Thanks for your extended reply, the issue is solved using the "Disks"-utility as mentioned in another reply here, but I dó read the sources you mentioned as I need to learn a lot, there's a long way to go...

I am gonna sound silly here, I know, but I can't find any general security-settings, I see firewall, users, keys etc. but no security in general...

But I have been looking at the properties of the targeted folder and it seems like I should be able to do everything on it (screenshot), so I am a bit lost now and don't know exactly what to do.
I am not afraid of using the terminal if easier, like Chmod-ding this folder or so, but I guess I'd better wait for a direct solution instead of experminenting and googling around for 3 year old answers etc...

websitespermissions

Thanks for the extra lesson, I did do some reading about this but now I can connect the dots.

I think I got it working, restarted a couple of times and Pulsar remembers the previously opened files without any screen asking for something, just starts where I left as it should!

The full filelocation is now: /mnt/F0E4C80BE4C7D1D0 ntfs-3g defaults,umask=022,uid=1000,gid=1000 0 0/Websites

So it includes everything that I edited in disks which is okay, I can copy the last part and most important of all: it's working.

Again thank you, I will pick-up the Linux-way of doing things and yes: preferrably as safe as possible...

1 Like

Another problem arose from this: I need to set the directory of the websitefiles in /etc/apache2/apache2.conf but when I use: /mnt/F0E4C80BE4C7D1D0 ntfs-3g defaults,umask=022,uid=1000,gid=1000 0 0/Websites as directory apache fails

Yesterday I tried to do it with XAMPP but couldn't get it running and I uninstalled it aiming to use the pre-installed apache, PHP and Mysql (I managed to upgrade php to 8.2 instead of the default 7.4)

What directorypath do I have to set now to get apache serving the webfiles?

I do not want to relocate them to /var/www/html/ because I have a separate partition on the drive that needs to be accessible from several locations, not only Zorin and I also do not have write-permissions in that folder if I wanted to.

I do not really need Apache, I would be happy with only PHP, in windows I used a batch-file instructing PHP what to do with the command:

D:\path\to\php.exe -S localhost:8080 -t D:\path\to\Websites

Can I do something like that here in Zorin too?

Wait: it's my machine, it's my software, I am the only user of this machine, why do I not have permissions to anything I that want to do?
Why am not the owner?

This does not make any sense: Zorin is supposed to be easy to use for everybody, but I am struggling to only get the basic things going, I don't want an external authority telling me what to do and what not with my own machine and my own files.

Surely there must be an easy non-complicated way to do things, there is nobody ever going to use my machine and I will take care when I do stuff online.

And I have been Googling (better: private duckduckgoing) a lot yes, it's not that simple as you state it, just do some google-search and everything will work just fine.

Sorry that I spoiled your thanksgiving, we don't have that here.

I will find my ways, thanks again.

Changes to Root can be devastating and break the Operating system.
Any unauthorized access to root can infect the machine. While it may be true that only you will access this computer, that does not protect you at all when accessing the Internet and World Wide Web.

1 Like

I understand about safety, but this is not the only thing: I can not open any file by using open with other than with the default text-editor, that's another thing, Pulsar is a standard install from the software section. And how do I get apache to run on the websitefiles in the separate partition? Xampp isn't working and Apache fails when I enter the new path/to/websitefiles

And I already have been busy for days only to get the basic things going, googling and googling and trying and trying to let me tell me that I need to do a simple google search?

I know about the dangers of the WWW, I just want to be able to do my stuff on my own machine and yes: I know how to do everything as root but is there no world in between over-complicated and totally unsafe?

If I install an application myself to work on files that are mine, then that's all my decision and my own responsibility. This is going too far: I only want to be able to edit files that are mine on my machine with the apps that I choose, if Zorin just like Windows treats it's users as if they know nothing then it's nothing different thán Windows telling you to do this and not to to do that.

It's a pity that it has come to this just because of these restrictions, I like Zorin a lot and I was getting used to it already but I also want to be a bit free in what I want to do without the OS obstructing all the time.

I must rethink this, it's all becoming too much hassle only to be able to edit some php-files, a bit over the top for me at the moment.

I think it is more that Operating Systems do this. All Linux Distros generally do as does Android and MacOS.
I find MS Windows to be the most restrictive, by far.
In the old days, Kali Linux used to install as Root - and that was it. No User Accounts. Everything was done from root. Sadly, that has now changed.

I agree with you that googling is not really an answer. It can lead to answers, if you know what to look for and are fortunate in your search hits. But it's a lot like the difference between going to the Library and attending University. You are not going to get a guided and formatted education at the library.

You are likely feeling a bit overwhelmed given the newness of it all combined with just trying to get what you want to work how you want it. Given all the google searches and different inputs and information; no wonder it feels a bit too much.

If I might suggest taking a step back and taking things One Step At A Time.
Some of what you describe can be solved by moving some relevant files from Root to Home and assigning the permissions to yourself (a one time action) so that you do not need to enter a password or worry about permissions for those items.
Permissions and ownership can also be set on an entire drive or partition - so that you do not need to enter credentials each time.
Avoid Flatpak or Snap Packages. They are containerized and will isolate from the system. (For me, I remove Snapd and Flatpak entirely and the my Software Store does not list or offer any Flatpaks or Snaps).

I am kind of jumping into this thread in the middle of it... So I would need to catch up to everything so far.

Okay, this is the story:

I have files on a separate partition that I want to access from different OS's, I often work on 10 or more files at the same time and when I stop and shut down the next time I need to open the editor (Pulsar) with all the files in tabs still there.

I was able to add these files as a projectfolder to Pulsar but every time I rebooted Pulsar couldn't find the directory anymore, only after I opened it with the "files"-application first.

That was solved after editing the Fstab but I need those files for other applications too like Apache and thus edit the documentroot in the apache-settings, but with the new path/to/my/files being:
/mnt/F0E4C80BE4C7D1D0 ntfs-3g defaults,umask=022,uid=1000,gid=1000 0 0/Websites
Apache fails to start

1.: And that's it: I just need Pulsar to remember the last items I was working on and load the projectfolder after I start it.

2.: Right-clicking on a file and use "open with", does not work for Pulsar, only for the default text-editor, which is okay for editing a simple file, but not for a whole project containing PHP-files etc. You need a tool like Pulsar to work on that.

3.: Apache needs to be told where the files are, by default it looks in /var/www/html/ and you can alter that in apache2.conf or httpd.conf (when working with XAMPP)

These three things work flawlessly on Windows, but Zorin obstructs this all.

And there will be more in the future I am sure, this is only the beginning, so I just want to be able to do what I want to do and have all the rights that I need for that and basically for everything that I want to do. But now it's either a fully open OS to everybody or having no access at all, there's nothing in between.

And that's what I mean: Zorin treats all users as morons and is way too overprotective by default, it would be much better if you can grant rights to certain users who know more than average and do other things than being on facebook all day.

So I don't really care if I am granted root-access to everything if there's no in-between possible, if I mess up I just reinstall the OS and start again.

So if anyone can tell me how to work with Zorin with full rights to everything and have Zorin mounting everything that's on my PC (I have more partitions that I want to use in the future) I would be happy with that. Nobody will ever use my laptop and if someone would they can't login because they don't know the password, sounds pretty simple to me.

Really: what happens now is that after installing Zorin it by default takes away all your rights to all your files and folders and you have no choice in that. It would be much better if right after install Zorin comes up with an application in which you can setup user-accounts and priviliges easily, just like every other management-system being an OS like Windows or a website where users can create accounts: there is always an admin who has access to everything and every user-account, but there's no admin-account in Zorin, it's either all or nothing at all.

So if that's it, then please give me all, I want to be able to do everything, even make stupid mistakes of which I will learn, I have all my personal files safely on a separate partition and I back them up on a USB-stick every day and next to that they are on an external harddrive too.

I can ofcourse do sudo bash in the terminal, then I am root@erwin which gives me all the rights. But will that also mount all my partitions by default and grant access to files to applications like Pulsar by default?

I would be very happy if someone can tell me how to have all the possible rights and access to all files and folders with whatever application I use right after logging into Zorin with my user-account.

And yes I have noticed that these packages cause problems, that's why I ditched Opera which was my favorite browser. But if you go to the software-section all these apps seem to be mixed-up, so removing Flatpack and Snap is the first thing that I am going to do, but I do not understand why they are installed by default if they are known to cause problems while Zorin is so keen about keeping the system running smooth, it shouldn't be offering these high-risk applications in the first place.

Really: Googling for solutions is about the riskiest thing that you can do, Google shows you what it wants to show you, not what YOU need and puts the websites with the most chance to conversions and sales on top, even if the articles are 5 years old. Google is not there for you but for it's own bankaccount and telling people how to do things in Zorin by asking Google is about the worst advice you can give, this is where forums like this can be golden.

Thing is: if you go to the Zorin Website everything looks very professional and this forum is an awesome application too. It all radiates professionalism and trustworthyness and the homepage gives a message like: just install Zorin, it's all a piece of cake and then you can go on with your stuff as you were used to.
But the reality is far from that: you're either a noob or a full-stack programmer/developer according to Zorin while it should give you the chance to set up your user-profile easily right after install.

Thank you for coming back on this, I was really ready to ditch Zorin and I already had my Windows-boot-USB ready to repair the MBR but I do not want to go back to Windows and I like a lot about Zorin.

One more thing: I have been holding back on other problems not wanting to overload this forum with issues and trying to find things out on the internet, but like yesterday

  • the network-adapter failed again and I had to hotspot-connect the phone and reinstall the drivers.
    -On the phone-connection I have full signal, in Zorin one or two levels below full signal and websites are loading not as fast as they should,
    -connecting through SSH with the webserver is extremely slow.
    -I had installed a small application that shows me another desktop-background image every 5 minutes, today it stopped working, just like that
    -and there will be more, because I just started setting up the basic stuff

You see? Zorin is not that stable as it says it is and that is by default and it's usability-level is way too low, if I encounter these problems with my humble level of knowledge then nobody I know will ever be able to use Zorin just like they use Windows and you should not pretend that it's all so stupid simple to switch to Zorin, that's just a commercial lie like you find everywhere on the WWW nowadays especially when Googling. Just be honest and warn people of what they can expect, my 84 year old mother or my wife will never be able to switch to Linux this way.

If you can help me get back on my way and go on with my things without being disturbed by the OS anymore then yes please!
And if I mess up, I will just reinstall Zorin, don't worry, I can handle that.

I think that our approach and perceptions are really important.
For example; Flatpak and Snap are included by default as it allows users full access to their options. There are pros and cons to everything and any and all software and hardware can cause problems or have driver issues, on every OS in existence.

The most helpful thing you can do is separate topics out and focus on one issue at a time. Having multiple different topics in one thread confuses the issues and it also leads to feeling frustrated.

For example; you are saying:

I can understand that as you examine file permissions you might feel pretty fed up and reach certain conclusions. But the above statement is inaccurate. You have full access to all files and folders with read/write access that you have ownership of. 100% full access.
By getting frustrated over one issue that is tasking you, it is natural that will inflate in your mind - it became that somehow, Zorin OS took over all your files and you lost access to all your files and folders. But we all know this did not happen.
Zorin OS has millions of downloads and the forum is not inundated with users complaining that Zorin OS locked them out of all of their files.

I am sure you can understand that any of us will have a very hard time narrowing down what the issue is when we must bypass claims like the above.
This thread has a marked solution. What this tells me is that at that point, the thread must have been on the right track and getting things sorted out. I believe that should be our starting point in examining what you need your computer to do and what behaviors you expect and how we can help you accomplish them.

I might also add a further suggestion: You may be well suited to try testing Zorin OS Lite. Zorin OS Core uses Gnome Desktop. Gnome relies on the Gnome Shell and Gnome Shell extensions. When you add software that operates on the desktop, it needs to be able to mesh with the shell. Some of what you describe may be more readily solved simply by switching desktop environments. The Zorin OS Lite XFCE D.E. may be more familiar to you, coming from Windows and what you know - as well as more accepting of the addition of third party software.

No one switches from one O.S. to a new O.S. easily. Zorin OS aims to smooth that transition to GnuLinux. But that doesn't mean it is guaranteed to be easy.
My own transition was quite tumultuous and I nearly went back to Windows several times. But after I began to embrace the learning curve and get a handle on the new concepts, things began to easily fall into place. Before long, I felt back in control. Now, I cannot imagine ever having to go back to Windows.

Thank your for this extended explanation, I see what I have done wrong here.
I took Zorin off of my laptop, because I kinda lost track of the changes I made and want to do a fresh install and start anew, which is very easy with Zorin to do, I do like a lot how the complete package is designed.

At the moment I am preparing myself for this, reading more into things to have a better overview of what to do and what not to do to set up the environment like I need it to be, I am the sole owner of this machine and I do not need user-accounts really, this is where all the complications start.

Is there a way to install Zorin for a single user having all permissions by default?
To bypass this whole user/permissions-thing from scratch?

(I also do not use this in Windows too and I like to run applications as administrator and I never messed up anything and if I would I just do a clean install of the system and start again).

Thank you, I'll connect the dots yes, at least I am aware of the possibilities and impossibilities now and I understand what options there are.

I do sometimes wonder if it is better to have a separate standard user account from the automatically generated one at boot. I have noticed using Devuan, Antix, MX-Linux that the first named user is a bit of a hybrid sudoer. I think depending on the nature of packages installed and which parts of the system are going to be touched, the user password is all that is required. On security updates it usually asks for the Root password - which in these other OS's gives you the option to create a separate password for Root (which is what I tend to do). I always remember an issue being brought to light with Freespire that the first user added to the system had automatic Root privileges, and once I was aware of this, made sure that the first user was named Admin and me as the second user as Standard. Something to consider. I vaguely remember that Windows had 3 levels of user, Administrator, Super/Power User, User.

I endorse this statement. This is an action I would never do as the moment a user creates any direct connection over the web, their system is compromised.

The O.P. likely is not looking for this as a solution, either. The X - Y problem becomes first and foremost.
Rather, they are trying to ensure that they have all necessary permissions for performing their external drive access and mount points.

A plain simple example: I opened Pulsar / new file typed in 3 letters and tried to save as .txt on the other partition. I did not have enough rights to do that.
That's going way too far, a user / owner of the machine should have access to all drives by default because he IS the owner and he HAS all rights to do so, that's his own responsibility.

Or at least he should have been given the opportunity to choose.

Most Linux-distributions are creating false expectations on their websites, making it look like it's so very easy: just install it and you're good to go.
Some distributions are all over the internet being the easiest ones for Windows users who are looking to switch and Zorin is one of them, but that's all not true.

Linux is completely different and I am not talking about the look and feel but the functionality, it's not PnP, it's a lot of work to be able to do what you want to do.

There is no standard-user, everybody is different and there should be an option at install or a simple tool afterwards where you can define how you want your machine to work.

At the momen it's like having to type in your password in your car whenever you want to switch gear, it's over the top.

There are some distributions that actually let you make an administrator-account and a user-account like Debian, that's a good basis for further setting-up the machine.

Again the same comparison: once you have a drivers' license you should be allowed to buy whatever car you want. This is the whole idea behind Linux: freedom.

Again: creating false expectations.

I know I will manage to build myself a machine that fits me, but 99% of the population does not have the knowledge to use Linux from scratch and if they try because of all this false information all over the internet, they'll switch back to Windows quickly and never try Linux again. But if you warn people upfront, then the ones that choose to take a plunge will be happy with every succes they have bacuse they knew from the start that it would not be as PnP as Windows is.

Just be honest about it: every distro should have this information on their websites, people have the right to be told the truth.