Popping noise as sound goes on/off

I don't think it was doing this before. Might have been an update or something I did.

I tried to change these settings but couldn't set values. Then tried to run the script but it didn't run.

audio - Linux Ubuntu Speakers Popping every few seconds - Super User.

Zorin Core on an old Lenovo desktop. No need for battery saving by turning off sound.

Pulseaudio needs no excuses; it does what it wants.

Uninstalled it.

Put the script in a text file and changed the extension to sh. Clicked on it and chose Run in Terminal. I think I saw it flash briefly. Also tried just Run.

Do you have alsa / Alsamixer?

Don't know what that is.

You can check with

sudo apt install alsa-base

Got the script to run. Took out the references at the top (is this SOP?). This time I got a login and it seems to have worked. Yea!

Not bad for a two week noob, including all the other stuff I fixed.

Edit: Nope, doesn't survive reboot, have to edit a file.

1 Like

True... as I would not have thought it has only been Two Weeks...
Welcome to Linux Adept. :grin:

Got: alsa-base is already the newest version

1 Like

In terminal run


You should see your sound settings open in an interactive UI within the terminal.

I did. Don't see anything to stop audio suspending.

I see reset and clear.

And you already checked the Power Save suspension configuration?

sudo nano /etc/pulse/default.pa

Comment out this line:

Automatically suspend sinks/sources that become idle for too long
#load-module module-suspend-on-idle
systemctl restart --user pulseaudio

How do you comment out something?

BTW, the script worked until I reboot. I tried to edit alsa-base.conf to prevent that but it won't let me! I am the only person using this computer. How can I not be allowed?

Can you please outline the steps you took and what message the system gave?

Commenting out, in this case, means placing a hashtag on front of the line. A hashtag tells the system to Ignore That Line.
For example:

This line is read and adhered to by the system

#This line is exactly like the one above, but ignored by the system.

It's already got ### in front of it. You want 4 or 1?

1 is all you need... but if it is Already Commented out- then that venture is pointless.
Let's try looking at something else...

sudo nano /etc/modprobe.d/alsa-base.conf

Look for this line:
options snd-hda-intel power_save=0

If it is not there, then paste it in at the end of the file (Move to the end using arrow keys).
Then ctrl+x to exit, y to sya yes to save, then enter to save and exit.

1 Like

I am not allowed to edit alsa-base.conf.

Apparently, I'm "not the owner" of this PC.

That script was supposed to edit it but didn't.

Ownership of files...
What Message did the System Display?

File is read only and I am not allowed to change.

Is Root the owner?

sudo -i

To elevate to Root. If need be, you can change the file access from read only to read /write. Any of:

chmod 666 /etc/modprobe.d/alsa-base.conf

echo 'options snd-hda-intel model=mbp55' >> /etc/modprobe.d/alsa-base.conf

chmod 644 /etc/modprobe.d/alsa-base.conf