Problem with installing wine | held packages

Dear Zorin Users
I don’t know how exactly I did it, but I got into problems during installing wine from
I just copy and paste all commands from the download section like I always did, but it doesn’t work and i have no idea how to fix it.
sudo apt install --install-recommends winehq-stable

I got:

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
winehq-stable : Depends: wine-stable (= 6.0.0~groovy-1)
E: Unable to correct problems, you have held broken packages.

Both dpkg --configure -a, fix-broken and autoremove cannot solve this problem.
Trying installing with synaptic is also not successful. I do not know why, but in synaptic I even see this packages are doubled -as showed below:

If Synaptic menu Edit->Fix Broken Packages can’t fix them, then try the specific steps at for 18.04. If those are the steps you followed, then try #1 & #2 here: NET Framework 4.5.2 - try after attempting complete removal using Synaptic.

1 Like

Your commands above show that in following the steps, you are trying to pull from Ubuntu Groovy Gorilla instead of fromUbuntu Bionic Beaver.
The problem with many Linux users writing instructions is that they seem to forget that not everyone is using the exact same distro at the exact same Time as they are…

I do not see them as doubled- I see Stable, Stable-dev, staging, staging-dev… I think that is normal.

You do need to Remove the Groovy Gorilla PPA that you added. You can do this from Synaptic. From the menubar, go to Settings > Repositories.
Once you remove the Wine Partial Install per Carmars post… You can install WINE using Zorins own repo

sudo apt-get install windows-app-support

Or you can search “windows-app-support” in Synaptic and install from there.

1 Like

A post was split to a new topic: Keys not working with Windows applications on Wine

i've run sudo apt-get install mono-complete

. wine mono hasn't appeared and installed yet.
is there another way? thanks you

This command installs Linux Mono, not on Wine. If you want Mono in Wine, you can use a Windows installer.

I want to install wine mono .

Available here:

You might also try:

sudo apt-get install winetricks
winetricks dotnet45

I've tried it. still same. wine mono has not appeared either.

I just tested this on my machine and it works fine...
Are you looking in ~/.wine/C: ?

I tried to install dotnet 4.62 and dotnet worked but dotnet 4.5 and dotnet 452 didn't work.