Problem with keyboard/sound/video playback on fresh install - Zorin lite

Hi, first I would like to apologize since English is not my main language so there can be some mistakes. I have a laptop formerly on Windows (Asus Eeebook X205TA) which worked fine but after thinking about it for a while I decided to switch to Zorin OS lite. The main reason is security, but also stability and speed. First time I tried to install the trackpad didn't work and during the install configuration the laptop froze. I waited for about one hour then decided to force reboot and try again.

This time the trackpad worked for some reason and the install didn't freeze at all. But once the installation was over and the laptop rebooted I noticed many problems:

  • No sound: For some reason it got no sound at all. The sound icon isn't mute or anything and I tried several settings or just to use my laptop speaker instead of my external ones but nothing works. However I suggest it's linked to the second problem:

  • No media playback: First time I noticed this it was when I tried to play a video on YouTube. It simply didn't play at all, video kept "loading". And after many tries it never really worked except about 2 seconds sometimes before "loading" again. So I decided to try some audio files I already have but it is basically the same, player have a hard time to even play it (sometimes timeline sticks to 0.00 or moves slowly) and as I mentioned before no sound at all.

  • Keyboard problem?: This one is a bit tricky. I sometimes have a lot of trouble while typing but I don't really understand the problem. Yesterday the message I was writing to my friend on messenger was sent even tho I didn't hit the enter button and my mouse was far away. Also some other times while I was still writing a message (a mail for example) the writing box left and a program launched, quitting whatever I was writing and making the software the new main window. I'm pretty sure it's not my fault since I never hard this issue back on Windows 10. Also I tried to type slowly and the "program launch" problem occurred while I was simply a letter with my far away. Also I got many more spelling mistakes than before.

If I can't get to resolve this I guess I have to go back to Windows since my main use is writing eBooks and listening to music but it will be difficult and painful since despite the above problems the laptop is actually a lot faster and I like the ergonomic and design. Zorin takes twice less of storage as well. And security is a factor for me.

Unfortunately I only have this computer and I really can't afford an other one since I don't even have $1 due to some unfair tutelage measure, if I want to buy some food I have to give a paper to the local store once a week and that's it. No cash at all and of course no credit card.

Thanks for reading, I hope I can find out the problem since I really want to use Zorin.

1 Like

No sound: For some reason it got no sound at all. The sound icon isn't mute or anything and I tried several settings or just to use my laptop speaker instead of my external ones but nothing works. However I suggest it's linked to the second problem:

Hello. Lets take one thing at the time :slight_smile:
I need you to install an app that can tell more about your sound card

sudo apt install inxi
inxi -A

Please post output of the second command.
Also try to adjust alsamixer

1 Like

Thank you for your fast reply! :grinning:

Here are the results from the inxi command:

Device-1: Intel HDMI/DP LPE Audio driver: HdmiLpeAudio
Device-2: sof-bytcht rt5645 driver: SOF
Sound Server: ALSA v: k5.15.0-69-generic

As for the alsamixer I get this message "This device has no commands."

Also I couldn't really test audio since neither YouTube or local files can be played... even by using the Play button and even moving it the timestamp stays stuck.

1 Like

Gday @faputa17 , Welcome to the community!

You have a very low spec machine
1.3Ghz cpu
2G ram
32G ssd
please show the results here from this command

free -h

Can you also show the results from this

inxi -b

Hi @Ocka , thanks for your message and your warm welcome!

Yes I do realize that my machine is really low spec, before that I always got rather good machines, the last one had a i7 11th gen with 32 GB of ram, NVME SSD + huge HDD and great graphic card from Nvidia allowing me to play every game. But as I said things changed recently and now I can't even afford a $10 laptop even if I find one.

Besides I'm honestly surprised by how fast and good this machine actually is. Of course it's by no means as fast as my old one but for the specs I'm surprised it runs this well on either Windows or Zorin (except the weird things happening on Zorin).

Here is the result of free -h

It's in French however, but apparently for a total of 1,96i there is 1,36i used and 87Mi empty, 227Mi shared, 452 in tamp / cache and 164 Mi available.

Here is the result of inxi-b (this time in English for some reasons):

1 Like

Ah. We have had fun and games with this one before.
If you serach the forum using "sof-bytcht rt5645" as search term, you will find several threads, including:
"Asus T100HA audio not working"

Is that the error you see when typing alsamixer in terminal?

1 Like

Thank you for your message, glad to see a lot of people willing to help!

I will read the threads including the one you specified of course.

Yes for alsamixer I get this message "This sound device has no commands.", I can show you a screenshot but it's in French.

EDIT Someone on a Arch forum apparently got the same error, real English version would be "This sound device does not have any controls". I tried to read this thread just in case but it seems really hard. But maybe it's because it's Arch?

1 Like

In alsamixer hit F6 and select the sof-bytch sound card.
Then hit F5 to show All sound channels.
Post a screenshot.

1 Like

Sure, here it is. I already tried to select a different sound card several times this morning by the way (the sof-bytch was the first one I tried).

1 Like

Good. Now for all those channels marked [MM] unmute them by selecting and typing "M" and increase the volume level.

You have only shown part of the alsamixer display. See those blue arrows on right side pointing to more channels. Can you display screenshot of the whole thing.
Look there for [Auto-Mute] and [Loopback] channels and their settings. Have a play with those.

1 Like

Thanks again for your message.

Ah yes indeed, I noticed I could expand to more channels but there was so much of them I thought it was just some kind of infinite loop...
Here are the screenshots anyway.

I will try to look for the settings you told me.

your latest screenshots are with F3 channels and not All/Tout F5 channels listed. So there are even more than that.

Have a play with alsamixer. I'm afraid it is not always an exacting science trying to fix sound problems.

1 Like

Soooo... some update.

I tried to unmute every channel one by one but at some point there was a insanely huge "beep" coming from the laptop that never stopped until I turn it off by keeping the power button for a long time. Otherwise it kept beeping really really loud even with the headphone plugged in, plugged out or with the laptop muted.

So I decided to try a clean install (this time I checked the "third-party app" box but I still have the same problem).

However I noticed something weird: I still don't have any sound with internal or external speakers nor with headphones EXCEPT if I connect an external monitor. In this case the sound does work (on the external monitor only).
Even the video playback that was always loading is now working (with rather low quality / sluggish fps). But if I disconnect the HDMI cable no sound and no playback.

Oh also not sure it can help but the image on the monitor is cropped even tho it is set to 1920x1080 on Zorin and on the screen itsef.

1 Like

As a wild card, due to multi issue's run this command.
This may help with some issue's.

sudo apt update

sudo apt -y install ubuntu-restricted-extras


This may also resolve the networking,( no device found) as well.

let us know if this improves some issues ( video/sound/keyboard)

I found a specific link referring to your sound issue/loud noise. try this if you still have sound issue's after running the above commands.

You say you have some sound via HDMI connected monitor. That points to the HDMI soundcard.

I have just done a websearch using "intel HDMI/DP LPE Audio no sound ubuntu".
(You may wish to do the same or maybe add "ubuntu 20.04" to search term.)

One of the results seems similar to problem you are suffering and may be of interest: pulseaudio - No sound - Lubuntu 21.10 - Ask Ubuntu

I note from that case the user had working sound on Lubuntu 19.04, but not on later 21.04. (although ZorinOS 16 is 20.04). There may be a hint there.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.