Problems sharing external drives from Zorin computer to Windows computers

Hello, from an admitted new Zorin/Linux user! I have recently installed Zorin Core 16 on a laptop, using a new internal SSD. In general, things are working well. However...

I cannot successfully "share" any external USB-drives connected to the Zorin computer with Windows computers on the same Wi-Fi network. It should be noted that I CAN successfully share Zorin folders (from the machine's INTERNAL drive) to Windows computers, and access them...no problem at all there. But the Zorin computer's external drives (and their sub-folders) are denied access on Windows machines.

Windows computers DO see the Zorin computer's shared external drives/folders...but any attempt to access them is met with:

"Windows cannot access..." and "You do not have permission to access..."

I have verified that all sharing permissions are accurate, and I invoked a "change ownership" Terminal command, in case that was the problem.
(sudo chown -R michael:michael /dev/sdb1)

One side-note: I can connect external drives to a Windows machine and successfully access them on another Windows computer via Wi-Fi...but the Zorin machine doesn't see them. Nor does a Mac.

I've done a lot of searching online for an answer. So far, no solutions.

If anyone has thoughts or suggestions, I'd greatly appreciate the help.

Thank you!

If I understand your post, it is the Windows OS that lacks permissions to access, not Zorin OS, correct?
If so, assigning the permissions in Zorin is harmless, but will not allow Windows the permissions.
This is likely caused by Windows being unable to work with the ext4 format of Linux.

Here is a guide that offers a few options, one of which may be helpful to you.

1 Like

Thanks so much for your reply, and the information in the link you provided.

First, to answer your question: It does seem that my Windows computer lacks the permissions to access EXTERNAL drives connected to the Zorin. However, the Windows computer DOES successfully access shared folders from the Zorin computer's INTERNAL drive. Windows sees the Zorin external drives, but access to them is denied with messages that read: "Windows cannot access..." and "You do not have permission to access..."

It should be noted that the external drives connected to the Zorin machine (and perfectly accessible BY Zorin) were originally used on my Windows computers, and are formatted NTFS. So as a further test (and using my Zorin computer) I formatted one of my external drives as FAT (the same format as the Zorin internal drive) hoping that would make the external drive accessible by the Windows computer over the Wi-Fi network. Unfortunately, the results are the same: the FAT external drive is recognized by Windows, but access is denied...the same as with the NTFS external drives. The Zorin internal drive share to Windows IS successful.

So to recap: it seems that all my external drive shares from Zorin to Windows are failing, regardless of format type (FAT or NTFS) but the Zorin internal drive/folder share to Windows IS successful.

What is accounting for the difference here?

I appreciate any continued suggestions. Thanks again!

Are the external drives set up in /etc/fstab? If they are, it doesn't matter how many changes you make with chown or chmod, it will be set by the fstab.

Is your firewall on and configured? You may need to modify firewall settings to allow the connection (an idea though i don't think it's your issue).

Have you tried modifying the /mnt directory permissions to allow other to view/read? Are the window machines going to be performing writes to the drives? Then changing the /mnt other permission to allow writes may be helpful.

I'm not well-versed in Terminal commands yet, but hopefully, these findings answer your questions properly.

Right-clicking on the external drives and checking the Permissions tab shows "Me" to be the owner. "Group" and "Other" Access is set to "Create and delete files."

Under the Local Network Share tab, "Share this folder" is checked, as are "Allow others to create and delete files in this folder" and "Guest access (for people without a user account)"

These same permissions are set for the Zorin internal drive folders that DO properly share to the Windows computer.

My Zorin firewall is definitely off.

Ans yes, the Windows machine will ideally be performing writes to the Zorin shared external drive. I have verified that the Windows machine CAN write to the Zorin's shared INTERNAL drive folders.

If you have any other suggestions in solving the external drive access problem, I'd be grateful. Thank you!

Do you have samba installed? I found this in a search and thought it may help... it may not, but it doesn't hurt to try. networking - Accessing NAS drive in Ubuntu 20.04 LTS - Ask Ubuntu

And you may have to mount it detailing the fs for other computers to access it. Look at the ntfs mount command here.

Harvey, thanks for the info. Keeping in mind that my Linux/Zorin knowledge is still basic, I hope the following screenshots help to clarify things.

Yes, Samba (Smb4K) is installed. I did find the "network communication" warning message to be curious, and perhaps you can tell me if this may be the problem.

But to repeat a detail from my earlier posts, I am successful sharing any folder or file from the Zorin machine's internal drive...regardless of the Samba warning message. I'm including a screenshot of "successful" permission settings.

The third screenshot shows permission settings for a failed share. The settings are identical to the successful share. The external drive is definitely mounted...at least as far as I can tell! (An "Unmount" button sits to the right of the drive's name, suggesting to me the drive IS mounted.) Its files are definitely accessible on the Zorin computer. But not the Windows computer on the same Wi-Fi network.

Lastly, I wonder if the fourth screenshot may be a problem. There is a ghosted-out (unchangeable) option under "Media Sharing" and I cannot switch it to "On". Any clues as to this setting, and its potential relevance to the issue?

If Terminal commands are necessary, I'd appreciate some detail in how to structure them.

I thank everyone, for the continued suggestions!




In the last settings window, at the very top, where it says sharing.... would you turn the switch to the right of sharing on, then you will be able to modify the media sharing switch.

Until you get used to it, you will have to pay attention to the windows in detail to change settings. It isn't always in your face, and seems counterintuitive, but is similar to Mac... still can be easily missed.

I missed that detail! Thanks, Harvey.

Unfortunately, this didn't solve the sharing problem either. I turned the Sharing switch on (as well as the Media Sharing switch in the dialogue box), added several external drives and folders to the list of sharable resources, and still...access to those items is denied on Windows computers. They are "seen" by Windows, but are not accessible.

This is truly a mystery to me. I'm open to any other suggestions. Thank you.

Even after a reboot?

Did you check the permissions after enabling the shares? Sometimes a change like that will set the permissions to their default.

I did check permissions, and they remained intact. Here's an interesting NEW wrinkle: after enabling "Media Sharing" in the Settings options, folders and files from the external drive became accessible in Windows, but only as media files playable through Windows Media Player. They appeared in File Explorer, sometimes under the "Devices and Drives" section, sometimes under "Network locations"...and this morning, not at all, until I restarted the various computers.

We're working on a new theory that a discrepancy may exist between Linux and Windows Samba versions. The quest for a solution continues.

Thanks for the ongoing thoughts!

-mll

Try disabling the media sharing and checking if you can access the files. You may have to cycle the network connections, though the change should propagate without that step.

Unfortunately, that didn't work. Media Sharing, as it turns out, makes files/folders available to Windows as a "Media Device" but not as a "File Folder" type of resource. So close...but no cigar. Our efforts continue. Thanks for the thoughts!