Pxe-e61 media test failure check cable after just running (not instaling) Zorin 16.2 from live USB

Hello, I am new in the forum. I have been using Zorin for a long time, but just joined this site. I never had a problem with Zorin and that is great. However, this is the first time I have an issue and I think it is going to be minor. I do not have enough experience and that is what brought me here.

I have an old version of Zorin installed on a Lenovo X220. I wanted to try Zorin 16.2 via live USB. I went through the installation options but did not start the installation process. I shut down my laptop and removed the installation media, to return to my previous OS to backup some files and I got the error

pxe-e61 media test failure check cable

Note that I just changed the boot order in the BIOS and as I said, I did not start the installation when I was running the live USB. I tried resetting to the default configuration in the BIOS but the error persisted. Also, my hard disk is not failing because I am able to browse it through my live USB. I have read other similar questions but my case is different, because in most cases this happens after installation, and not by just running the live USB. Please help me. I need my previous OS working so I can backup my files before installation. Finally, I tried doing a backup with my live USB and Deja Dup but most of the files do not get backed up. It shows permission denied. Thanks in advance.

I'm not sure what this error is, but searching online it seems this refers to an error trying to boot from a media over the network. Make sure the boot order does not check for any network devices before the hard drive i.e., plugged through ethernet cable.

Yes, I removed the network device from the boot order. But the error is still happening.

Which OS is your previous OS?

You may need to clear CMOS:

My previous OS is Zorin 12.4.
I tried clearing CMOS through the BIOS but it is still trying to boot from the network. I even removed the network device (with "!") from the boot order, with no luck.

I think you can help me in two ways. By fixing the boot problem or by finding a way to do a backup of my files. If I can back up my files there is no need to return to my previous OS. I tried to back up with Deja Dup, but most of the files do not get backed up, apparently by permissions problems. I am trying to back up my home folder.

Is there a way to back up through the Live USB with any back up software? Since Deja Dup is not working properly, I tried to install Vorta but there is no space available. It seems that it cannot be installed when you are running the OS with a Live USB.

Did you clear CMOS, yet?

It looks for a networked drive when it cannot find your physical harddrive. If you adjusted your boot order and the error is still occurring, then it likely means that your hard drive is not being recognized.
I cannot fathom a way that running a LiveUSb would suddenly turn your hard drive invisible. It may just be the funny timing of things that an error on your hard drive appeared right when you booted something else.
If you can boot back into the LiveUSB, you may be able to use the disk management tools such as Gnome-Disks or Gparted to examine your hard drive or test it.

I edited my previous post.
Ok, I will check my hard drive for errors.

Backing up the drive:
If you can access the drive using LiveUSB or by removing the drive and plugging it into another machine, I would actually recommend against using a GUI backUp creator like Timeshift or DejaDup.
If your edition is 12.4 and you are moving to 16.3, that is quite a leap. Trying to solve Software from two editions back will be problematic. It really is personal files and data that gets priority for your needs. Even your home .config directory can be ignored since many of those configurations won't match the standards on 16.3 from 12.4

I would just go through the HOME directory and start with your desktop or documents folder and look through what you want to keep. If you want to keep everything, right click your ~/Documents directory and choose to Compress the file. You can compress it as tar.gz. Compression of a large directory can take a long time. But it would take just as long if not longer using a GUI backup tool - since compressing it is the first thing that it does, too. They usually then add their own markers or encrypt it...

Repeat this for Pictures, Videos, etc.
Make sure you reveal hidden files and look through your home non-hidden and hidden files. For example, since I use launchpad, I would save a copy of dput.cf from my home directory. You may have similar files. If not then, you are in the clear.
You may want to keep a copy of bash-history or wget-hsts.

You won't need to save copies of your bashrc or your xsession or .profile.

OK, thanks for all your suggestions. But what can I do with the files that show permission denied? For example, some PDFs have this restriction. I cannot backup or open them. Before this problem happened, I could access them with no problems.

So I found that by login as root from the terminal, I was able to open the files that previously showed permission denied. Then, I created a back up with Deja Dup, closed the Deja Dup GUI and started the back up from the terminal with sudo deja-dup --backup, to make sure that it had root privileges. But I got the following error.

Backup Failed
Failed with an  unknown error.

Traceback (innermost last):
  File "/usr/bin/duplicity", line 106, in <module>
  File "/usr/bin/duplicity", line 92, in with_tempdir
  File "/usr/lib/python3/dist-packages/duplicity/dup_main.py", line 1525, in main
    action = commandline.ProcessCommandLine(sys.argv[1:])
  File "/usr/lib/python3/dist-packages/duplicity/commandline.py", line 1175, in ProcessCommandLine
    globals.backend = backend.get_backend(args[0])
  File "/usr/lib/python3/dist-packages/duplicity/backend.py", line 225, in get_backend
    obj = get_backend_object(url_string)
  File "/usr/lib/python3/dist-packages/duplicity/backend.py", line 211, in get_backend_object
    return factory(pu)
  File "/usr/lib/python3/dist-packages/duplicity/backends/giobackend.py", line 82, in __init__
  File "/usr/lib/python3/dist-packages/duplicity/backends/giobackend.py", line 37, in ensure_dbus
    output = p.communicate()[0].decode("utf8", errors="replace")
 AttributeError: 'str' object has no attribute 'decode'

Please help. I am definitely running out of options.

I would recommend using the suggestions here;

OK, I did a manual back up with tar and after it finished, I got the terminal flooded with

Read error at byte x, while reading x bytes: Input/output error

File shrank by x bytes; padding with zeros

This happened with several files. Is this backup corrupted? If so, how can I fix these errors?

Those errors usually mean that a backup utility ran out of space for the snapshot.

How did you perform a Manual Backup that would produce that error?

Have you checked your disk space usage in Disk Analyzer?

I issued this command to do the backup

tar -czf /path/to/my/external/hard/drive/backup.tar.gz /folder/to/back/up

I removed the v flag to have only the errors being printed.
The folder with the files to backup is 59.1 GiB (before being compressed). I have 302.2 GiB free in my external hard drive.

I do not see anything wrong with your command. But yes, I agree those are corrupted and not trust worthy.

Perhaps try compressing smaller files at a time.
When I do it, I compress just the directories needed from Home Folder, not the entire home folder at once.

You were right. It seems that my hard drive is damaged. Somehow this happened when I was running the Live USB, so I thought that I ruined something when I was going through the installation options. But I actually did not change anything. It was merely a coincidence that the hard drive failed at that moment.

I realized this when I tried to open the files that had the read and file shrank errors. They are damaged both in the source as in the backup destination. I cannot open them. I checked the damaged partition with GParted and had no errors, but it took less than a second to do the check, so I wonder if it actually did something.

However, the command badblocks found 22252 damaged blocks so it is more likely that the disk is actually damaged. Now I regret myself for not doing periodical backups. I lost some of my files. Anyway, is there something I could do to repair the damaged sections and recover them? Thanks for all the help.

This is unlikely. Repairing is not so straightforward.
If there is physical damage to a disk - there is no repair. I would simply move the Good Files you want to keep to another drive manually. Then, if you feel inclined, you can try using DiskDigger to try to recovery data.
The Free version will gather everything as Unlabeled data. Sorting it out is nightmarish. So I learned to run it for One File Type at a time. Such as run it for just .docx then run for just .jpg - and so on.

This can also be caused by a loose ribbon cable.

You may also want to hook the drive up as a child (slave) and boot from the live usb to access it again.

The difference would be using an external port and adapter to read the drive.

You could also attempt another sata/ata/ide slot. Attach it after booting to the usb.

Either save your files to another usb or a spare drive. While web is also an option, it has more opportunity for corruption.

1 Like

Sorry for the delay. I think I am going to try this workaround but for the moment I am trying to install Zorin on a new laptop. I created a new topic because I had a problem.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.