Ralink RT3290 wifi intermittent - not the network or hardware


I'm new here and new to Linux so would be grateful for any assistance. I have exactly the same problem as here: Ralink RT3290 wifi not working which doesn't seem like it was solved unfortunately. Is anyone able to offer any advice?

I bought an second hand mini Acer desktop off ebay and have reformatted it using Windows 10 but always wanted to try Linux so have dual booted it with Zorin. Upon launching it works fine and I can use the internet, I have downloaded an application so I am not imagining that it works (lol) but then after a few minutes it stops working and won't work until I reboot or disable/enable the wifi adapter.

It works fine on the Windows partition so I don't believe it to be the hardware or the network and I have other devices using the wifi at the same time, including this laptop which is right next to the Zorin PC so has the same signal strength etc.

Help? :slight_smile:

This is one of those troubleshooting catch-22's, where so many factors can be checked, it can make your head spin.
You may check the answers here:

If you have already visited the other thread and not found anything helpful in it; the last suggestion really is to get new Wifi Adapter.
I know what you are thinking: "But it works on Windows." Yes. Windows is a billion dollar corporation with a large number of employees and resources. The Windows operating system comes with internet troubleshooter and diagnostics onboard. In addition to a graphical user interface, the diagnostics on Windows works in the background, bumping the signal to restart it when the net drops.
This software is not as present or prevalent in Linux. Partly because this is a bad idea... It can prevent a user from knowing when their hardware is falling into disrepair. On the surface, something bumping the signal to keep it active may sound like a nice idea. But when it is retrieving a weak signal, you are almost misled into thinking everything is fine when it is not.
Ability to know about hardware issues as they develop so you can plan ahead to purchase helps a lot.

1 Like

Thank you for your response. I will go through the suggestions in the link you have provided but I guess that unfortunately if there isn't a quick win with this then it does make sense to just use Windows instead! I will post back if anything works from the linked page :slight_smile:

There's also https://askubuntu.com/a/593018

1 Like

I fully agree.

1 Like

On the page you linked I started with this suggestion:
I had the the same problem with my RT3090 wireless card after upgrading my laptop from 14.04 to 16.04.

After some messing around, I discovered that the Wifi would only work after resuming from suspend.

I finally seem to have fixed the problem by adding the following to the file /etc/rc.local:

sudo ifconfig wlan0 up
sudo service network-manager restart


Which has actually worked when ran in the terminal!! Amazing!!! Now I need to figure out how to add it to the etc/rc.local thing it mentions!

I'm super pleased - thank you so much for your time :slight_smile:

1 Like

See this: No /etc/rc.local file on Ubuntu 18.04? Here’s what to do… – Server Administration – vpsfix.com Forum


Oh yeyyyy thank you I appreciate this so much!! :slight_smile:

1 Like

Glad to help. So it is up and running fine?

Yes after I did the steps I mentioned from the other post I turned it on the next day to perform the steps you linked and it was still working so I didn't need to do anything else apparently! Many thanks :slight_smile: