Ralink RT3290 wifi not working

I installed Zorin OS lite on my hp pavillion 2000 laptop. After installation, it worked quite nicely. However, I am having issues related to wifi connectivity. After connecting with my wifi, it works properly for 2-3 minutes. Then, my internet stops working. Although the laptop remains connected to the wifi(shown in the panel ) but internet doesn’t work. If I disable the wifi and enable it again, then it begins working again for another 2-3 minutes. Then the problem repeats. I need to disable and enable the wifi again and again to continue using internet. How can I solve this problem permanently?

Welcome to the forum joybhowmik
Could you please tell your Wireless Adapter information?
In terminal:

sudo lshw -C network

In the meantime, you might try disabling ipv6 and setting static ipv4.

sudo nano /etc/sysctl.conf

net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1

In terminal, use nano as a text editor:

sudo nano /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

When the editor opens, change “wifi.powersave = 3” to “wifi.powersave = 2”

1 Like

Here is the wireless adapter information:

*-network
description: Wireless interface
product: RT3290 Wireless 802.11n 1T/1R PCIe
vendor: Ralink corp.
physical id: 0
bus info: pci@0000:01:00.0
logical name: wlo1
version: 00
serial: 48:5a:b6:99:d5:81
width: 32 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=rt2800pci driverversion=5.4.0-47-generic firmware=0.37 ip=192.168.0.105 latency=0 link=yes multicast=yes wireless=IEEE 802.11
resources: irq:16 memory:c2510000-c251ffff
*-network
description: Ethernet interface
product: RTL810xE PCI Express Fast Ethernet controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:08:00.0
logical name: eno1
version: 05
serial: a0:1d:48:ff:69:2d
capacity: 100Mbit/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 firmware=rtl_nic/rtl8105e-1.fw latency=0 link=no multicast=yes port=MII
resources: irq:19 ioport:2000(size=256) memory:c2404000-c2404fff memory:c2400000-c2403fff

Some online solutions, but I recommend waiting for Aravisian’s response.

  1. https://askubuntu.com/questions/253632/how-do-i-get-a-ralink-rt3290-wireless-card-working
  2. https://webwiks.com/techcorner/get-ralink-rt3290-wifi-work-linux-distribution/

RealTek 3290 PCIExpress…
It’s a bit tricky since it does work when rebooted but not after a while. Normally, we would look to finding and installing the correct drivers. But that it works at first, implies the drivers and the Kernel are working together.
It sounds like the signal is falling apart the longer the card is used.

If this is a Notebook (laptop), not a Desktop PC, I would suggest checking the Hardware First Thing. If the case feels hotter in the area that the Network Card is, you may be looking at hardware failure. These two symptoms, signal loss with use and overheating- usually mean the card is on its last legs.
Not Always… so test and check… But be mentally prepared.
IF the Card is going out… Most folks just pick up a WiFi adapter like a TP-Link.

I the card is still good, there may be something else going on there we can try some fixes on.

Sorry for the late reply. I do have an usb wifi adapter. But how can I configure it in linux in a way that the internal wifi gets disabled and wifi then runs from the usb wifi adapter?
Lastly, I am using Zorin OS alongside Windows, so if I disable the internal adapter in linux, will it also get disabled from the windows part too? (N.B.: It works fine in Windows)

This depends on the drivers and chipset- how you install it. Many work out of the box, since they use the same drivers and chipset. If the device is well supported, this will happen and you will not need to do anything.
Otherwise, when you install the drivers, you then set the chipset of the WiFi device to autostart.

As above, you would not need to disable it, just prefer the other. But if you did disable it, this would effect only Zorin OS.

Hey bro, followed your advice and connected an external usb wifi adapter, no new drivers were needed, however, the same thing happened again. At first, the wifi was connected without any interruption but after a few minutes, the internet stopped working and I needed to disable and enable wifi again to connect to internet. Basically, same as before, is it any software issue or settings that I could try to change? Eagerly waiting for your reply.

I had a similar issue months ago. The net would slowly degrade and while showing me as connected, not actually connect. I got used to turning off and on the connection from my computer after trying many fixes. I happened to get a note from my ISP saying my router was getting old and they offered to provide a new one. I accepted and it arrived- I hooked it up.
I didn’t really think about it.

But that above problem went away with that action.

Honestly, I do not think any settings are involved. If if was Settings, then your settings would either connect and work or not connect and not work.
I think it is not the hardware itself because if it was, the USB adapter would have shown different behavior.
Is it software conflict, driver conflict, x conflict or kernel conflict? Yes, all of these are possible and diagnosing and troubleshooting is… tedious…

It may be as simple as using a different driver:

if the one you have works- but does not work well.

If may be that the firmware needs updating as I see in your OP that the configuration is rt2800pci and the firmware is rtl8105e.