Realtek ALC221 Audio

Hi there,

I'm back on Zorin and now have a driver issue with my onboard Realtek ALC221 Audio:

The output was working quiet well but the input hat noises that made it impossible to use.

Tried a lot!

went through that Ubuntu helpfile what just made my audio device appear as "Dummy output":face_with_diagonal_mouth:

Then at last set the ALSA conf modprobe (/etc/modprobe.d/alsa-base.conf) to the DELL model wich allegedly has same hardware ...

options snd-hda-intel model=dell-headset-multi

but that changed nothing :frowning:

Can anybody please help me on getting the Realtek ALC221 Audio on my HP 705 G1 MT work?

Neither input nor output is working at the momentimage

Thank you in advance ...


What were you using before? I've seen some weird stuff happen if certain steps aren't taken before installing Linux coming from Windows recently :grimacing: sound being one I've noticed..

before I used the drivers that came with the installation ...

Sound output was working OK but I could not use my microphone because of terribly annoying noises ...

Oh you were talkin about wich OS I was using , sorry!

I was on Manjaro wich is stil running on my Notebook.
But there I had issues after installing the MESA drivers from Git :joy:

No worries haha

What is the result of sudo dmesg | grep -i audio and lspci | grep -i audio?


I find it funny whatever comes! :stuck_out_tongue:
File or folder not found :sweat_smile: :joy::rofl:

no sorry!
Just had to replace the "and" with an "&" :wink:

1 Like

There should be more - definitely not loading a driver.

I also did some digging, looks like Manjaro is on 6.something - if you're all current with updates you should be on 5.15.0-87-generic. I'm willing to bet it's kernel version as it worked with Manjaro; given it is Arch based at that. I have another laptop that doesn't like anything below 6.x.x kernels.

I'm not exactly sure on the steps for doing that with Zorin, I'll have to step down here - I'm hoping someone that knows how to do this properly will see this. I have not played with kernels myself to give any steps :see_no_evil:

1 Like

Just can confirm that!

Am on 5.15.0-87-generic and all had been working on Manjaro, but please dont ask what Kernel version I used there! Just can say, that I did't have had any audio issues :wink:

But I also had it running fine on Zorin with audio before. But as far I remember I was led to install the alternative driver, wich no more happened since I installed Zorin again yesterday ...

Damn old hardware!
Only one issue after the other!
Hope y'all also followed some investment plans!
Me did and obviously can buy better hardware soon and hopefully never ever have to struggle with antique hardware problems again!

1 Like

I am about to try my luck with Chat GPT wich advised me to update the kernel

sudo update-initramfs -u

and then reinstall the sound-related packages:

sudo apt-get --reinstall install alsa-base alsa-utils pulseaudio linux-sound-base

... restarting ...

Lol Thats fun!

The AI had no solution and asked me to forward the issue to the Zorin community!

Here the transcript of performed steps that I hope will help one of you to get that solved:

please write a transcript that I can forward to the zorin community to help them understanding what steps were performed and didn't lead to a solution


Certainly, here is a detailed transcript that you can share with the Zorin community for further assistance with the "Dummy" output device issue on your HP EliteDesk 705 G1 Desktop running Zorin OS:


Issue Description: I am experiencing an issue with the audio output on my HP EliteDesk 705 G1 Desktop running Zorin OS. The system is only showing "Dummy" as the output device, and I have followed various troubleshooting steps but have not been able to resolve the issue.

Troubleshooting Steps Taken:

  1. Checked Sound Settings: Verified that the correct output device was selected in the sound settings. "Dummy" was the only option available.
  2. Checked Sound Card Recognition: Ran the aplay -l command, which did not list the sound card. This suggests a potential issue with the sound card detection.
  3. Checked System Logs: Ran dmesg | grep -i snd to check for any relevant system logs related to the sound card but did not find any clear indications of the issue.
  4. Reinstalled Audio Drivers: Reinstalled the audio drivers using the command sudo apt-get --reinstall install alsa-base pulseaudio to ensure they were correctly set up.
  5. Updated the Kernel: Updated the Zorin OS kernel to the latest version to ensure all necessary drivers were up to date, but the issue persisted.
  6. Checked ALSA and PulseAudio Configurations: Examined the ALSA configuration using cat /etc/modprobe.d/alsa-base.conf and the PulseAudio configuration using cat /etc/pulse/ No conflicting settings were found.
  7. Updated Zorin OS: Ensured that the Zorin OS installation was up to date by running sudo apt update && sudo apt upgrade to update all installed packages.
  8. Reinstalled PulseAudio: Reinstalled PulseAudio using the commands sudo apt-get --purge remove pulseaudio and sudo apt-get install pulseaudio.

Current Status: Despite performing the above steps, the issue still persists, and the system continues to show "Dummy" as the output device.

Request for Further Assistance: I would appreciate any guidance or insights from the Zorin community to help resolve this issue and get the audio output working correctly on my HP EliteDesk 705 G1 Desktop. If there are any specific steps or additional troubleshooting methods I can try, please let me know.

Thank you for your assistance.

Feel free to share this transcript with the Zorin community to provide them with a comprehensive overview of the steps you've taken and the current status of the issue. They will be better equipped to provide further assistance based on the information provided.

Obviously you're better than the AI :joy: :+1:

Thank you guys :pray:

1 Like

Doing a web search on this shows that this device has given a lot of people a lot of problems.
For testing, let's try adding the following parameter snd_hda_intel.model=alc221-hp-mic

sudo nano /etc/default/grub

Arrow key down to
Add in the parameter using right shift paste so it looks just like
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash snd_hda_intel.model=alc221-hp-mic"

Tap ctrl+o to overwrite, then enter key to save current configuration. Tap ctrl+x to exit the editor.
The terminal will revert to normal appearance; now you must run

sudo update-grub

for the changes to take effect.
Reboot and test.

1 Like

I didn't even think to ask: are you running with Secure Boot enabled or disabled?

1 Like

All steps performed:

... grub updated
... rebooted
... BIOS checked:
Secure boot is disbabled

Sound card is still on "Dummy-Output":

No sound :sweat:

The HP site shows HP Elitedesk to have "Realtek 2-channel ALC221 codec
" audio:

lshw only shows the Graphicards HDMI Audio:

here I'm sturck :confounded:

1 Like

BTW when I follow the HdaIntelSoundHowto

I get no Info about Intel nor Realtek audio from

cat /proc/asound/card0/codec* | grep Codec

I recommend restoring grub to "quiet splash" for now, then.

While you are in the terminal, lets check some things;

sudo apt update && sudo apt full-upgrade

killall pulseaudio

rm -r ~/.config/pulse

sudo apt install --reinstall pulseaudio alsa-utils

Launch AlsaMixer from terminal:


Please post a screenshot.
You can use the F6 key to change your hardware source.

1 Like

Error opening the mixer device: file or directory not found

no application found

The alsamixer is part of alsa-utils.
Did you run the command from up above:

sudo apt install --reinstall pulseaudio alsa-utils

1 Like

I would try following my SoundBlaster guide by blacklisting the HDMI element. Also have you installed all Codecs, such as SOX? Best using Synaptic Package Manager to see/view all codecs. :wink:

Also try this. Elevate yourself to root and in /etc create a folder and name it 'pulse off' - then drag the 'pulse' folder into the newly created 'pulse off' one. Now using Synaptic Package Manager (available from the Software Store/Channel) and search for all ALSA packages - install everything but not JACK or OSS packages. Install all the QAS packages, especially 'mixer' and also the alsa-pulse plug-in needed to hear streaming audio.

{How I miss the old days when getting sound to work was reliant on tweaking OSS (Open Sound Software) and choosing the correct Bitrate for the soundcard to work! :joy:}


OK sorry that was my misunderstanding!
the message "Error opening the mixer device: file or directory not found" points to a non-found device wich is logic as a "Dummy Device" is just a placeholder for a device :wink:
So alsamixer is installed but cant be started as the Device was not found :grin:

"sudo apt install --reinstall pulseaudio alsa-utils" has no use ...

OK I'l go through this tomorrow as in my state I need sleep before I can think about doin things that could have wrong effect when done wrong,

But pls dont mind, I will follow on that tomorrow an re-edit this answer post to give an answer on hot it succedwd ... thX in advanvance for ur try :heartpulse:

1 Like