Realtek RTL8821 network adapter unstable

Hi, I just installed Zorin on my new W11-laptop as a dual-boot and that went perfectly fine
But there’s a problem with my network-adaptor, I can go online, but I have to load every page twice, sometimes more than that and:

every time I open the Software-section the connection fails completely, there is no way to get updates or install any kind of software.

When i tried Zorin from an image using ventoy there was no problem with the networkadapter whatsoever, it worked every time.

I have Zorin 16.3 Core

The wifi-icon switches states all the time, filled, empty or with a question mark.


What have I tried so far?
I did thorough searches for solutions (I am a Linux-Noob) and tried the most likely-to-work:

  1. With sudo rfkill list all
    I have seen tthat there are no blocks on anything

  2. With lsmod | grep asus
    I could see that the asus_nb_wmi module was loaded, só I did:
    echo "options asus_nb_wmi wapf=1" | sudo tee /etc/modprobe.d/asus.conf
    and restarted the system, but no change.

Now: I have found many other possibilities to try but I think it’s better to first ask, before I mess up the whole system...

Info:
The software and updates-section / additional drivers-tab does show the right network adapter but says “the device is not working” and the option “Do not use the device” is selected by default. When I select the option “Using DKMS source etc.” the screen hangs.

With sudo lshw -C network
I get:

*-network
description: Wireless interface
product: RTL8821CE 802.11ac PCIe Wireless Network Adapter
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:02:00.0
logical name: wlo1
version: 00
serial: 10:68:38:01:11:5f
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=rtw_8821ce driverversion=5.15.0-78-generic firmware=N/A ip=192.168.1.103 latency=0 link=no multicast=yes wireless=IEEE 802.11
resources: irq:154 ioport:3000(size=256) memory:84000000-8400ffff

Anyone who has the golden-tip for me? I would to get going with Zorin, it’s my number 1 choice

I have included some screenshots



1 Like

Do you have Secure Boot enabled in your BIOS Settings? It is known to interfere with this wifi driver.

If it is disabled, connect using Ethernet or your Phone Mobile Hotspot connected via USB cable.
Once connected to a stable connection, please run

sudo apt install --reinstall rtl8821ce-dkms

sudo apt update && sudo apt full-upgrade

Reboot and test.

One other thing, change your pkg source list from your Country's server and change it to Main Server after you have followed Aravisian's advice.

Or before in order to ensure that "apt update && apt upgrade" command retrieve packages from the Main Server rather than the regional server.

1 Like

Thank you both, I am still struggling to get a stable connection, I can connect with my phone-hotspot but it's on an off also and I can't get aravisians first command to run without errors, says it can't connect to ubuntu... etc. I need to find a way to get a secure connection, but I am out of ideas at the moment.

So back in Windows again to be able to let you know that I am working on it and also that I am very pleased with your quick answers and that I am trying hard at the moment to work something out.

Now that I have a stable connection in Windows, can't I download the right driver-files somewhere and load it into Zorin with a USB-stick or from the external HDD (where ever I save them). Or is that not possible?

Anyway: I'll sure be back!

Does your BIOS have CSM to allow you to choose between EFI and Legacy Boot? Can you provide us with model of Asus Notebook?

1 Like

That is unusual... You are not in a bit of a Faraday cage, are you?
You have the same symptom with signal loss on WIfi and on Hotspot which are utterly different providers. And your system shows you as having the driver already installed...

It's an AsusVivobook x515ea_F1500ea

|Processor|11th Gen Intel(R) Core(TM) i3-1115G4 @ 3.00GHz 3.00 GHz|

|Geïnstalleerd RAM-geheugen|8,00 GB (7,70 GB beschikbaar)|

Zorin is on a 100gb partition

Btw: safe boot and fast boot are off

I am not sure about that BIOS-question...

Right, back online using Zorin ánd the wifi-connection.
I have been a bit silly: when I configured the phone as a hotspot I had to turn wifi off or it would't do that. So I did. But silly me did not realise that I could put it back on again after establishing the hotspot-connection with my laptop and some things díd work but very slowly and unstable (I guess I was on paid-internet at that time...).

I tried in Windows and it worked perfectly ánd automatically switched on wifi on the phone again giving me a fast and steady connection...

So: back to Linux, ran the commands and the magic happened,strangely don't have full signal but 1 level less than full but I believe it's fast enough.

Now I am gonna find out that other thing, changing the source list to Main server, I think I have a pretty good idea where to do that.....

But lots of thanks to you both, I am happy, that updating was pretty exciting btw...

Now I am all good

1 Like

A refresher: Software & Updates application.:wink:

If this is a notebook computer, you also might disable powersave for Wifi to ensure that your signal is not interfered with to preserve battery:

sudo nano /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Change the contents to 2:

[connection]
wifi.powersave = 2

Tap ctrl+o to overwrite, then tap enter key to save current configuration. Tap ctrl+x to exit the editor.

1 Like

Everything done! Still no full signal but it's pretty fast,I don't have any problems with this.

Many thanks, this was very good support!

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.