Realtek USB NIC not found by Zorin

Hello!
I am trying out Zorin OS Core on a Win10 desktop. The installation went fine, except I have a Realtek USB NIC to connect to the internet. Zorin does not recognize that it is there. Any suggestions on how to fix this? The model number is: 8821CU. It is an 802.11AC NIC.

Thanks!

1 Like

Real quick, is SECURE BOOT & FAST BOOT disabled?

sudo apt update && sudo apt install -y dkms git

If you are asked to choose a provider, choose Ubuntu 21.10

mkdir ~/src && cd ~/src

git clone GitHub - morrownr/8821cu: Linux Driver for USB WiFi Adapters that are based on the RTL8811CU, RTL8821CU and RTL8731AU Chipsets && cd ~/src/8821cu

sudo ./install-driver.sh

Source:

1 Like

This sounds something from script of "The IT Crowd", but have you tried unplugging then reinserting the USB NIC?

1 Like

Wouldn't hurt thats for sure!

I have seen strange weirdness before with USB drives, even in Windows way back in the day. Where you plug something in, and it install drivers, but nothing happens after that. After unplugging, and replugging it in, wala, pops up, now can use.

Sometimes my Canon camera does that on my Linux distro of POP OS. I will plug it in, nothing happens, no camera storage pops up in interface. Turn off and on again, oh suddenly now its there! Weird!

Hello! Thanks for the quick reply. Sorry I could not get back to you earlier. I did have Fast Boot enabled so I disabled it and tried again. No change...

Thanks for the suggestion though. :blush:

Ha Ha!...I tried doing that just now...No change. Zorin does not see the NIC... :frowning_face:

Looks like this might help. Where can I get step by step instructions on how to install this?

Thanks!

Oh well, worth a try. Did you take a look at @Aravisian 's reply post #3 above?

Wait a minute! I just read further and saw some instructions on how to do this. I will give it a try and let everyone know.

Hello again!

I am continuing to have network connection problems..:frowning: I brought my machine out to my router and did a regular network connection and Zorin did not recognize this connection either.

Looking around, I don't see any "device manager" (like windows) so I don't see what Zorin thinks my NIC card is, nor do I seen any way to reconfigure my system to find the correct card.

Being unable to connect to the internet is going to be a major problem for me to overcome.

The NIC card is an Intel 82567LM-3 Gigabit network card. I think it is part of the motherboard.

What do you recommend I do next?... :blush:

You can try installing cpu-z or cpu-x

In terminal, you can run inxi or lshw to glean pretty much all in-depth hardware information you want.

Everything I check shows support for this device beginning in kernel 5.4.
I wonder if the 5.11 kernel has a regression on this driver. We can test this easily by installing and running the 5.8 kernel and seeing if that works.

sudo apt install linux-headers-5.8.0-63-generic linux-modules-extra-5.8.0-63-generic linux-modules-5.8.0-63-generic linux-image-5.8.0-63-generic

Reboot and tap the esc key at the Motherboard Splash Screen and choose Advanced Options for Zorin at the Recovery Menu.
Arrow key down to Zorin on the 5.8 kernel and boot from it.

Test internet.

If this does not work, then rebooting will put you back on the 5.11 kernel. We can see if Linux-Firmware helps. You may need to install the Motherboard Firmware Update.

I think I am going to have to take the plunge and install Zorin in order make this change. I ran the "Sudo" line in the terminal and it completed normally. But I did get this message at the end. "update-initramfs is disabled since running on read only media."

Then I rebooted the PC and went into the reboot options. I did not see any advanced options in the reboot menu and when I selected the USB install drive the PC locked up...:frowning:

When I rebooted again and loaded Zorin the normal way, I did not see any advanced options there either. So I continued with the load from USB option and there was no change.

If I install Zorin (dual boot), I should be able to do this command again and then it will stick? Or do I have to do some other process to complete this?

Thanks for your assistance!

I misunderstood this to mean that Zorin OS was installed.
Yes, the above tips are for an installed system - rebooting the LiveUSB will reset the default Demo, not saving any changes.

@TomN Note that "reset" even applies if you had set persistence on your Live USB. There is a known problem with persistence on Ubuntu 20.04, and so Z16.

Zaba, you may have noticed some of us freaking out about Ventoy.

I might suggest you try it out... And check out its Persistence on Zorin 16. It may be a worthwhile project. :wink:

1 Like

So, my question is; if I install Zorin 16 core on my PC, what do I need to do to go back to the 5.8 kernel? Will the instructions Aravision suggested work or should I do something else?

1 Like

Yes.

And if they don't, it is FrenchPress' fault.

Ok...I have been thinking about this problem of connecting with my current USB WiFi card and I was wondering if it would be simpler to purchase a different WiFi card. Is there a list of cards that Zorin supports out of the box? Where would I find it and/or how should I look for one?

When in doubt, throw money at the problem... :blush:

1 Like

Yes it would be simpler and I can almost guarantee you 100% that it will work. But I won't put my foot in my mouth an say 100% lol. Let me get you a link to a powerful WIFI adapter that I think you will like...

This one is better in the sense that the cable gets the adapter away from your other USB ports and computer itself, providing you a little more flexibility.

If you prefer something smaller, more compact, but still fast, there is this options...

If you want the smallest version for the most compactness and portability, there is always this. But I warn you its slow, your not going to stream 4K content with this puppy!

2 Likes