Replacing Gnome software with an alternative?

I like having a software store, it makes it easy to find some apps or try out new apps that I didn't even know existed. However, with the buggy mess the gnome software store is, I prefer to avoid it as much as possible, using the terminal for updates and synaptic for installing native packages. However, I'd still like to have something that looks and behaves like gnome software (but with less bugs) so I can sometimes go and try out new apps and see if they are better than what I currently use.

So my question before doing anything that might break my zorin installation: is it possible to completely replace gnome software with a different software store without anything breaking?


You could try elementary OS's software center (app center if I recall it correctly). But you don't need to remove Gnome Software Center.

EDIT; Here it is: GitHub - elementary/appcenter: Pay-what-you-can app store for elementary OS

thanks for the suggestion, but one of the dependencies seems to be meson 0.56.0 and I can't seem to find a way to update the 0.53.2 version that comes pre-installed

I forgot to specify, but I did find it and download a newer version of it. The problem comes when installing it, since the steps are not working for me (or maybe I'm getting confused on something)

Here is a .deb file you can use:

You may need to first install Ninja:

sudo apt install ninja-build

Then double click the above downloaded .deb file to run it.

1 Like

Firefox warns me saying the file is unsafe when trying to download it, something that never happened with any other .deb file before. I'm guessing it is a false-positive? Looking at the link, that does seem like an official ubuntu repository but it's the first time I get this kind of warning with deb files so that got me overthinking for a second

uhh... yes. I have no idea why Firefox would report that.

1 Like

That fixed the error that said I was on an older version. However, now there's another error saying something about "valac"

Build started at 2023-09-18T19:16:51.367792
Main binary: /usr/bin/python3
Build Options: -Dprefix=/usr
Python system: Linux
The Meson build system
Version: 0.61.2
Source dir: /home/juanjose/Descargas/appcenter-7.3.0
Build dir: /home/juanjose/Descargas/appcenter-7.3.0/build
Build type: native build
Project name: io.elementary.appcenter
Project version: 7.3.0
Sanity testing C compiler: cc
Is cross compiler: False.
Sanity check compiler command line: cc sanitycheckc.c -o sanitycheckc.exe -D_FILE_OFFSET_BITS=64
Sanity check compile stdout:

Sanity check compile stderr:

Running test binary command: /home/juanjose/Descargas/appcenter-7.3.0/build/meson-private/sanitycheckc.exe
C compiler for the host machine: cc (gcc 9.4.0 "cc (Ubuntu 9.4.0-1ubuntu1~20.04.2) 9.4.0")
C linker for the host machine: cc ld.bfd 2.34 ERROR: Could not execute Vala compiler "valac"

It created this log as a txt file, the error that the terminal showed is the same as the log but with less details

Try running

sudo apt install valac

Then try running the .deb self-installer.

the problem with valac was fixed, but then it still would not work. I've tried manually searching and downloading all the dependencies (most of them were not installed or the zorin repositories had an older version than what I needed) and now I got stuck again at the libgdk2.0-common dependency, which on gdebi it just says:

Error: The dependency <<libgdk-pixbuf2.0-common>> breaks the package <<libgdk-pixbuf2.0-0>> (=2.40.0+dfsg-3ubuntu0.4)

There's a chaos of dependencies in this

Granite needs to be on a newer version for meson to be able to build this program, the newer version of granite requires the dependency libgranite6 on the same version, libgranite6 requires the dependency libgdk-pixbuf2.0-0, and that also needs the dependency libgdk-pixbuf2.0-0-common, which cannot be installed because it would break a package that is already installed

To be fair, some the packages said on ubuntu's packages website that they were for ubuntu 22.04 LTS, and isn't Zorin based on ubuntu 20.04? If I had to guess, maybe that's causing some kind of compatibility problem

Yes, this is quite the rabbit hole. I would say that this is not working out. You are going into dangerous territory at this point.

Yeah, I think I am just gonna stop trying. If the newer version of gnome software that zorin 17 comes with is as buggy as the one we currently have, I'll try again. But for now I think it'd be best to stop

1 Like

You can even use GNOME Software but if you don't want to download stuff directly from there you can click Website under the software description to open the original software page on your browser and download it.

1 Like

I don't think you need KDE (Plasma) installed. Take a look at 'apper' which should be in Synaptic Package Manager:

I found it to be better than KDE's flagship Store, Discover, which can be buggy.
Installation of Apps and Updates much faster in Apper than in Discover!


I gave it a try and it seems to do it's job pretty well: haven't gotten any stability issue (yet), it's intuitive and tells exactly where something is coming from. The only problem I see is that the section icons on the main page don't load, but I'm guessing that's something about using a kde app on cinnamon; something similar happened when I gave discover a try, but that's not a big deal. Other than that, it seems good enough and I'm gonna keep it for now. Thanks for suggesting it!

1 Like

Which are the "section icons"?

I just tried this out...
The Spark Store cannot be installed due to an un-satisfiable dependency on libdtkcore5 greater version than 5.4... which... is not even available on Ubuntu 22.04, much less 20.04.
I could install the CLI console version though.

But it only prints in Japanese.
I cannot speak Japanese.

So I removed it.

I show my ignorance glaringly. Was it in Chinese?

I am abashed.

I can only say... Many users should look very carefully into the history and current standing of Deepin, Deepin Store, Deepins EULA (yes... they have one that is required) and make their own determination as to whether to not just trust anything Deepin related, but whether they want to show any support to such an entity.