Replacing grub bootloader with systemd-boot bootloader in Zorin OS 16.2

Actually, after installing zorin os 16.2 on my dell inspiron 3593 i am facing issues in grub boot. "Minimal bash like line editing is supported " when i reboot my pc everytime i am getting this error so , when i press f12 and go to bios and than restarts my pc than again i am getting this error i have to repeat this steps 2-3 times than only i can see zorin os grub bootloader menus and i had installed zorin os on a separate ssd and i have two disk one is hdd and one is ssd. I installed zorin os replacing the windows 11 so currently in my pc i had only one operating system that is zorin os 16.2 core version. so after doing lots of research and applying lots of solution to this error i come to know that the issue are with my system firmware version 1.25.1 not able to read or find grub bootloader files in ssd disk ( i had set installed zorin os on ssd and boot priority set to first ). so i noticed that this problem only encounter when there is grub installed and trying to boot grub bootloader. so i removed zorin os and than installed pop os 22.04 LTS ( which don't uses grub bootloader by default , it uses systemd-boot bootloader by default ) and it is running fine without showing any boot errors. so i think i am able to explain my issues to this forum so if anyone please help me to solve this error. And if anyone can help me with replacing grub bootloader with systemd-boot how to do this and one more question does zorin os will supports systemd-boot ??

This is the disk where currently zorin os is installed.

Please see this thread here:


Thanks for the reply and giving me the solution but i had tested this method with zorin os 16.2 , but it doesn't work for me and the grub error "Minimal bash line like editing is supported " is still always there that's why i want to replace grub with system d-boot. if the issues was just speed of boot time than that is not an issue,grub also boots the os fine but the issue that i am facing is different.

What are you doing in the bios are you doing to remove the error? Have you tried boot repair?

Can you please type exit at the Minimal bash line like editing is supported warning and relay what the terminal tells you? May need to find the cause to solve your issue instead.

yes i am trying to remove the error i had done every solution to fix this error and in the bios boot priority is set to first and also i using zorin os as a single os no dual boot but again and again the error comes. yes i had tried boot repair also but this doesn't fixes the issue

After typing exit in the Minimal bash line like editing is supported warning and after typing exit diagnostic screen appears and start scanning my pc hardware to find bootable devices.

You said you are able to boot the machine into Zorin?
Or it cannot boot at all?

In your BIOS Settings, are you set to AHCI or to RAID?

yes that's what i am saying i am getting error always but after rebooting 3-4 times i get the grub boot menu options also that is the issue my system not able to load grub boot files sometimes maybe there is some firmware or hardware compatibility issues , i am not sure about it. and i am running single os with AHCI sata operation i bios with secure boot disabled.

It sounds like it only sometimes sees the bootable device, correct?
Have you checked the SATA cable?

yes correct , it only sometimes sees the bootable device and i am using laptop , also i don't have much technical experience but i had done hardware disgnostic test on my dell inspiron 3593 laptop there is no issues found on that.

It appears that many people have this problem on that particular machine. One poster suggested it may be an issue with TPM...
This clearly is a standing bug.

Thank god i am not alone who is facing the same issue , actually this seems right , it is a bug specially for dell inspiron 3593 or any other inpiron series but what is the solution for that ???

And this error only comes when there is a grub involved , i had tested this on ubuntu 22.04 LTS and zorin os 16.2 core. Then i tried to install pop os which don't uses grub bootloader that works fine boots without showing any error that issue is related to grub and inspiron 3593.

Can you please suggest some best linux distros that don't uses grub bootloader as their by default installation for new user.

Aside from POP_OS, I would also need to search the web to learn which others might. But first - have you tried using Legacy boot in your BIOS settings? You might try Gummiboot, but really, as this is the only installed OS On the machine, using Legacy is likely to resolve the issue (Legacy only allows up to four bootable devices), I think and you needn't worry about EFI troubles.

But dell inspiron 3593 comes with only uefi mode only in bios i can't change it because legacy is not supported. And gummiboot ( systemd-boot ) bootloader i tried to install it but i think zorin os 16.2 is not supported for gummiboot.

It is supported - but gummiboot has also never been an easy install and configuration.
I have not even fully performed it myself... So I am hesitant to offer detailed advise. But there are many guides on the web. Just search for "How install gummiboot Ubuntu 20.04".

But in the bios boot menu it is showing me only ( uefi mode only , legacy is not supported ) and i have done search regarding systemd-boot bootloader which is the new name of gummiboot , both are same and pop os uses systemd-boot. But ubuntu doesn't support this i had tested on it, what i had done that i try to remove grub bootloader and add systemd-boot , with all the cofiguration files but after doing so ubuntu doesn't able to works properly and it starts crashing or becomes unstable. Maybe i had done something wrong during the changing process of bootloader but it is quite a difficult or a challenging task to do.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.